nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   275.09.07 I no longer have /usr/include/vdpau files (http://www.nvnews.net/vbulletin/showthread.php?t=163589)

geisj 06-17-11 07:15 AM

275.09.07 I no longer have /usr/include/vdpau files
 
After installing 275.09.07 on linux centos 5.6 I no longer have any files in /usr/include/vdpau.
My previous version was 256.35 and they are in this build.

Matter of fact I dropped back to 256.35 and re-installed and they come back.

I then re-installed 275.09.07 again and the files are removed.

I install with "sh NVIDIA-Linux-x86_64-275.09.07.run -s"

How do I get vdpau.h and vdpau_x11.h with the new version.

Jerry

ioni 06-17-11 07:26 AM

Re: 275.09.07 I no longer have /usr/include/vdpau files
 
libvdpau is available for a long time

geisj 06-17-11 07:44 AM

Re: 275.09.07 I no longer have /usr/include/vdpau files
 
There might be a libvdpau I did not look for that.

However, If I am compiling gstreamer and those libraries
I would think they would be looking for vdpau.h . This is the
file I "think" I need . How can I get it so all my other programs
compile and use VDPAU.

Jerry

ioni 06-17-11 07:53 AM

Re: 275.09.07 I no longer have /usr/include/vdpau files
 
Quote:

Originally Posted by geisj (Post 2446200)
There might be a libvdpau I did not look for that.

However, If I am compiling gstreamer and those libraries
I would think they would be looking for vdpau.h . This is the
file I "think" I need . How can I get it so all my other programs
compile and use VDPAU.

Jerry


libvdpau has a pkg-config file and is used to get all the include path. your programs will compile file against libvdpau. libvdpau is not new, exists for couples of years now and almost all multimedia apps can use it without any problems

kwizart 06-17-11 08:09 AM

Re: 275.09.07 I no longer have /usr/include/vdpau files
 
It's provided by the EPEL repository for RHEL and derived.
yum install libvdpau-devel

It's included by default on fedora since fedora 10.

Ahmad Samir 06-17-11 07:40 PM

Re: 275.09.07 I no longer have /usr/include/vdpau files
 
The VDPAU headers aren't shipped in the .run since 260.19.04 c.f.: http://www.nvnews.net/vbulletin/show....php?p=2314331

Previously, they had announced that the headers won't be shipped any more since distros should provide the libvdpau package in their repos (most distros have it already AFAIK): http://www.nvnews.net/vbulletin/showthread.php?t=138880


All times are GMT -5. The time now is 01:51 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.