nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Screen does not sync when un-plugging and re-plugging (http://www.nvnews.net/vbulletin/showthread.php?t=163604)

fdelache 06-17-11 03:26 PM

Screen does not sync when un-plugging and re-plugging
 
1 Attachment(s)
Hi all,

I have a Gentoo system with a Quadro 4000 card and two monitors connected on DisplayPorts.
When I un-plug a monitor from the DisplayPort outlet and re-plug it, my monitor never syncs back.
I need to restart the XServer for the monitor to sync again.

I compiled the nv-control-dpy tool to get more information.
Here is the output of the command nv-control-dpy --probe-dpys when one of my monitor is un-plugged:
Quote:

Using NV-CONTROL extension 1.25 on :0
Connected Display Devices:
DFP-1 (0x00020000): DELL U2410
DFP-2 (0x00040000): DELL U2410

Display Device Probed Information:

number of GPUs: 1
display devices on GPU-0 (Quadro 4000):
DFP-1 (0x00020000): DELL U2410
DFP-2 (0x00040000): DELL U2410
As you can see, the card still detects both monitors even when only one is connected.
Is there any specific configuration in the Kernel or xorg.conf that needs to be done in order to get the monitor sync correctly when I plug it back?

Thanks a lot.
Franck

fdelache 06-20-11 11:13 AM

Re: Screen does not sync when un-plugging and re-plugging
 
Ok I found out that the issue I had with nv-control-dpy not reporting the loss of a monitor was due to an Option I had in my xorg.conf file:
Quote:

Option "ConnectedMonitor" "DFP-1,DFP-2"
If I remove this option, then when I unplug my monitor and run the command nv-control-dpy --probe-dpys, it returns:
Quote:

Using NV-CONTROL extension 1.25 on :0
Connected Display Devices:
DFP-1 (0x00020000): DELL U2410
DFP-2 (0x00040000): DELL U2410

Display Device Probed Information:

number of GPUs: 1
display devices on GPU-0 (Quadro 4000):
DFP-1 (0x00020000): DELL U2410
If I run the command a second time, I then get:
Quote:

Using NV-CONTROL extension 1.25 on :0
Connected Display Devices:
DFP-1 (0x00020000): DELL U2410

Display Device Probed Information:

number of GPUs: 1
display devices on GPU-0 (Quadro 4000):
DFP-1 (0x00020000): DELL U2410
Unfortunately, when I plug my monitor back it still doesn't sync.
Any Idea?

Thanks.
Franck

fdelache 06-23-11 03:58 PM

Re: Screen does not sync when un-plugging and re-plugging
 
I found out that if I use Ubuntu 10.10 rather than Gentoo then the issue is not present.

As I have to stick to Gentoo, I want to know what are the differences between Ubuntu and my Gentoo installation. Any idea where this might be configured (Kernel option, ACPI, any other daemon...)?

Thanks


All times are GMT -5. The time now is 02:54 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.