nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   EN210 silent driver problem with Scientific Linux 6 (http://www.nvnews.net/vbulletin/showthread.php?t=164249)

redman 07-09-11 12:35 PM

EN210 silent driver problem with Scientific Linux 6
 
Yesterday I bought components for a new system including the Asus 210 Silent videocard (1GB DDR3 memory). After building the system I installed Scientific Linux 6 (x86_64) on it and the Linux x64 (AMD64/EM64T) display driver version 256.53 (as suggested on the Nvidia Download Driver page. It all seemed to work fine except than on several occasions the graphical display (X-server) seemed to reboot/respawn without cause presenting me the Gnome login screen. Unfortunately the logfiles didn't give any clue as what happened.

After some trying I found a way to reproduce the problem. By booting into runlevel 3 and starting X by hand I found that by starting "glxgears" and grabbing the glxgears window (showing the rotating wheels) and moving it around quickly I found several "errors" in the logfiles (glxgears died with a "segmentation" error).
Code:

Jul  9 15:15:00 Yavin kernel: glxgears[2116] general protection ip:33cb63aabd sp:7fff58cbaa70 error:0 in libX11.so.6.3.0[33cb600000+139000]
Jul  9 15:15:20 Yavin kernel: glxgears[2120] general protection ip:33cb63aabd sp:7fff3b2447f0 error:0 in libX11.so.6.3.0[33cb600000+139000]
Jul  9 15:15:28 Yavin kernel: glxgears[2121] general protection ip:33cb63aabd sp:7fff577178f0 error:0 in libX11.so.6.3.0[33cb600000+139000]
Jul  9 15:15:43 Yavin kernel: glxgears[2122] general protection ip:33cb63aabd sp:7fff35df28c0 error:0 in libX11.so.6.3.0[33cb600000+139000]
Jul  9 15:15:58 Yavin kernel: glxgears[2123] general protection ip:33cb63aabd sp:7ffff55035d0 error:0 in libX11.so.6.3.0[33cb600000+139000]

When I disabled the Nvidia driver and ran the default driver the glxgears-test didn't cause any problem.
This leads me to believe that the problem lies with the Nvidia driver.
Since the driver is from august last year, could it be a mismatch with Scientific Linux 6 (a rebuild from Red Hat Enterprise Linux)?
RHEL (and all the clones including Scientific Linux) do not come with their own Nvidia driver (except the default nv driver). So I need to use the one from Nvidia or any of the 3rd party repos (which wouldn't be my first choice).

There seems to no newer driver for the EN210 Silent card.
Of course I tried the latest 275.09.07 driver, but alas, no improvement.

I wondering if there is a solution or should I replace the card with one that is supported by the 275.09.07 driver (like the 9500GT I'm using without any problem) ??

darksky 07-09-11 01:25 PM

Re: EN210 silent driver problem with Scientific Linux 6
 
What are the temps of your card? Is it a thermal problem?

Code:

$ nvidia-smi -q -d TEMPERATURE

redman 07-09-11 01:59 PM

Re: EN210 silent driver problem with Scientific Linux 6
 
No, the problem can be reproduced as soon as I log in. As a matter of fact, when I opened the terminal and tried to resize that window the respawning occured. So I logged in and checked the temperature by using the "Nvidia X Server Settings" (since the command you mentioned didn't work) and the temperature was 37 - 38 degrees.


All times are GMT -5. The time now is 08:47 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.