nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Error! Linux cannot find my nVidia integrated sound card! Please help! (http://www.nvnews.net/vbulletin/showthread.php?t=1644)

targatop 09-08-02 01:08 PM

Error! Linux cannot find my nVidia integrated sound card! Please help!
 
When I install the NVIDIA_nforce-1.0-241 rpm package for my Linux Distro (RH 7.3, Kernel 2.4.18_3) it appears to install fine, but my sound card does not show up. However, my ethernet card works.

So I uninstalled that RPM and went and got SRPMS (I have all my kernel source/headers installed). Those error out and say:

In file included from i810_audio.c:74:
/usr/include/linux/delay.h:1323: asm/delay.h No such file or directory
i810_audio.c:85:30: linux/ac97_codec.h: No such file or directory.
i810_audio.c:87:25: asm/uaccess.h: No such file or directory.
i810_audio.c:88:25: asm/hardirq.h: No such file or directory
make[1]: *** [i810_audio.o] Error 1
make[1]: Leaving directory '/root/nforce/nvaudio'
make: *** [all] Error 2

Any suggestions? I get the same error on the SRPMS or if I install from source. I am desperate to get this working. Thanks in advance!

targatop 09-08-02 04:55 PM

FIXED THIS PROBLEM! GOT ANOTHER!
 
Okay, I can get it to compile now...I just needed to specify my kernel directory. RH7.3 puts the original installed kernel in /usr/src/linux-2.4 for the 2.4.18-3 kernel.

For ease of installation purposes I symbolically linked the directory.

This can be fixed using the following commands:

cd /usr/src
ln -s linux-2.4 linux-2.4.18-3

Then run the makefile and things should smooth out.

However, I am still getting a lot of unresolved symbol errors. Has anybody had a similar problem?


All times are GMT -5. The time now is 02:12 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.