nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem with 4496 drivers (http://www.nvnews.net/vbulletin/showthread.php?t=16451)

msc73 08-14-03 07:18 AM

Problem with 4496 drivers
 
1 Attachment(s)
X fails to start. The log indicates that it can't open /dev/nvidia0 (input/output error). However the kernel module loaded successfully with modprobe and the devices /dev/nvidia* all exist.

I get lots of messages in /var/log/messages showing kernel errors but I'm not expert enough to interpret them. I've attached the relevant parts of the file.

Any ideas where things are going wrong? I'm fairly sure I have the correct kernel source version (2.4.20-19.7)

Thanks for any help,
Martin.

Xin(tEb 08-18-03 04:12 AM

Have you followed all the instructions in the readme file?

Perhaps you don't have enabled the driver in XF86Config adding "nvidia" replacing "nv" in device section

When X start you would see a NVIDIA LOGO
and try to run GLXgears benchmark
to see if all is working

Xin(tEb 08-18-03 04:15 AM

I read you attachement
It seems to be more complex lol
So i am from no help
Sorry
I'm newbie

energyman76b 08-19-03 10:33 PM

so, you get an oops, and another oops, and a third one. That is not a X, that is a kernel problem

Is the modul you used for the correct kernel?
It does not look so, so you should not ask 'are my sources correct' but 'have I installed the correct kernel rpm?
I think the answer is no.

Glück Auf
Volker

msc73 08-20-03 03:55 AM

I went back and looked at it again. The kernel source was the same as the running kernel. However the kernel headers rpm was not updated. For some reason Red Hat don't seem to provide updates for this package when the kernel is updated (at least I couldn't find them).

I got around the problem by symlinking /usr/include/linux to /usr/src/linux/include/linux. However, then the installer wrongly detected that I was running Red Hat 7.3 and installed the wrong kernel module. So finally I forced it to compile the module from scratch and it worked! Now I have X and normal GL apps working nicely.

However I do get an X server crash when I run a GL4Java program when using the NVIDIA libGL.so. So I have had to go back to Mesa for the time being :-(

Anyone else had problems with GL4Java?

Cheers for the suggestion anyway.


All times are GMT -5. The time now is 05:58 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.