nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Suse 8.2 I need a install guide !!! plz (http://www.nvnews.net/vbulletin/showthread.php?t=16600)

oguzhan86 08-17-03 04:57 PM

Suse 8.2 I need a install guide !!! plz
 
Hi,

i have installed Suse 8.2 pro now and i have Geforce3Ti200.
How can i run the " NV INSTALER" ?
I donīt know how i can shut down the X Server....and so on...
I am a linux NEWBE!!!!
:rolleyes:

Can somebody write me how can i shut down the X server on Suse 8.2 and then what i need to do ......

I have downloaded this file: "NVIDIA-Linux-x86-1.0-4496-pkg2.run"
Is that right??????

thx

oguzhan86:confused:

zsutomato 08-17-03 09:49 PM

search google first:)
edit your /etc/inittab and change your default run level to 3 and restart you pc
and then run like this
sh ./NVIDIA-Linxxxxx.sh and is ok
and then use sax2 to enable 3D acceleration enable
if test is ok
run startx to go back to X win
if your X is stable for some time, then you can modifiy default run level back to 5 in your /etc/inittab

Notice!!!
some suse users found this driver would make your x unstable or frozen.

pe1chl 08-18-03 01:40 AM

First read the articles about this topic on the first 3 (or so) pages of this forum.
Ask the question again if you still have not found what you need.

tiger_campbell 08-18-03 05:47 PM

Not a nice one for a newbie....

I have just been through all this myself. I am quite experienced and it took a long time.... The Nvidia installer will work under SuSE, i.e. it will install the files in the right places, including the kernel module,, but then you need to edit /etc/X11/XF86Config by hand. Sax2 fails totally on Nvidia cards, and will wipe out what you have done, trash XF86Config, and leave you with a non-working or partly working frame buffer only. Also Sax(2) is an absolute pain in text mode, it keeps trying to go into X, even when it is not workable.

If enough people complain to SuSE, they may well fix it.

BTW Nvidia cards are unusable under SuSE Office Desktop (based on 8.1), there are no binutils, which the installer needs, they can't be installed because of the wrong glibc, fixing that breaks almost everything...... Then when you update EVERYTHING to more or less SuSE 8.2, Crossover Office breaks totally, a new one from Codeweavers will cost you.... But I digress.

Best to get the XF86Config from Nvidia (part of their documentation), and put in the monitor info, modelines, etc manually. Keep the sections of the file relating to mice and keyboards as SuSE set them.

Sadly with no working X, not a nice situation for a newbe, it may have to be edited with "vi".

However, it "may" work for you....

Here is how to use the installer.

1. Download the driver from http://www.nvidia.com/object/linux.html, which will be the Linux IA-32 version, currently NVIDIA-Linux-x86-1.0-4496-pkg2.run. If you have the PC configured for dual boot, and have got the Windoze partition(s) mounted under Linux, you can do this in Windoze. Save the file somewhere, not in a main Linux directory. Make a subdirectory for it. It can stay in a Windoze partition if you wish. Remember, Linux can read Windoze files bot not usually vice-versa.

2. Boot into SuSE. If you get into X, try CTRL-ALT-F5 to bring up an alternative text console, or kill X by CTRL-ALT-Backspace, if that gets you a text mode login, or read the earlier post. When you have a text mode login, log in as root.

3. "cd" to where you put the downloaded driver. Ideally it will be in a directory all on its own. You just need to do "sh *.run", where * will substitute for the filename, saves a lot of typing. That is why you should have only one .run file. If not, type it out in full, e.g. "sh NVIDIA-Linux-x86-1.0-4496-pkg2.run" if that is the name of your file.

4. Things will now happen. Watch for error messages. If it complains about missing binutils, install them from CD (nightmare using Yast in text mode.....) and try again.

5. Back up the /etc/X11/XF86Config to somewhere safe before you try Sax2 to configure the card. You may have more success than me, I have a fairly old Gforce 2Ti

6. You will as I said most likely have to edit XF86Config by hand. Read the Nvidia documentation carefully, get your monitor's frequencies from the manual or a web search. Set up a not too ambitious setting (e.g. 800x600) to get it working, you can always edit new modes afterwards. The Config in the Nvidia documentation is a very good place to start.

7. Sit back and enjoy. You will now have a good system, and will have learned a lot!

BTW, don't blame Nvidia for any of this, their cards configure OK with Mandrake or Red Hat. The problem seems to be that SuSE uses a peculiar configuration system, which is quite sophisticated but not entirely bug-free. However, on balance, once you get it working, SuSE is agruably best, but of course it should work out of the box.

pe1chl 08-20-03 02:47 AM

I don't completely agree with you.
The office version may be different, but the plain SuSE 8.2 (which this thread is about) is not so bad. Binutils are no problem at all.

SaX2: I don't like it either, and I always polish the XF86Config afterwards, but basically it works. At least with 8.2 it had no real problems with the card. Older versions were often very buggy, that is true.

The only real newby-unfriendly issue in 8.2 is the weird compiler version string, that confuses automatic installers (not only the nVIDIA installer!) and makes them output an error message indicating that the kernel was not compiled by the C compiler on the system.
However, that can be worked around. See other threads.

tiger_campbell 08-20-03 05:02 PM

Interesting. You are quite entitled to disagree, and a bit of constructive criticism never did anyone any harm, indeed I find it stimulating. I only know what happened to me on my PC with my exact setup, and think the situation needs more investigation. I will check out the compiler version string problem later, it sounds like a good place to start.

I had another attempt at using Sax2, it completely butchered the config again, and left it with one mode working, with a virtual desktop about 20% larger than physical, which is not what I want, but no obvious evidence of why, i.e. no apparent setting like this in XF86Config.

Under Section "Files" it misses an apparently vital entry, RgbPath "/usr/X11R6/lib/X11/rgb", which seems to prevent anything working. It also has a very bad habit of, while using text mode, defaulting to a silly set of frequencies and/or sync polartities which are incompatible with the monitor I am using, which copes with 26-110KHz horizontal. I strongly suspect it is setting it too low, but don't have an oscilloscope to check. Also, in the last invocation it set the vertical refresh to 12-160! 160 is correct, but 12? John Logie Baird's spinning disk television might have been in that region.

I suppose it comes with source code, so I should have a look to see what is going on.

I am suddenly feeling the urge to investigate further, and may report back eventually, just possibly with a fix, if my programming skills are up to it, which I must confess is doubtful.

pe1chl 08-24-03 04:54 AM

Quote:

Originally posted by tiger_campbell

I had another attempt at using Sax2, it completely butchered the config again, and left it with one mode working, with a virtual desktop about 20% larger than physical, which is not what I want, but no obvious evidence of why, i.e. no apparent setting like this in XF86Config.
[/b]
One irritating feature of Sax2 is that it maintains a resolution table for each colordepth, and this is not obvious as you select between colordepths with a selection list with pulldown.

So, when you select 24 bit color and select a resolution, it may be that there is an entry for 16 bit or 8 bit color with a higher resolution and this generates the larger virtual desktop.

Always select all the colordepths one by one, clearing out any resolution selections you don't like, and finally select the colordepth you want to work with and select only one resolution. That removes the crazy resolution switching stuff.

Xin(tEb 08-24-03 12:27 PM

Hello,

You all seem to be quite XFree86 geeks
I think you will be helpful
Here is my problem on my Dell Dimension 8200 [1702 FP lcd] SuSE 8.2 XFree86 4.3 driver IA32 4363 box
The DVI mode doesn't work well that is to say the screen is green like grass and looks like oil and pixelated nevertheless I can see the suse desktop in the Xserver.

Whereas D-sub analog works very well in 1280*1024 depth 24

What can I change in my config to make it to work

The technical specifications for my monitor don't mention if it is for DVI or D-SUB
Do I have to set the same specs for analog and dvi ?

Help

tiger_campbell 08-24-03 03:46 PM

Hello pe1chl,

Yes I agree it is not the nicest of features. What was actually wrong was that under "Screen" subsection "Display" the modes in one of the colour depths started at 1400x1050, which is what I think I was getting, but under "Section "Modes" the only modeline I had not commented out was for 1600x1200, which would have set the virtual size, or was it the other way round? Anyway that is fixed now, but it did not work without manually commenting out most of the Modelines.

I started to look into Sax2, it seems that there is about 7MB of stuff there, a lot of Perl scripts (arguably the easiest way to do it, but not for me..). Seems to me that the whole issue of X configuration has got out of hand, in the same way that Windoze has gone, because of the ridiculous diversity of PC hardware architectures. Even so, a fresh approach would be best.

Having said all this, I think that my combination of hardware is simply one that has not been envisaged by SuSE, or there may be another factor (guessing, buggy monitor EDID?) which is upsetting things, because it does seem that a considerable amount of work has gone into SAX2.

One piece of the picture I don't have, despite an extensive search, is the range of possible pixel clock frequencies, presumably defined by the Nvidia card, so I can't investigate the modelines very well, except by trial and error, and risking the possibility of a big bang from the monitor.

I have a decently working computer now, but this whole matter is bugging me, so investigation will continue....


****************************


Xin(tEb,

This sounds like a mismatch between the graphics card resolution and the actual number of pixels on the screen. To get decent results on a LCD, you must match it pixel for pixel. If your LCD for example is actually 1024*768, in analoguue mode the analogue to digital conversion in the LCD controller would do some kind of interpolation, which would effectively result in one pixel in 5 in each axis being dropped, or averaged over its neighbours. This might be acceptable on graphics, on small text it would be very noticeable as some letters would be thicker than others.

On DVI there would be problems if there was not an exact match. The DVI spec is available at http://www.ddwg.org/downloads.html. It may help....

Otherwise, if your PC is dual boot, try playing with the resolutions in Windoze, see what happens. One thing not to worry about, you will not blow up the LCD, unlike a CRT!

Try manually editing /etc/X11/XF86Config, comment out (add "#" in 1st column) any Modelines which do not agree with your actual screen resolution. There should be some that do agree, and some matching entries under "Screen", check that you have Subsections with Depth 16 or Depth 24, comment out the whole subsection, line by line, for any with Depth 8 or less. It *might* just be not sufficient colours.....

Finally, is your DVI cable OK? Check under Windoze or another PC. The DVI interface actually has 2 channels, on low to medium bandwidth applications only one is used, but at sufficiently high resolution both are used, and I seem to remember from reading the spec a few months ago that there was scope for incompatability.

Let us know how you get on, I for one am learning too, and am intrigued to know what is really wrong here.

Xin(tEb 08-25-03 04:12 AM

XF86Config
 
In my etc/X11/ i have 3 XF86Config files
one classic, one with a -Sax2Save ending, and a -linux ending
This morning I've tried to change XF86Config settings and restart X to see the results
And at my surprise nothing was listen by XFree86 4.3
So i'm wondering which one of the files is the main config file???

With these settings in Monitor section the Xserver should have crash or something but nothing happenned with HorizSync and VertRefresh removed ?!?

What is the file that XFree86 really asks for parameters???
Is there another one in /usr/lib/X11/ ?
Does the 3 files count egally for X (saxsave and -linux ending)

I'm on SuSE 8.2 for information

Send me pls a good XF86Config for a DVI interface
If you have one somewhere
so that i can make comparison with mine

Xin(tEb 08-25-03 04:15 AM

My monitor worked fine via DVI 2 months ago on Windows
so the cable problem doesn't exist

tiger_campbell 08-25-03 08:59 AM

XF86Config is the file X11 is using, unless told otherwise. Don't know if that is possible, but maybe in the startx script. Certainly on my SuSE it is the active file. The -Sax2Save file is created as a backup when using Sax2, and is, the first time at least, the original default file. I suspect it gets overwritten each time Sax2 is used. I can't prove that, as I used Yast2, which I think invokes Sax2 to do the work, but it left me with a .YaST2save file instead. The .linux file has not so far appeared on my system......

Now, to complicate matters, there is quite possibly a file at /usr/X11R6/lib/X11/XF86Config.eg which is an example file, which may even be useful to you. It is from the XFree86 Project, has not been customised by SuSE. Piecing together ideas in that file, and the example provided in the Nvidia literature, may be useful.

It might help while you are experimenting to set Option "DontZoom" as it seems to cause all sorts of nuisance problems.

Just occurred to me, the problem may simply be that you are feeding data too fast to the LCD, try lowering horizontal and vertical refresh rates, and pixel clock., and tweaking modelines (if used) for longer sync pulse.

Check that you have

RgbPath "/usr/X11R6/lib/X11/rgb"

as without that there will be severe problems. Sax2 omitted that on my installation.

The only reference Nvidia make to DVI is under Option "IgnoreDisplayDevices", but that will not be needed if you power up the LCD before the PC, so that X11 reads the necessary parameters from the monitor EDID.

Would it be practicable to post your XF86Config file here so we could have a look at it? Sufficient pairs of eyes might spot something amiss. We might learn something to help us too.


All times are GMT -5. The time now is 02:41 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Đ1998 - 2014, nV News.