nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   FX5200 'no screens found' Fatal server error (http://www.nvnews.net/vbulletin/showthread.php?t=16646)

desperate5200 08-18-03 03:38 PM

FX5200 'no screens found' Fatal server error
 
1 Attachment(s)
Hi,
I don't consider myself a linux newbie, I even got a Intel WLAN pcmcia card to run on a Thinkpad under linux once and that took some patience, but I'm far from being a linux crack.

I just CANT get the latest NVIDIA driver (the NVIDIA-Linux-x86-1.0-4496-pkg2.run) to work. I've tried virtually all possible combinations from the most likely to the most unlikely, none worked.

My machine:
Athlon XP 2600+
ASROCK K7S8X Motherboard
512 MB Ram
GForce FX5200 (128MB) (from XFX, BIOS Version 4.34.20.18.00)
Suse 8.2 with all possible updates as of Aug-18-2003 running the updated k_athlon kernel

I've tried about 5 times to do it the conventional way, like it says on the Suse-page (i.e. copying the neccessary files and make cloneconfig dep, with all the latest sources installed, then compiling my own nvidia-kernel because no precompiled one was found with IGNORE_CC_MISMATCH=yes) with all sorts of different resolutions. The driver compiles and installs fine. When I go to sax2 and enable the 3D accelleration it automatically switches to 'nvidia' instead if 'nv', as it should, but when I test the x-server I only get a black screen everytime, which I cant even ctrl-alt-backspace out of.

When that failed I virtually raped the driver in all possible ways, in the end doing everything manually, such as editing the XFree86.conf, forcing to use old precompiled kernels and so on.

I know I was doing it right, because at work I did the same procedure (the conventional one) with my RIVA TNT2 1 GHz Athlon and everything worked beautifully. I use the same Suse version and the exakt same software setup.

But on my machine at home NOTHING worked!

I've attached the XFree error log. The interesting stuff is in the end. I don't really know what to do with the 'no screens found' error. I've tried various different resolutions, all produce the same result.

I would really appreciate help!
Thanks.

XoD 08-18-03 08:12 PM

NVIDIA kernel module
 
Your log says that it was impossible to initialize the kernel module. Check out that the *right* nvidia kernel module gets loaded before you start X. If it is done properly, try to recompile the nvidia kernel module with the headers of your running kernel.
Don't forget to post your XFConfig86 if the problem remains.

desperate5200 08-19-03 05:39 AM

1 Attachment(s)
Hi,

I checked everything, the problem is still there. I've attachted all the log's. The individual ones are seperated by -----.

From the way I read the 'nvidia-installer.log' It reads my runnnig kernel header files. Plus I didn't find any of the *.h files in the driver package anywhere else on my system.

This time I didnt testx in sax2, I saved right away and then started x with logverbose 5. the result is the 'XFree86.log' Intererstingly enough there are no real (EE) Errors, but I still only get a black screen which I cant get out of again.

Someone have any idea?

Thanx

XoD 08-19-03 07:35 AM

AGP init failed in your X log
 
Your AGP init failed...
Did you check that you nvidia kernel module was loaded?
$>lsmod

desperate5200 08-19-03 10:01 AM

AGP init
 
Hi,

no it didn't. I did it manually:
modprobe nvidia
startx
-> same error (agp..failed)

Am I going at it the wrong way or is there another module I have to load?

XoD 08-19-03 01:49 PM

Keep going...
 
Ok... then you did load manually the nvidia kernel module. But you need to check its presence with the 'lsmod' command.
If AGP still fails, did you try to load the linux AGP kernel module?(I don't know its name because I compiled it straight into my kernel)

mtrr 08-19-03 06:48 PM

agpgart, that's the module name. look in your BIOS setting
for an option like:

assign IRQ to VGA


maybe you can try to switch between kernel GART and
nVidia GART (take a look in the readme for the options for
NvAGP)

cheers

desperate5200 08-20-03 10:24 AM

resignation
 
thanks guys,

I've included both modules and checked my bios for agp settings. I played around but still no good news. I'm giving up for now. This is eating up too much of my time. I really appreciate the help though!

2D is at least better than 1D;-|

XoD 08-20-03 10:59 AM

Diagnosis...
 
When you finished to load both kernel modules, don't start X yet. Check out the text files in /proc/driver/nvidia/agp ! Use cat to print their content. That will tell you if the AGP is at least properly detected chipset side and graphic board side.


All times are GMT -5. The time now is 03:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.