nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   compiling 1.0-4180 on AMD64 / RedHat64 beta (Taroon)? (http://www.nvnews.net/vbulletin/showthread.php?t=16652)

rconstance 08-18-03 06:20 PM

compiling 1.0-4180 on AMD64 / RedHat64 beta (Taroon)?
 
Has anyone had any luck getting the 1.0-4180 driver to compile on the RH64 beta (Taroon) for a AMD64 system.? When compiling the NVIDIA_kernel module I get the following error:

nv.c:1282: warning: passing arg 1 of `remap_page_range_Rsmp_7a2932f2' makes pointer from integer without a cast
nv.c:1282: incompatible type for argument 4 of `remap_page_range_Rsmp_7a2932f2'
nv.c:1282: too few arguments to function `remap_page_range_Rsmp_7a2932f2'

This is because in include/linux/mm.h on the 2.4.21-1.1931.2.349.2.2.entsmp kernel, the remap_page_range function prototype is now 5 arguments instead of 4. So the nv.c isn't written to support this newer kernel.

I know its unlikely this will be fixed anytime soon especially considering that kernel is still in beta, but I was wondering if anyone has figured out a workaround to get the kernel module compiled. The GLX module compiles fine, by the way.

Thanks for the info!

-Roderick

phlunkie 08-18-03 07:49 PM

I'd don't think many people have access to amd64's.....must be nice! I'm jealous!!!!!

jahshaka 09-24-03 12:14 AM

Error compiling NVKERENL on Hp Itanium2 box
 
Hi,

I am having the exact same problem on my itanium 2 system. I am running RedHat's AW-3.0 (taroon) on a dual proc itanium 2 hp-zx6000 (smoking fast system who needs 32 bit support anyway)

I also noticed few errors before the remap_page error related to the highmem.h file, but i have 10gig ram on my box so maybe that was just on my system?

Please let me know if theres a patch i can use to get the drivers to compile.

Thanks,

Jah

jahshaka 09-24-03 02:07 AM

Feedback from Redhat...
 
Heres some feedback from redhat on taroon drivers... the best part is that taroon has code that is 'back ported from 2.5.x,' After some checking around, i noticed people having the same problems trying to get nvidia drivers to work on the 2.6 kernel... so i guess when nvidia gets a ia64 build for the 2.6 kernel going it should work with taroon.

lets hope this is real soon or all the redhat advanced workstation workstations will be running ati cards...

>>

Red Hat doesn't support Nvidia's binary drivers at all on any platform.
We do not approach vendors and ask them to speed up their proprietary driver release process for drivers we don't support either.

People who use their drivers however are of course free to ask them for
updated drivers, support, etc. if they wish, however Red Hat is not involved
in that process.

Nvidia uses their own proprietary agpgart, and does not use the agpgart
which we ship, so any fixes to agpgart that we provide won't affect users
using Nvidia proprietary drivers at all.

The problem described in the email you point out above, is because the Red
Hat kernel contains various enhancements over a stock 2.4.x kernel, which
have either been developed at Red Hat directly, or back ported from 2.5.x,
which change many kernel internals. The kernel does not have a
advertised ABI, and so proprietary kernel modules will break and require
their vendors to fix them to work with new kernels. Nvidia will have to
update their drivers to work with the Red Hat Enterprise Linux 3 kernel.

Please contact Nvidia directly for any support issues/requests pertaining
to their drivers.

Thanks.


All times are GMT -5. The time now is 07:32 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.