nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Screen only flicker after nvidia driver install (http://www.nvnews.net/vbulletin/showthread.php?t=166624)

odin89 09-23-11 10:10 AM

Screen only flicker after nvidia driver install
 
Hi,
I installed Arch Linux today. When i want start GDM then the Screen is only flickering. The Driver Version is 280.13 and the Card is a Nvidia GT220. Same Problems with Ubuntu 11.04 and 11.10beta. Only Opensuse 11.4 works.
The Xorg.0.log looks ok for me.
Code:

[    14.342]
X.Org X Server 1.10.4
Release Date: 2011-08-19
[    14.342] X Protocol Version 11, Revision 0
[    14.342] Build Operating System: Linux 3.0-ARCH x86_64
[    14.342] Current Operating System: Linux myhost 3.0-ARCH #1 SMP PREEMPT Tue Aug 30 08:53:25 CEST 2011 x86_64
[    14.342] Kernel command line: root=/dev/sdb1 ro
[    14.342] Build Date: 17 September 2011  07:42:58AM
[    14.342] 
[    14.342] Current version of pixman: 0.22.2
[    14.342]        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    14.342] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    14.342] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep 23 14:57:34 2011
[    14.367] (==) Using config file: "/etc/X11/xorg.conf"
[    14.367] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    14.391] (==) ServerLayout "Layout0"
[    14.391] (**) |-->Screen "Screen0" (0)
[    14.391] (**) |  |-->Monitor "Monitor0"
[    14.391] (**) |  |-->Device "Device0"
[    14.391] (**) |-->Input Device "Keyboard0"
[    14.392] (**) |-->Input Device "Mouse0"
[    14.392] (==) Automatically adding devices
[    14.392] (==) Automatically enabling devices
[    14.416] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    14.416]        Entry deleted from font path.
[    14.416] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    14.416]        Entry deleted from font path.
[    14.464] (==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi/,
        /usr/share/fonts/75dpi/
[    14.464] (==) ModulePath set to "/usr/lib/xorg/modules"
[    14.464] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    14.464] (WW) Disabling Keyboard0
[    14.464] (WW) Disabling Mouse0
[    14.464] (II) Loader magic: 0x7d6160
[    14.464] (II) Module ABI versions:
[    14.464]        X.Org ANSI C Emulation: 0.4
[    14.464]        X.Org Video Driver: 10.0
[    14.464]        X.Org XInput driver : 12.2
[    14.464]        X.Org Server Extension : 5.0
[    14.465] (--) PCI:*(0:1:0:0) 10de:0a20:1043:830f rev 162, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @ 0x0000bc00/128, BIOS @ 0x????????/524288
[    14.465] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    14.465] (II) LoadModule: "extmod"
[    14.496] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    14.508] (II) Module extmod: vendor="X.Org Foundation"
[    14.508]        compiled for 1.10.4, module version = 1.0.0
[    14.508]        Module class: X.Org Server Extension
[    14.508]        ABI class: X.Org Server Extension, version 5.0
[    14.508] (II) Loading extension MIT-SCREEN-SAVER
[    14.508] (II) Loading extension XFree86-VidModeExtension
[    14.508] (II) Loading extension XFree86-DGA
[    14.508] (II) Loading extension DPMS
[    14.508] (II) Loading extension XVideo
[    14.508] (II) Loading extension XVideo-MotionCompensation
[    14.508] (II) Loading extension X-Resource
[    14.508] (II) LoadModule: "dbe"
[    14.508] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    14.509] (II) Module dbe: vendor="X.Org Foundation"
[    14.509]        compiled for 1.10.4, module version = 1.0.0
[    14.509]        Module class: X.Org Server Extension
[    14.509]        ABI class: X.Org Server Extension, version 5.0
[    14.509] (II) Loading extension DOUBLE-BUFFER
[    14.509] (II) LoadModule: "glx"
[    14.509] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    15.105] (II) Module glx: vendor="NVIDIA Corporation"
[    15.120]        compiled for 4.0.2, module version = 1.0.0
[    15.121]        Module class: X.Org Server Extension
[    15.121] (II) NVIDIA GLX Module  280.13  Wed Jul 27 17:12:07 PDT 2011
[    15.121] (II) Loading extension GLX
[    15.121] (II) LoadModule: "record"
[    15.121] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    15.121] (II) Module record: vendor="X.Org Foundation"
[    15.121]        compiled for 1.10.4, module version = 1.13.0
[    15.121]        Module class: X.Org Server Extension
[    15.121]        ABI class: X.Org Server Extension, version 5.0
[    15.121] (II) Loading extension RECORD
[    15.121] (II) LoadModule: "dri"
[    15.122] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    15.138] (II) Module dri: vendor="X.Org Foundation"
[    15.138]        compiled for 1.10.4, module version = 1.0.0
[    15.138]        ABI class: X.Org Server Extension, version 5.0
[    15.138] (II) Loading extension XFree86-DRI
[    15.138] (II) LoadModule: "dri2"
[    15.138] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    15.139] (II) Module dri2: vendor="X.Org Foundation"
[    15.139]        compiled for 1.10.4, module version = 1.2.0
[    15.139]        ABI class: X.Org Server Extension, version 5.0
[    15.139] (II) Loading extension DRI2
[    15.139] (II) LoadModule: "nvidia"
[    15.139] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    15.196] (II) Module nvidia: vendor="NVIDIA Corporation"
[    15.197]        compiled for 4.0.2, module version = 1.0.0
[    15.197]        Module class: X.Org Video Driver
[    15.216] (II) NVIDIA dlloader X Driver  280.13  Wed Jul 27 16:55:26 PDT 2011
[    15.216] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    15.229] (++) using VT number 7

[    15.236] (II) Loading sub module "fb"
[    15.236] (II) LoadModule: "fb"
[    15.236] (II) Loading /usr/lib/xorg/modules/libfb.so
[    15.240] (II) Module fb: vendor="X.Org Foundation"
[    15.240]        compiled for 1.10.4, module version = 1.0.0
[    15.240]        ABI class: X.Org ANSI C Emulation, version 0.4
[    15.240] (II) Loading sub module "wfb"
[    15.240] (II) LoadModule: "wfb"
[    15.240] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    15.250] (II) Module wfb: vendor="X.Org Foundation"
[    15.250]        compiled for 1.10.4, module version = 1.0.0
[    15.250]        ABI class: X.Org ANSI C Emulation, version 0.4
[    15.250] (II) Loading sub module "ramdac"
[    15.250] (II) LoadModule: "ramdac"
[    15.250] (II) Module "ramdac" already built-in
[    15.251] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    15.251] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    15.251] (II) Loading /usr/lib/xorg/modules/libfb.so
[    15.267] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    15.267] (==) NVIDIA(0): RGB weight 888
[    15.267] (==) NVIDIA(0): Default visual is TrueColor
[    15.267] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    15.267] (**) NVIDIA(0): Option "FlatPanelProperties" "Dithering=Disabled"
[    16.186] (II) NVIDIA(GPU-0): Display (ONK TX-SR308 (DFP-1)) supports NVIDIA 3D Vision
[    16.186] (II) NVIDIA(GPU-0):    stereo.
[    16.187] (II) NVIDIA(0): NVIDIA GPU GeForce GT 220 (GT216) at PCI:1:0:0 (GPU-0)
[    16.187] (--) NVIDIA(0): Memory: 1048576 kBytes
[    16.187] (--) NVIDIA(0): VideoBIOS: 70.16.2e.00.07
[    16.187] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    16.187] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[    16.187] (--) NVIDIA(0): Connected display device(s) on GeForce GT 220 at PCI:1:0:0
[    16.187] (--) NVIDIA(0):    ONK TX-SR308 (DFP-1)
[    16.187] (--) NVIDIA(0): ONK TX-SR308 (DFP-1): 165.0 MHz maximum pixel clock
[    16.187] (--) NVIDIA(0): ONK TX-SR308 (DFP-1): Internal Single Link TMDS
[    16.194] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
[    16.194] (**) NVIDIA(0):    enabled on all display devices.
[    16.241] (II) NVIDIA(0): Assigned Display Device: DFP-1
[    16.241] (II) NVIDIA(0): Validated modes:
[    16.241] (II) NVIDIA(0):    "1280x720"
[    16.241] (II) NVIDIA(0): Virtual screen size determined to be 1280 x 720
[    16.277] (--) NVIDIA(0): DPI set to (147, 203); computed from "UseEdidDpi" X config
[    16.277] (--) NVIDIA(0):    option
[    16.277] (--) Depth 24 pixmap format is 32 bpp
[    16.277] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[    16.280] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    16.280] (II) NVIDIA(0):    may not be running or the "AcpidSocketPath" X
[    16.280] (II) NVIDIA(0):    configuration option may not be set correctly.  When the
[    16.280] (II) NVIDIA(0):    ACPI event daemon is available, the NVIDIA X driver will
[    16.280] (II) NVIDIA(0):    try to use it to receive ACPI event notifications.  For
[    16.280] (II) NVIDIA(0):    details, please see the "ConnectToAcpid" and
[    16.280] (II) NVIDIA(0):    "AcpidSocketPath" X configuration options in Appendix B: X
[    16.280] (II) NVIDIA(0):    Config Options in the README.
[    16.282] (II) NVIDIA(0): Setting mode "1280x720"
[    16.361] (II) Loading extension NV-GLX
[    16.417] (==) NVIDIA(0): Disabling shared memory pixmaps
[    16.417] (==) NVIDIA(0): Backing store disabled
[    16.417] (==) NVIDIA(0): Silken mouse enabled
[    16.418] (**) NVIDIA(0): DPMS enabled
[    16.418] (II) Loading extension NV-CONTROL
[    16.418] (II) Loading extension XINERAMA
[    16.418] (II) Loading sub module "dri2"
[    16.418] (II) LoadModule: "dri2"
[    16.419] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    16.419] (II) Module dri2: vendor="X.Org Foundation"
[    16.419]        compiled for 1.10.4, module version = 1.2.0
[    16.419]        ABI class: X.Org Server Extension, version 5.0
[    16.419] (II) NVIDIA(0): [DRI2] Setup complete
[    16.419] (==) RandR enabled
[    16.419] (II) Initializing built-in extension Generic Event Extension
[    16.419] (II) Initializing built-in extension SHAPE
[    16.419] (II) Initializing built-in extension MIT-SHM
[    16.419] (II) Initializing built-in extension XInputExtension
[    16.419] (II) Initializing built-in extension XTEST
[    16.419] (II) Initializing built-in extension BIG-REQUESTS
[    16.419] (II) Initializing built-in extension SYNC
[    16.419] (II) Initializing built-in extension XKEYBOARD
[    16.419] (II) Initializing built-in extension XC-MISC
[    16.419] (II) Initializing built-in extension SECURITY
[    16.419] (II) Initializing built-in extension XINERAMA
[    16.419] (II) Initializing built-in extension XFIXES
[    16.419] (II) Initializing built-in extension RENDER
[    16.419] (II) Initializing built-in extension RANDR
[    16.419] (II) Initializing built-in extension COMPOSITE
[    16.419] (II) Initializing built-in extension DAMAGE
[    16.420] (II) Initializing extension GLX
[    16.846] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[    16.846] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    16.846] (II) LoadModule: "evdev"
[    16.847] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    16.857] (II) Module evdev: vendor="X.Org Foundation"
[    16.857]        compiled for 1.10.0, module version = 2.6.0
[    16.857]        Module class: X.Org XInput Driver
[    16.857]        ABI class: X.Org XInput driver, version 12.2
[    16.857] (II) Using input driver 'evdev' for 'Power Button'
[    16.857] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    16.857] (**) Power Button: always reports core events
[    16.857] (**) Power Button: Device: "/dev/input/event2"
[    16.857] (--) Power Button: Found keys
[    16.857] (II) Power Button: Configuring as keyboard
[    16.857] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[    16.857] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    16.857] (**) Option "xkb_rules" "evdev"
[    16.857] (**) Option "xkb_model" "evdev"
[    16.857] (**) Option "xkb_layout" "us"
[    16.876] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    16.876] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    16.876] (II) Using input driver 'evdev' for 'Power Button'
[    16.876] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    16.876] (**) Power Button: always reports core events
[    16.876] (**) Power Button: Device: "/dev/input/event1"
[    16.876] (--) Power Button: Found keys
[    16.876] (II) Power Button: Configuring as keyboard
[    16.877] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input1/event1"
[    16.877] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    16.877] (**) Option "xkb_rules" "evdev"
[    16.877] (**) Option "xkb_model" "evdev"
[    16.877] (**) Option "xkb_layout" "us"
[    16.878] (II) config/udev: Adding input device HDA NVidia HDMI/DP (/dev/input/event4)
[    16.878] (II) No input driver/identifier specified (ignoring)
[    16.878] (II) config/udev: Adding input device HDA NVidia HDMI/DP (/dev/input/event5)
[    16.878] (II) No input driver/identifier specified (ignoring)
[    16.878] (II) config/udev: Adding input device HDA NVidia HDMI/DP (/dev/input/event6)
[    16.878] (II) No input driver/identifier specified (ignoring)
[    16.879] (II) config/udev: Adding input device HDA NVidia HDMI/DP (/dev/input/event7)
[    16.879] (II) No input driver/identifier specified (ignoring)
[    16.887] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[    16.887] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    16.887] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    16.887] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    16.887] (**) AT Translated Set 2 keyboard: always reports core events
[    16.887] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[    16.887] (--) AT Translated Set 2 keyboard: Found keys
[    16.887] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[    16.887] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[    16.887] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[    16.887] (**) Option "xkb_rules" "evdev"
[    16.887] (**) Option "xkb_model" "evdev"
[    16.887] (**) Option "xkb_layout" "us"
[    16.887] (II) config/udev: Adding input device PC Speaker (/dev/input/event3)
[    16.887] (II) No input driver/identifier specified (ignoring)

Anyone have an idea what i can try?

greets odin89


All times are GMT -5. The time now is 03:15 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.