nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   glXCreateContext errors (http://www.nvnews.net/vbulletin/showthread.php?t=16713)

milo 08-20-03 05:36 AM

glXCreateContext errors
 
I've noticed a strange problem today: After a reboot, or a re-start of X, there are no problems with any OpenGL applications. However, after the first time I run one, all further attempts to do so fail with the following message:

Code:

Error: glXCreateContext failed
X appears to start correctly, and I can find no errors in the log, or anything else in /var/log/messages or dmesg.
Can anyone suggest a cause, or where to investigate further?

The system details are:

Card: GeForce2 MX/MX 400
Video BIOS: 03.11.01.24.00
Card Type: AGP
NVRM version: NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4496
GCC version: gcc version 3.3.1 (Gentoo Linux 3.3.1, propolice)
Kernel: 2.6.0-test3-mm2
This is on an Athlon MP SMP system.
Thanks,
Milo.
:confused:

am2020 08-21-03 02:40 PM

Hi. I have a similar problem with a QuadroFX 750 running on a dual Xeon (SMP) and drivers 4496, but NVIDIA is either ignoring my requests or they do not know what's going on. It does not happen on my single processor GeForce4 4400 card.

I have done some testing and found that setting
__GL_FORCE_DIRECT=0 in the environment
will fix the problem.

(Using bash: export __GL_FORCE_DIRECT=0)

Now, I do not know what that flags does, yet.


All times are GMT -5. The time now is 12:23 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.