nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed) (http://www.nvnews.net/vbulletin/showthread.php?t=167210)

NickLion 10-10-11 01:20 AM

Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)
 
4 Attachment(s)
Good day!
I have a problem with installing 285.05.09.
My OS is openSuSE 11.4 with Tumbleweed, so I have kernel 3.0.4. Now is nvidia 280.13 drivers installed.
What I do:
0) go to tty and run 'init 3' to stop kdm (and Xorg)
1) run NVIDIA-Linux-x86_64-285.05.09.run (downloaded from site), all seems 'ok', installer log see in attachment
2) do nvidia-bug-report.sh (see nvidia-bug-report.log.1-before-no-x.gz)
3) run 'init 5' or 'startx' - it's looks 'ok' (see nvidia-bug-report.log.2-after-no-restart.gz)
4) restart computer.... and no X at all :) (see nvidia-bug-report.log.3-after-restart.gz)
So as I see, after restart old kernel module (from 280.13) is loaded, and new libraries can't work with it.
Why it's not replaced with new one?

Hope this info is helpful. Or maybe any other info needed?

towo| 10-10-11 01:35 AM

Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)
 
make sure, there is no nvidia-package installed from any suse-repo
boot to tty
rmmod nvidia
update-initramfs
startx

NickLion 10-10-11 07:13 AM

Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)
 
I've never installed nvidia rpms from repo (in this OS installation) :)

DeiF 10-10-11 09:43 AM

Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)
 
I didn't read the logs, but you can try this:

Edit the file "/etc/modprobe.d/99-local.conf" adding the following:
Code:

blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-173
blacklist nvidia-96

Then run "mkinitrd". Reboot.

Deanjo 10-10-11 12:43 PM

Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)
 
Quote:

Originally Posted by NickLion (Post 2489324)
So as I see, after restart old kernel module (from 280.13) is loaded, and new libraries can't work with it.
Why it's not replaced with new one?

Hope this info is helpful. Or maybe any other info needed?

Sounds like you didn't run 280.13's uninstall option (--uninstall) before installing the new ones.

NickLion 10-11-11 12:16 AM

Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)
 
Quote:

Originally Posted by Deanjo (Post 2489478)
Sounds like you didn't run 280.13's uninstall option (--uninstall) before installing the new ones.

Yes. But with previous versions upgrade proceeded well. Installation of 285.05.09 detects old version and says that 280.13 would be removed.

Nv5-SMURF 10-11-11 11:32 AM

Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)
 
Its said before u need to do 'mkinitrd' , why cuz in /boot is a initrd-file wich has the nvidia driver inside wich is loaded at boot

if u try to start X in init3 and do xinit u get bounced back in console with the remark older driver version incompatible with the library version

u should check also /etc/sysconfig/kernel if NO_KMS_IN_INITRD="yes" is set

Nv5-SMURF 10-11-11 11:34 AM

Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)
 
And yes unfortunaly u must reboot

NickLion 10-14-11 01:03 AM

Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)
 
Quote:

Originally Posted by Nv5-SMURF (Post 2489752)
Its said before u need to do 'mkinitrd' , why cuz in /boot is a initrd-file wich has the nvidia driver inside wich is loaded at boot

if u try to start X in init3 and do xinit u get bounced back in console with the remark older driver version incompatible with the library version

u should check also /etc/sysconfig/kernel if NO_KMS_IN_INITRD="yes" is set

Why this is needed in new version and wasn't needed in previous upgrades?


All times are GMT -5. The time now is 01:35 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.