nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   OpenGL not working (http://www.nvnews.net/vbulletin/showthread.php?t=16747)

prtsoft 08-20-03 08:37 PM

OpenGL not working
 
1 Attachment(s)
When ever I try to use a GL game like wolfenstine, ot tuxcart, or tuxracer, they all kill with errors.
Wolf-ET:

ET 2.55 linux-i386 May 27 2003
----- FS_Startup -----
Current search path:
/home/Paul/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (4 files)
/usr/local/games/enemy-territory/etmain

----------------------
3729 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 4/4/4 Color bits, 16 depth, 0 stencil display.
NV: could not get NV card info (Invalid argument)
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 144
Minor opcode of failed request: 5
Serial number of failed request: 36
ERROR: couldn't create font (glGenLists)
GL_RENDERER: (null)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: Q_strncpyz: NULL src

Tuxracer:

Tux Racer 0.61 -- a Sunspire Studios Production (http://www.sunspirestudios.com)
(c) 1999-2000 Jasmin F. Patry <jfpatry@sunspirestudios.com>
"Tux Racer" is a trademark of Jasmin F. Patry
Tux Racer comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to redistribute it under certain conditions.
See http://www.gnu.org/copyleft/gpl.html for details.

NV: could not get NV card info (Invalid argument)
*** tuxracer error: Couldn't initialize video: Could not create GL context (Success)

XoD 08-21-03 06:52 AM

DGA?
 
I check the init of my ET... I don't have a DGA mouse or so... get rid of the DGA extension xfree module!
I give you my XF86Config module section to show you how to disable the dga module
Section "Module"
Load "dbe"
Load "record"
SubSection "extmod"
Option "omit XFree86-DGA"
EndSubSection
Load "glx"
EndSection

BTW... if you still have troubles, don't forget to give us also your xfree log file!

prtsoft 08-21-03 08:28 AM

1 Attachment(s)
Ok, I changed that and no go, I run tuxracer, and get the same errors as b4:

Tux Racer 0.61 -- a Sunspire Studios Production (http://www.sunspirestudios.com)
(c) 1999-2000 Jasmin F. Patry <jfpatry@sunspirestudios.com>
"Tux Racer" is a trademark of Jasmin F. Patry
Tux Racer comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to redistribute it under certain conditions.
See http://www.gnu.org/copyleft/gpl.html for details.

Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
*** tuxracer error: Couldn't initialize video: Couldn't find matching GLX visual (Success)

Wolf-ET:

ET 2.55 linux-i386 May 27 2003
----- FS_Startup -----
Current search path:
/home/Paul/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (4 files)
/usr/local/games/enemy-territory/etmain

----------------------
3729 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsyste


Below is my Xfree86.0.log

XoD 08-21-03 09:02 AM

GLX not properly loaded
 
You xfree log tells us that your GLX extension is not loaded properly.
Here is MY xfree log section dealing with the nvidia GLX extension loading:
LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4496
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1

Then you have to check out presence and type(mesa glx or nvidia glx) of /usr/X11R6/lib/modules/extensions/libglx.so

mtrr 08-21-03 09:02 AM

two things:

use the latest driver if possible, and make a system update
if you'd looked into your logs a little you would have seen
that on your own.

and I don't know why DGA should be deactivated


cheers

prtsoft 08-21-03 09:25 AM

OK, I checked, that file exists, but it is a symlink to the old driver, 4363, how to i change it to point to 4496?

XoD 08-21-03 09:25 AM

DGA or not DGA?
 
Do you know in more details to the relationship between DGA and the nvidia driver?(I know DRI is useless with those driver, and I'm lazy investigating that right now...).

XoD 08-21-03 09:28 AM

Check out ALL symlinks
 
You have to check that all symlinks!
Looks like your driver installation is... stuffed!

prtsoft 08-21-03 09:49 AM

Re: Check out ALL symlinks
 
Quote:

Originally posted by XoD
You have to check that all symlinks!
Looks like your driver installation is... stuffed!

OK, but how do i change them?

BTW:

I had this working, before i copied my old HD over to my new one, now after it is copied, it's doing this... :(

XoD 08-21-03 10:54 AM

Brute force...
 
Download the installation binary from nvidia web site and re-install it... brutally...
It should copy the right file and create the right symbolic links.


All times are GMT -5. The time now is 01:24 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.