nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Segmentation fault and complete freeze with GT520 (http://www.nvnews.net/vbulletin/showthread.php?t=167793)

x-Na 10-25-11 03:54 PM

Segmentation fault and complete freeze with GT520
 
1 Attachment(s)
Hi!


I bought a new graphics card, a GT520 silent. But it seems to make X Segfault when switching VT, not always but usually at least once a day.

I have the 285. drivers installed which had this fix, hoping it would help:

"Fixed a bug causing the X server to crash after a VT-switch while running an OpenGL stereo application which is a member of a swap group."

I have no idea what an OpenGL stereo app would be, I'm just running Gnome 3.2 with two or more X sessions running at the same time. With my old 6200 LE card everything works.

x-Na 10-27-11 05:13 AM

Re: Segmentation fault and complete freeze with GT520
 
Anyone....?

x-Na 10-29-11 07:27 AM

Re: Segmentation fault and complete freeze with GT520
 
I am still saying that this is something similar to the bug in 280 about the VT switch. Either only for this GPU or some other unknown thing.

With 280 I get the freezes almost every single VT switch. With 285 it's usually when I (or my wife) has left their browser open and want to relogin to their session. But the way the freeze happens is similar, cursor is visible and a about 50 pixel square are left behind.

ledoc 10-29-11 11:59 AM

Re: Segmentation fault and complete freeze with GT520
 
Wow your X crashes a lot...
Did you try the 290 driver?

For the record, this seems to be the backtrace, if anyone else has any idea or seen it before..

Quote:

Backtrace:
[ 50577.908] 0: /usr/bin/X (xorg_backtrace+0x26) [0x460576]
[ 50577.908] 1: /usr/bin/X (0x400000+0x64b8a) [0x464b8a]
[ 50577.908] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7ffb6ad01000+0x10060) [0x7ffb6ad11060]
[ 50577.908] 3: /lib/x86_64-linux-gnu/libc.so.6 (0x7ffb69c1c000+0x8acbb) [0x7ffb69ca6cbb]
[ 50577.908] 4: /usr/lib/xorg/modules/libfb.so (fbBlt+0xf0) [0x7ffb64ac3580]
[ 50577.908] 5: /usr/lib/xorg/modules/libfb.so (fbOddTile+0x170) [0x7ffb64ad0640]
[ 50577.908] 6: /usr/lib/xorg/modules/libfb.so (fbFill+0x45b) [0x7ffb64ac71eb]
[ 50577.908] 7: /usr/lib/xorg/modules/libfb.so (fbPolyFillRect+0x1c4) [0x7ffb64ac7844]
[ 50577.908] 8: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so (0x7ffb64cd6000+0x46b5df) [0x7ffb651415df]
[ 50577.908] 9: /usr/bin/X (0x400000+0xde925) [0x4de925]
[ 50577.908] 10: /usr/bin/X (miPaintWindow+0x1a0) [0x45b5a0]
[ 50577.908] 11: /usr/bin/X (miWindowExposures+0xc2) [0x45b762]
[ 50577.908] 12: /usr/bin/X (0x400000+0x13487d) [0x53487d]
[ 50577.908] 13: /usr/bin/X (miHandleValidateExposures+0x68) [0x5651f8]
[ 50577.908] 14: /usr/bin/X (UnmapWindow+0x240) [0x457380]
[ 50577.908] 15: /usr/bin/X (DeleteWindow+0x2b) [0x4573db]
[ 50577.908] 16: /usr/bin/X (FreeClientResources+0xdc) [0x44ea5c]
[ 50577.908] 17: /usr/bin/X (CloseDownClient+0x5a) [0x42f05a]
[ 50577.908] 18: /usr/bin/X (0x400000+0x2fae7) [0x42fae7]
[ 50577.908] 19: /usr/bin/X (0x400000+0x232fe) [0x4232fe]
[ 50577.908] 20: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7ffb69c3d30d]
[ 50577.908] 21: /usr/bin/X (0x400000+0x235ed) [0x4235ed]
[ 50577.908] Segmentation fault at address (nil)
[ 50577.908]
Caught signal 11 (Segmentation fault). Server aborting

x-Na 10-29-11 02:13 PM

Re: Segmentation fault and complete freeze with GT520
 
Quote:

Originally Posted by ledoc (Post 2496054)
Wow your X crashes a lot...
Did you try the 290 driver?


Just got it installed about 15 minutes ago. I'm guessing we'll now by tomorrow if it will fix this. I actually reinstalled my machine as it needed it anyways, but that didn't help, so from that point of view this seems to be a driver issue.

x-Na 10-31-11 05:50 AM

Re: Segmentation fault and complete freeze with GT520
 
So it seems that one reason for these freezes is running video using vdpau. Sometimes a vt switch, after I've watched a video with vdpau, done to other desktop and back to mine causes the complete freeze, but not always.

And for some reason it doesn't even write the segmentation fault errors to x.org.logs anymore, but it still does freeze the computer.

Deanjo 10-31-11 09:37 PM

Re: Segmentation fault and complete freeze with GT520
 
I don't know, I have several GT520 cards in heavy use in HTPC systems and they are constantly utilizing vdpau. I can't describe the experience with anything but rock solid. And these cards have been used from the 270 series of driver without anything really going wrong.

x-Na 11-01-11 01:43 AM

Re: Segmentation fault and complete freeze with GT520
 
Are you using gnome-shell and having multiple users logging in during the day? Or otherwise having many VT changes? The system is quite stable when I am the only one using it. Having other users logging in seems to cause trouble. Having firefox open may have some effect.

Anyways, I even went so far and created a new account to myself and I am copying all my data to that users directories so I can rule out any configuration setting in my personal config files.

Deanjo 11-01-11 05:24 PM

Re: Segmentation fault and complete freeze with GT520
 
Quote:

Originally Posted by x-Na (Post 2496801)
Are you using gnome-shell and having multiple users logging in during the day? Or otherwise having many VT changes? The system is quite stable when I am the only one using it. Having other users logging in seems to cause trouble. Having firefox open may have some effect.

Anyways, I even went so far and created a new account to myself and I am copying all my data to that users directories so I can rule out any configuration setting in my personal config files.

VT's, multiple users, FF are not an issue here. The only real difference is perhaps is that gnome is not present on the system (KDE and xbmc sessions are in heavy use however.)

x-Na 11-02-11 05:47 AM

Re: Segmentation fault and complete freeze with GT520
 
Quote:

Originally Posted by Deanjo (Post 2497071)
VT's, multiple users, FF are not an issue here.

In my point of view, this is the only issue I am having trouble with.

x-Na 11-04-11 02:47 PM

Re: Segmentation fault and complete freeze with GT520
 
How to rule out a faulty card? Any hints?

x-Na 11-13-11 01:06 PM

Re: Segmentation fault and complete freeze with GT520
 
Still nothing on this? Keeps happening with 290.06 drivers too.


All times are GMT -5. The time now is 05:48 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.