nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   A7N8X Deluxe memory and Linux install problems (http://www.nvnews.net/vbulletin/showthread.php?t=16842)

hyperion133 08-22-03 02:42 AM

A7N8X Deluxe memory and Linux install problems
I have tried to install SuSE 8.2, Mandrake 9.1 and Red Hat 9.0 on an Asus A7N8X Deluxe system.

The system is:

Asus A7N8X Deluxe mobo rev 1.04 bios 1004
2 sticks of Kingston 512 mb DDR RAM (1gb total)
Asus V9520 dual-head video card (FX5200)
3 Western digital 120gb HDDs
Plextor CD-RW
Plextor DVD/CD-RW
Antec True Power 480w PS

Actually there is another identical system that gives exactly the same problem.

Trying to install any of the Linuxes mentioned gives an introductory screen with installation/upgrade/etc options. After selecting the option to install nothing but a blank screen is the result. This hung me up for a long time but after switching out several things I finally found out that all Linuxes would install and run fine as long as only 1 memory stick was physically installed. If two are installed everything is blank as stated. Even after everything is installed and running with only 1 stick, shutting down and installing a second stick into a system that was running fine gives a system that will not boot into Linux at all, although there is no problem at all with booting Windows (XP Pro). And this has nothing to do with dual-channel mode, it happens regardless of which memory slots multiple sticks are installed in.

Has anyone else had this problem or know how to resolve it? I don't know if this is an Asus/nVidia issue or a kernel issue but limiting the system to 1 stick of RAM to run Linux isn't acceptable.

One thing I have noticed about posting regarding this mobo is a lot of people saying that any A7N8X before rev 2.0 will have problems, and if someone knows for a certainty that this problem is the result of a pre-2.0 board then any help thanks. But if it's just a guess then I'll say that I've never had any trouble at all with my rev 1.04s and I have watched others build systems with rev 2.0s that were returned to the store or sent back on RMA (6 out of 9 failures right out of the box) so I'm unlikely to suspect the board itself.

Any help appreciated.

StormWeaver 08-24-03 03:40 PM

I have the same issue here

My configuration :
Asus A7N8X Delux
Asus V9280
Athlon XP 2500+
1 GB of DDR3200
LG 16x DVD
LG 52x24x52 CD-RW

I have tried every other way to install any distribution , same thing happens , just a blank screen , will i have to change the MB to get it to work ?
Any feedback is appreciated

hyperion133 08-24-03 05:21 PM

Everything will work fine as long as only 1 DIMM is installed. Nothing works before or after installation with 2 or 3 DIMMs. Still waiting for anyone who knows why.

StormWeaver 08-24-03 06:19 PM

RH 9 works
still trying with Suse ( i am not a fan of RH) , i will let u know if i find anything

KillerFry 08-25-03 09:58 PM


For some reason SuSE install (and some others, I think Mandies too) don't like to have 1GB of RAM on them during the installation process. But once Linux is installed, you can pop the other RAM module right in!

That's what I did.

hyperion133 08-28-03 01:40 AM

Well I tried RH 9.0, Mandrake 9.2 and SuSE (preferred) 8.2 Pro and all had the same problem. More than 1 DIMM - blank screen after the welcome - new installation - kernel loaded screen. And installing with 1 DIMM and then after installation inserting another DIMM just gets the blank screen again.

tmb 09-12-03 08:18 AM


Originally posted by hyperion133
Everything will work fine as long as only 1 DIMM is installed. Nothing works before or after installation with 2 or 3 DIMMs. Still waiting for anyone who knows why.
The 2.4.21 kernel had a bug in the vesa framebuffer memory allocation,
wich shows up at systems with 1GB or more ram when used with graphic
cards with 64MB of ram or more....

There are many ways around it... (atleast for MDK 9.1)

boot with one of theese:

linux vga=normal
linux mem=800

boot / install with only 512MB in the system,
get the latest kernel from security updates, install it,
and now you can add your other memory module back...

You can also get my modified install boot disks at:

hyperion133 09-12-03 08:37 AM

Thanks for the info
I've been posting everywhere I know for more than three months on this. You're the first person who has tracked it to a kernel problem instead of grabbing at straws regarding the memory, mobo, power supply, etc, etc...


All times are GMT -5. The time now is 04:29 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.