nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVIDIA on openSUSE 12.1 problems (http://www.nvnews.net/vbulletin/showthread.php?t=168720)

microchip 11-15-11 03:23 PM

NVIDIA on openSUSE 12.1 problems
 
Hi,

I just upgraded my system to openSUSE 12.1 and after manually installing the NV drivers, I discovered a rather interesting problem.

Even though driver installation went without problems and glxinfo is reporting correct information, it appears as if my system is still using software rendering instead of hardware acceleration through the NV driver. Games are impossible to play (they render like 0.1 FPS and appear to hang), when scrolling in the browser, it gets stuck as well (the motion is not fluid at all). I even tried making an xorg.conf file but that didn't make a difference at all. I'm using a GeForce 6610 XL with the latest stable driver version 285.05.09 on Xorg 7.6

Does anyone have a clue what is going on?

Alex_T 11-17-11 12:27 AM

Re: NVIDIA on openSUSE 12.1 problems
 
Please make sure you do not have Nouveau driver installed. It interferes with the NV drivers the way you described.

microchip 11-18-11 07:16 AM

Re: NVIDIA on openSUSE 12.1 problems
 
Thanks, I seem to have sorted it out :)

MrAli 01-13-12 02:47 AM

Re: NVIDIA on openSUSE 12.1 problems
 
I recently onstalled Nvidia driver in openSUSE 12.1 useing one click install to increase my laptop performance but i feel my laptop after installing that driver has been slower. for example now Firefox act slower than before and scrolling up or down webpage is very slow, also scrolling in pdf documents has been slow.
some mounths ago when i had openSUSE 11.4 installed in this laptop, i installed Nvidia driver in it and in that case also this installation caused to slower performance in my laptop.
how can i solve the problem? (if there is any)
is this problem popular?

c_olsson 01-13-12 05:08 AM

Re: NVIDIA on openSUSE 12.1 problems
 
Quote:

Originally Posted by MrAli (Post 2519464)
I recently onstalled Nvidia driver in openSUSE 12.1 useing one click install to increase my laptop performance but i feel my laptop after installing that driver has been slower. for example now Firefox act slower than before and scrolling up or down webpage is very slow, also scrolling in pdf documents has been slow.
some mounths ago when i had openSUSE 11.4 installed in this laptop, i installed Nvidia driver in it and in that case also this installation caused to slower performance in my laptop.
how can i solve the problem? (if there is any)
is this problem popular?

I've this problem too. I've installed opensuse 12.1 (both 32 and 64 bit versions) into three totally different computers with old and new hardware and graphic cards and the problem is same: some of the graphic functions is not hardware rendered and the CPU will get a high load from the Xorg-process. The desktop is usable but slower on machines with nvidia cards than other (OLD!) cards like Matrox MGA.

I'm running the last nvidia driver (290). Games running in full screen mode use the hardware without problems and with full performance.

I haven't figured yet if the problem is in the nvidia driver or in x11. I't seems x11 don't use the hardware rendering even if it's present. glxinfo shows the rendering as activated.

It seems this problem may be addressed in the beta version 295 of the driver but I haven't tried it yet.

soramimo 01-16-12 06:30 PM

Re: NVIDIA on openSUSE 12.1 problems
 
I've been having the same problem with an insanely slow KDE experience (chrome scrolls so slowly, it's barely usable etc).

However, I fiddled around a bit and I seemed to have solved the problem. I haven't figured out, if any of these measures was solely responsible for the increased performance, but here is what I did:

- uninstalled nouveau driver
- used nomodset kernel parameter on boot

Also, I installed razor-qt to exclude any memory issues from KDE 4.7 and it seems to work quite nicely.

I'm on a Dell Vostro 1500 using a Geforce 8600M on the binary drivers (which worked just fine using openSUSE 11.4).

If anyone is interested, I can go ahead and track down what exactly did the trick.


Cheers,
Chris

MrAli 01-17-12 01:41 PM

Re: NVIDIA on openSUSE 12.1 problems
 
Quote:

Originally Posted by soramimo (Post 2520369)
If anyone is interested, I can go ahead and track down what exactly did the trick.
Chris

please do that ...

c_olsson 01-18-12 05:06 AM

Re: NVIDIA on openSUSE 12.1 problems
 
Installing KDE 4.8 RC2 (4.7.97) speeds up everything alot. It runs very much better than 4.7 but may be some difficult to install becauce all dependicies to solve.

soramimo 01-20-12 11:20 PM

Re: NVIDIA on openSUSE 12.1 problems
 
Quote:

Originally Posted by MrAli (Post 2520555)
please do that ...

Well ok, it seems like "nomodset" does not make a huge difference, but uninstalling nouveau helped a lot.

However, KDE is still quite slow sometimes, just from switching windows and desktops there are noticeable lags and the frame rate (which you can measure using a "desktop effect") goes from 60fps to 30fps.

These slow-downs don't occur in razor-qt, however it has other problems (such as missing wifi app), thus I'll also give KDE 4.8 a try or go back to KDE 4.6 until these problems are fixed.

soramimo 01-20-12 11:43 PM

Re: NVIDIA on openSUSE 12.1 problems
 
when doing some experiments, I noticed that kwin was eating up quite a few cpu cycles (25% constant cpu load), so I installed openbox-kde and this speeds things up quite a bit.

I'll keep testing, but this seems to be a reasonable solution for now...


All times are GMT -5. The time now is 08:40 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.