nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   sh NVIDIA-Linux-x86-1.0-4496-pkg2.run/PLEASE HELP ! (http://www.nvnews.net/vbulletin/showthread.php?t=16875)

Hatschi 08-22-03 02:57 PM

sh NVIDIA-Linux-x86-1.0-4496-pkg2.run/PLEASE HELP !
 
Hello!

Well, iam am very new in the linux scene and i had just for 3 days ago, installed suse Linux 8.2
I tried to install the Nvidia driver with the command:
sh NVIDIA-Linux-x86-1.0-4496-pkg2.run

Error message:
Unable to find the kernel header files for the currently running kernel. Please make sure you have installed the kernel header files for your Kernel; If you know the correct kernel header files are installed, you may specify the kernel include path with the ---kernel-include-path commandline option.

Well...

first, mya english ist not so good because i am german.... second i am verx new linux user and i dont know what i have to do right now ;)

please explain me step for step what i have to do right now, with all commands.... Copy Paste *gg*

kernel i guess i have if i saw that right: 2.4.20-100-i586 for athlon prozessors
Card: GF4 TI 4600 Plat.

thx all for help !!!

massimo 08-22-03 09:09 PM

Hi, I had the same problem and I have fixed it following the suggestions of great people of the forum.

Simply, before doing sh NVIDIA-Linux.....

download and install the source for your kernel (different from mine but I guess the method is the same)

Refer to the thread "RH9...Kernel...Nvidia..."

LucaMarcel 08-23-03 04:17 AM

Hi hatschi!
 
Hi hatschi!

I am German too,

Have you solved your problem?

I have discovered the same and can't find a solution.

Melde Dich!

Gruß LM

daimon 08-23-03 05:35 AM

(see below for a bad english translation)

hi hatschi,

ich habe das gleiche problem mit SuSE 8.2 und dem gleichen kernel (2.4.20-100). dieses problem tritt bei jedem kernel > 2.4.20-39 auf, da dieser bei der final release verwendet wurde, während alle anderen upgedated sind, so dass nVidia nur für den 39er vorkompiliert hat. die installation der entsprechenden kernel-sources haben bei mir auch nix bewirkt. eines der probleme ist, dass an der falschen stelle nach der datei kernel.h gesucht wird. gesucht wird in /lib/modules/2.4.20-4GB/build/include/linux/ während diese datei bei SuSE im verzeichnis /usr/include/linux zu finden ist. versuche mal folgendes:
sh NVIDIA-Linux-x86-1.0-4496-pkg2.run --kernel-include-path /usr/include
dadurch gibst du an, wo die datei kernel.h steckt. allerdings sucht es dann nach einer datei modversions.h, weswegen ich vorher im verzeichnis /usr/include/linux
cp kernel.h modversions.h ausgeführt habe.
wie auch immer, hat auch nicht geholfen :-(
-----------------------------------------

hi hatschi,

i have the same problem with SuSE 8.2 and the same kernel (2.4.20-100). this problem occurs with every kernel > 2.4.20-39, since this is the one the SuSE-team used for the final release, while every other is an update. nVidia has made a precompilation only for the 39-kernel. installing the kernel-sources didn't help on my system. one of the problems is, that it doesn't look at the right place for the file kernel.h. it searches in /lib/modules/2.4.20-4GB/build/include/linux/ while under SuSE it seems to be in /usr/include/linux.
try:
sh NVIDIA-Linux-x86-1.0-4496-pkg2.run --kernel-include-path /usr/include
with this option you specify the place of the file kernel.h. but then it searches for the file modversions.h (does anybody know why?). so i executed
cp kernel.h modversions.h
in the directory /usr/include/linux
before i retried.
however, it didn't work :-(

Hatschi 08-23-03 10:22 AM

Thx all !
 
Thx , it works ....


the tread "RH9...Kernel...Nvidia..." was very helpfull....

for all who get the same problem:


download the src.rpm from kernel...
rpm -ivh k_athlon-2.4.20-100.src.rpm

Init 3


sh NVIDIA-Linux-x86-1.0-4496-pkg2.run

it works !!!!

Well i guess i downgraded the kernel because after i runned yast online update it patched my kernel, but the was not a problem after i installed the nvidie driver ;) after i patched, than the kernel and Nvidia driver it still works;)


Thx all for help !!!


Hatschi


All times are GMT -5. The time now is 04:48 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.