nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   problem installing the drivers.. (http://www.nvnews.net/vbulletin/showthread.php?t=16882)

Zerodark 08-22-03 05:00 PM

problem installing the drivers..
 
I am using a GeForce 4 card, it's pretty old i guess now, but it works still :p I figured that since i'm using an AMD chipset, i should use the AMD64 drivers, so i downloaded them, followed the instructions to the best of my ability and quit the X server, tried to install the kernel module, and this is what i got:

cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -mcmodel=kernel -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=4180 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNV_64_BITS -DNVCPU_X86_64 -I. -I/usr/src/linux/include -Wno-cast-qual nv.c
cc1: code model `kernel' not supported in the 32 bit mode
nv.c: In function `nv_agp_translate_address':
nv.c:2756: warning: cast from pointer to integer of different size
make: *** [nv.o] Error 1


I've tried many times to get it installed but it doesn't seem to want to work. Any help would be appreciated. Thanks.

juddtaylor 09-23-03 10:52 AM

You should only use the AMD64 driver if you have one of AMD's 64 bit processors (currently, only the Opteron).

Use the IA-32 driver, or athlon if available.


All times are GMT -5. The time now is 06:51 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.