nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Epox 8RDA (http://www.nvnews.net/vbulletin/showthread.php?t=16969)

jimscafe 08-24-03 06:08 PM

Epox 8RDA
 
I have the Epox motherboard with onboard network card, sound, USB and Fire Wire (it also has graphics but I have also installed a separate gforce graphics adapter).

I am a real newbie (i.e. haven't yet got Linux to work correctly) and am trying to install the drivers for the network card.

My system is RedHat 9 and the kernel is version 2.4.20.8.

First I downloaded nvidia nforce-1.0-0261.rh90up 2.4.20.6.athlon.rpm and tried to install but it reported the wrong kernel version.

Then I downloaded Nvidia nforce-1.0-0261.src.rpm and tried to install using

rpm --rebuild - but it reported no --rebuild option (even though my book Linix in a Nutshell says it is a command)

Next I tired to install nvidia nforce-1.0-0261.tar.gz which I managed to unzip succesfully (!! thats how new I am!) and then typed make - but it came up with all sorts of errors. It started like this :-

[root@localhost nforce]# make
make -C nvnet
make[1]: Entering directory `/home/test/nforce/nvnet'
cc -c -Wall -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes
-DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -fal
ign-functions=4 -DMODULE -I/lib/modules/2.4.20-8/build/include nvnet.c
In file included from /usr/include/linux/module.h:20,
from nvnet.h:20,
from nvnet.c:21:
/usr/include/linux/modversions.h:1:2: #error Modules should never use kernel-hea
ders system headers,
/usr/include/linux/modversions.h:2:2: #error but rather headers from an appropri
ate kernel-source package.

As expected when I then tried make install - it didn't work.

What to do next??

(Before I even got the make command to work it complained that cc was not installed so I played about with the package applications software and tried to install everything in the developers section - then make at least started).

I am sure others have had the same problem but have been unable to find a similar thread except in the graphics forum by someone who had already installed different kernels - and still regarded himslef as a newbie! So I have some way to go yet..
:rolleyes:

keertib 08-31-03 06:08 PM

Check this out: http://www.pheran.com/nv7linux/
There is a nice RPM package there.

It works for my Epox 8RDA+


All times are GMT -5. The time now is 05:34 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.