nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X Server fails to start Fedora 16 GT330M (http://www.nvnews.net/vbulletin/showthread.php?t=170423)

anketell 12-15-11 01:10 AM

X Server fails to start Fedora 16 GT330M
 
1 Attachment(s)
Having just upgraded to Fedora 16, I am having trouble loading an nvidia driver. I have tried the standard package version 290.10 and have compiled several earlier drivers to no avail. All drivers report the following:

[ 24.810136] NVRM: failed to copy vbios to system memory.
[ 24.811605] NVRM: RmInitAdapter failed! (0x30:0xffffffff:861)
[ 24.811617] NVRM: rm_init_adapter(0) failed
[ 25.018686] NVRM: failed to copy vbios to system memory.
[ 25.020173] NVRM: RmInitAdapter failed! (0x30:0xffffffff:861)
[ 25.020185] NVRM: rm_init_adapter(0) failed
[ 25.209577] NVRM: failed to copy vbios to system memory.
[ 25.211061] NVRM: RmInitAdapter failed! (0x30:0xffffffff:861)
[ 25.211073] NVRM: rm_init_adapter(0) failed
[ 25.409101] NVRM: failed to copy vbios to system memory.
[ 25.410620] NVRM: RmInitAdapter failed! (0x30:0xffffffff:861)
[ 25.410632] NVRM: rm_init_adapter(0) failed
[ 25.601878] NVRM: failed to copy vbios to system memory.
[ 25.604997] NVRM: RmInitAdapter failed! (0x30:0xffffffff:861)
[ 25.605037] NVRM: rm_init_adapter(0) failed
[ 25.781421] NVRM: failed to copy vbios to system memory.
[ 25.782853] NVRM: RmInitAdapter failed! (0x30:0xffffffff:861)
[ 25.782864] NVRM: rm_init_adapter(0) failed

Previously, under Fedora 14, I needed to recompile driver 260.* as later drivers (packaged or otherwise) would not work. Unfortunately the 260.* driver will not compile against the 3.1.4 kernel of Fedora 16.

I have attached to output of nvidia-bug-report.sh

When run it reported the following three times:

NVIDIA: could not open the device file /dev/nvidia0 (Input/output error).

Any assistance in resolving this issue would be greatly appreciated.

leigh123linux 12-15-11 07:32 AM

Re: X Server fails to start Fedora 16 GT330M
 
post


Code:

lsmod |grep -e nouv -e nvid

anketell 12-15-11 02:02 PM

Re: X Server fails to start Fedora 16 GT330M
 
Quote:

Originally Posted by leigh123linux (Post 2511070)
Code:

lsmod |grep -e nouv -e nvid

Code:

nvidia              12112133  0
nvidiafb              36859  0
fb_ddc                  1447  1 nvidiafb
i2c_algo_bit            4958  1 nvidiafb
vgastate                5234  1 nvidiafb
i2c_core              25728  17 tuner_xc2028,dvb_usb_dib0700,dib7000p,dib0090,dib7000m,dib0070,dvb_usb,dib8000,dib9000,dib3000mc,dibx000_common,videodev,nvidia,nvidiafb,fb_ddc,i2c_i801,i2c_algo_bit

...and with nvidiafb blacklisted:

Code:

nvidia              12112133  0
i2c_core              25728  14 tuner_xc2028,dvb_usb_dib0700,dib7000p,dib0090,dib7000m,dib0070,dvb_usb,dib8000,dib9000,dib3000mc,dibx000_common,videodev,nvidia,i2c_i801


Plagman 12-15-11 03:26 PM

Re: X Server fails to start Fedora 16 GT330M
 
Please attach an nvidia-bug-report.log as per the sticky instructions. Also, can you clarify what kind of machine this is? (eg. model reference if it's a notebook computer or similar)

anketell 12-15-11 03:36 PM

Re: X Server fails to start Fedora 16 GT330M
 
Quote:

Originally Posted by Plagman (Post 2511278)
Please attach an nvidia-bug-report.log as per the sticky instructions. Also, can you clarify what kind of machine this is? (eg. model reference if it's a notebook computer or similar)

Thanks for your response.

Please see original post for nvidia-bug-report.log

The machine is a Toshiba Satellite A660

Everything worked fine with a 260.* driver, however this no longer compiles under later kernels.

anketell 12-16-11 04:58 AM

Re: X Server fails to start Fedora 16 GT330M
 
Further to this, cat /proc/driver/nvidia/gpus/0/information produces:

Code:

Model:                  GeForce GT 330M
IRQ:                    16
Video BIOS:          ??.??.??.??.??
Card Type:          PCI-E
DMA Size:          32 bits
DMA Mask:          0xffffffff
Bus Location:          0000:01.00.0

The drivers inability to query the vbios version would appear to be consistent with it's inability to copy the vbios to system memory. Is this a fundamental problem with later drivers and this GPU? Perhaps someone with greater insight can shed some light here.

anketell 12-19-11 03:59 PM

Re: X Server fails to start Fedora 16 GT330M
 
Superficially, it appears similar to an earlier issue:

http://www.nvnews.net/vbulletin/showthread.php?t=113929

But I'm unable to assess this.

anketell 01-16-12 04:08 AM

Re: X Server fails to start Fedora 16 GT330M
 
Have resorted to fedora 14 and driver 260.19.44 - NVIDIA's support for Linux is clearly not entirely comprehensive.

Moreover and more disappointing is that there was no clear indication of their position on this issue. At least be honest and transparent guys. My decision process would have been helped considerably if you had 'fessed up to not being able to help. Instead you chose to leave me in limbo.

Disclaimers aside, what is your true position on Linux drivers and support?

Plagman 01-18-12 10:58 AM

Re: X Server fails to start Fedora 16 GT330M
 
I did not chose to leave you anywhere; in fact, I've been actively trying to get access to a Toshiba Satellite A660 in the past weeks but couldn't get my hands on one.

There's a possibility you're hitting the same problem as described in this thread:

http://www.nvnews.net/vbulletin/showthread.php?t=166508

Please refer to that post for the latest update:

http://www.nvnews.net/vbulletin/show...0&postcount=19

anketell 02-19-12 11:50 PM

Re: X Server fails to start Fedora 16 GT330M
 
Ok - thank you.

I can certainly test driver fixes for you if that would help.

Plagman 02-21-12 04:10 PM

Re: X Server fails to start Fedora 16 GT330M
 
Hi anketell,

Can you please attach the output of the `acpidump` command?

anketell 02-24-12 05:15 PM

Re: X Server fails to start Fedora 16 GT330M
 
1 Attachment(s)
Quote:

Originally Posted by Plagman (Post 2530466)
Hi anketell,

Can you please attach the output of the `acpidump` command?

As requested - cheers.


All times are GMT -5. The time now is 01:45 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.