nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVaudio + Quake3 = Crash (http://www.nvnews.net/vbulletin/showthread.php?t=17060)

tourettes 08-26-03 11:02 AM

NVaudio + Quake3 = Crash
For the longest time, I have been having great problems with running Quake 3 with my nvidia nforce board in linux. I would be able to start the game, but when i go to "teleport" to a level, the game would freeze and cause me to kill the X server. This also happens in the Quake 3 mod Urban Terror but only when the theme music is played. Any other sound works.

So, it seems by reading the readme file that comes with the nforce drivers for linux that i need to disable SPDIF in the module in order to increase compatibility accross applications (allowing me less then 48Khz playback). So, here is my output:


$modprobe -v nvaudio spdif_status=0
Output of dmesg:

Nvidia + AC97 Audio, version 0.24, 02:26:39 Aug 26 2003
Nvaudio: in Funcction Nvaudio_init_module
PCI: Enabling device 00:06.0 (0005 -> 0007)
PCI: Setting latency timer of device 00:06.0 to 64
Nvaudio: NVIDIA nForce1 Audio found at IO 0xe000 and 0xe100, IRQ 11
Nvaudio: Audio Controller supports 6 channels.
NVaudio: Defaulting to base 2 channel mode.
ac97_codec: AC97 Audio codec, id: 0x8384:0x7609 (SigmaTel STAC9721/23)
Nvaudio: only 48Khz playback available.
Nvaudio: AC'97 codec 0 supports AMAP, total channels = 2
ac97_codec: AC97 Audio codec, id: 0x8384:0x7608 (SigmaTel STAC9708)
Nvaudio: only 48Khz playback available.
Nvaudio: AC'97 codec 1, total channels = 6
So, it appears that it did not work because i still get the "Nvaudio: only 48Khz playback available"

So, just to test it, I run quake3, here is the output (the relavent part):

----- finished R_Init -----

------- sound initialization ------
/usr/local/bin/quake3: line 5: 873 Segmentation fault ./quake3.x86 $*
An immediate seg fault with the nvaudio drivers. Here is the output from /var/log/messages when running Quake:


Aug 26 13:27:26 judith kernel: forget_pte: old mapping existed!
Aug 26 13:27:26 judith kernel: kernel BUG at memory.c:290!
Aug 26 13:27:26 judith kernel: invalid operand: 0000
Aug 26 13:27:26 judith kernel: CPU: 0
Aug 26 13:27:26 judith kernel: EIP: 0010:[<c0125657>] Tainted: P
Aug 26 13:27:26 judith kernel: EFLAGS: 00210282
Aug 26 13:27:26 judith kernel: eax: 00000021 ebx: 14830027 ecx: d53d8000 edx: dedbbf7c
Aug 26 13:27:26 judith kernel: esi: d4ad1668 edi: 0019a000 ebp: 14840000 esp: d53d9e8c
Aug 26 13:27:26 judith kernel: ds: 0018 es: 0018 ss: 0018
Aug 26 13:27:26 judith kernel: Process quake3.x86 (pid: 873, stackpage=d53d9000)
Aug 26 13:27:26 judith kernel: Stack: c0247aa0 001aa000 001aa000 146a6000 0019a000 d4c474d4 de8dcc40 4d5aa000
Aug 26 13:27:26 judith kernel: d4c474d4 00010000 d78fb7c0 d69d2740 d53d9ee4 e084bd4b 4d59a000 c72a6000
Aug 26 13:27:26 judith kernel: 00010000 00000027 d78fb7f4 d78fb7c0 00000000 d69d2740 d53d9f18 e084be8e
Aug 26 13:27:26 judith kernel: Call Trace: [<e084bd4b>] [<e084be8e>] [<c0126878>] [<c010c592>] [<c010730f>]
Aug 26 13:27:26 judith kernel:
Aug 26 13:27:26 judith kernel: Code: 0f 0b 22 01 1a 78 24 c0 e9 5e ff ff ff 8d b6 00 00 00 00 8d
So, i don't know where to go from here. Maybe I just need to use a different sound card. I have a Asus a7n 266-e motherboard with the sound on-board.

Oh yeah, and if i try to play any sounds back through Wine (such as when i try to play half life) the sounds are totally distorted, kind of like a 'chipmunk' sound.

Does anyone have any ideas or suggestions?

tourettes 11-20-03 02:13 PM

Anyone out there now that may possibly be able to help me with this problem? It's still an on-going issue.

I have been waiting for newer nforce drivers to test, but they don't seem to be coming out any time soon.

yanng 11-21-03 04:13 PM


Try to use the supplied i810_audio driver instead.

In file /etc/modules.conf add:

alias sound-slot-0 i810_audio

and remove all related nvaudio stuff.

This trick works on my:

Asus A7N8X2.0
Athlon XP 2500+ Barton
GeForce FX5200
nVidia nForce Drivers 261 mdk91
nVidia Graphics Driver 4363

Have fun ;)

tourettes 11-21-03 05:34 PM

Yeah, but i810_audio is not the issue, nvaudio is. The reason I need NVaudio is so I can play games like Quake3 and Urban Terror without experiencing audio problems. Currently, I can not play these games fully using the i810_audio or alsa drivers.

According to the readme file, this is a known issue and is fixed in nvaudio when passed the spdif_status=0 parameter to the module to turn off spdif output. However, when I use nvaudio, I get immediate seg fault. *Aparently* this is supposed to be fixed, but isn't. I have sent an email to the linux bugs email address and received no reply.

stiffux 11-24-03 01:52 PM


It seems there is a problem (perhaps more) with this driver or this motherboard.

I also meet problem. (see my post about "nvaudio driver problem" for more information).

I wrote to nvidia support I received first reply to ask me if I used the latest driver but from one week I have no feedback.

Don't hesitate to write to support : more there is mails to ask upgrade more luck we have to have one.

Another question to ALL who read this thread and meet problem with lastest audio driver (nvaudio before it was i810*) inform us on the forum.

I am curious to know if some meet same problem as us with another motherboard.

power to GPL ...

yanng 11-28-03 02:37 PM


I've used the 248 version on a mandrake 9.0 for a while, and all worked fine.

I've recently installed a 9.1, and when I've installed the nforce drivers 261, programs like xmms or xine work fine, but when I launched quake3arena, it crashes with a segmentation fault.

It seems that q3a is using 11Khz and 22Khz audio, so I've tried to append the spdif_status=0 in file modules.conf, but I get the same crash.

In fact, at the first launch, q3a crashes, then at the second launch, the game works, but no sound at all, even for all other programs.

I'm not using the 6 channel audio, so when I've replaced the nvaudio driver, all programs who use audio work fine, so I decided to use the i810 audio driver until that bug will be fixed.

I'm using 1.32b-3 Linux native q3a version with a windows version of the file pak0.pk3.

I've flashed the bios last week with a version 1007 (C18B1007.zip), a v1003 was shipped with the motherboard.

Hope this will be useful :confused:

tourettes 11-28-03 03:20 PM

No offense, but i'm very much glad that i'm not the only one who experiences these problems. I was begining to think it was a specific hardware problem with what I purchased.

What happens is that after the initial seg fault in quake3, the nvaudio module locks the /dev/dsp file not allowing any other programs to access it, and prevents you from unloading the module. The next time that Quake3 starts, it gives up on sound, and skips it.

I'm going to send another email to Nvidia on this, this needs to be resolved. This was supposed to be fixed in the last driver release, even the release notes states that it's fixed, but it's not.

Soul-Crusher 11-30-03 01:58 AM

It's an mmap audio bug in Quake 3. I have a friend who is having this exact problem on his i810.

Supposedly, Forceware 1.0-0261 fixes this.

tourettes 12-08-03 11:30 PM

Yeah, by the sounds of the changelog, this problem should be fixed. I have yet to get a response back from NVidia tech support regarding the issue, and it's been almost 6 months since the last nforce driver release (I reported this problem in July probably).

I hope that it comes out soon, it's very frustrating having to restart my Xserver each time i go to do something in Quake3.

fdawg4l 12-23-03 08:22 PM

keep hoping
Im almost positive that nvidia will not release a driver that will allow for any sampleing rate other than 48khz on the nforce boards. I have an nforce with a soundstorm and after much probing and poking around in the nvidia driver, I realized its the same "cursed" (it actually says that in the code) driver as i810_audio. Apparenlty we're using the AC97 chip instead of the MPT which does all of the fun 6 channel audio stuff. They will not release the code or white papers. I threw an SBLive in my box just so I could get GOOD audio, let alone anything other than 48khz; something with the ac97 chip causes buzzing in my speakers and the same goes for my laptop which uses the same chip. There is currently a petition at www.nforcershq.com (look in the forums, then linux) to get nvidia to do something, but they probably will not.

Here's my theory -
Dolby Digital is patented (obviously) and therefore not open source. I have a feeling that nvidia and intel are simply using the DSP to do all of the 6 channel dolby decoding which means that the assembly code that sets up the DSP would probably have to be binary only since open source is out of the question. A binary only driver would probably need to be licensed which, obviously, wont happen. We can get a SPIDF out if we prod enough, providing the spidf doesnt go anywhere near the DSP.

Home theater and good quality audio just wont happen unless the manufacturers use REAL hardware decoding and not using programmable DSPs which load their routines via the OS. Linux is at a downfall here which really sucks considering im a Linux person and an audio engineer. Im stuck rebooting forever.

BTW, there is 1 card that does dolby prologic in linux, but i believe it only worked with an older 2.4 kernel and the control app isnt really supported anymore.

All times are GMT -5. The time now is 03:50 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.