nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nVnet with RH9 (http://www.nvnews.net/vbulletin/showthread.php?t=17131)

nvidiausr 08-27-03 08:55 PM

nVnet with RH9
I've just installed RH9 on my new biostar M7NCG board with nforce2. Everything works fine except I can't get the NIC running. I installed both of the RPMs on Nvidia's site:



nvnet (eth0) shows up when I go to install a ethernet card, so I choose that, but when you click activate I get the message "nvnet device doesn't seem to be present, delaying initialization" I also get this message on reboot. I checked the modules.conf and it has the line: alias eth0 nvnet.

I tried adding insmod eth0 at the bottom, but that just ended up giving all sorts of errors on reboot.

What do I need to do here?

nvidiausr 08-27-03 09:09 PM

Just read on this same forum that others have had the same trouble with RH9. One guy said to do the following:

1. download the newest driver
2. extract
3. cd to driver directory (/complete/path/to/nforce/nvnet)
4. make && make install
5. reboot

However, I'm pretty much a newbie when it comes to Linux. cd I'm guessin is change directory command as in the 'ol dos days. What is the step 4 though (make && make install)???

geowiz 08-27-03 10:36 PM

Make and make install
make and make install are the commands that compile the driver and then do the installation based on the information in Makefile in the same directory.

If you've compiled it before, it needs to be "cleaned up" prior to making the module so I think it's a little safer to:
make clean (cleans up the old stuff)
make (invokes the compiler)
make install (installs the file, sets permissions and owner)

Hope that helps understand the commands. They are generic and used all the time to build drivers, compile programs, build the kernel etc. Even if you use rpm or deb packages, those commands are used if you use the source rpm's - it's just that the rpmbuild invokes those commands for you ;-)

nvidiausr 08-27-03 10:58 PM

Ah ha, I see. So I guess RH already has a compiler built in to use? Looks like I need to go over to their site and do some reading. -thanks

geowiz 08-27-03 11:15 PM

It is available for installation on the CD's. If you chose to install the "development tools" it will be there. To check: rpm -q gcc . That will tell you if the GNU C compiler is installed. It is needed to compile new kernels and other applications but seldom needed otherwise if you only install binary programs.

Red Hat, SuSE, Mandrake etc normally have a large number of GNU and Open Source programs, often in the 1000's of packages. The GNU tools include the compilers - c, c++, fortran, ........

Explore the application - you'll be amazed as to what's available! Enjoy !

nvidiausr 08-28-03 01:00 PM

Got the NIC to finally be recognized!!! Thanks so much for the guidance. I had to install the GNU compiling utilities, but is was actually not too tough. However, I can't get my connection going. It hangs for a while and then fails on the eth0 on bootup, then when on the desktop and I choose to initialize, I get the same kinda result, searches for a while, then nothing. I tried putting in PRI and SEC DNS but that didn't seem to help.

Is it crucial to put a hostname as well? I'm sure there's something that needs to be changed on the settings, but can't figure out just what. But I think I about got this beast tamed. I'm using a cable modem by the way, and it works with my other system fine.

nvidiausr 08-28-03 04:52 PM

Well I'm thinkin' this must be a problem related to insmod or modprobe. I tried adding a insmod eth0 line into the modules.conf file. That just caused errors.

When I type ifconfig in a terminal, the eth0 shows up, but there is no IP address.

I also checked with a cat ifcfg-eth0 , and


all are showing up.

When I did the tarball, I extracted to a new tmp folder, and only did the make, make install in the nvnet subfolder, so it wouldn't screw up the audio. Sure got me stumped here.

geowiz 08-28-03 06:39 PM

Looks like the driver is there. check to see if it is loaded by /sbin/lsmod and seeing if nvnet is listed. If so, then it's probably the network config.

Quick question ... you indicate that you are on cable. Can I assume the cable modem is handling the connection stuff and you are just getting an address from the cable box via dhcp? If it is only a cable modem, it is possible that you need to be running pppoe or pppoa back to the cable place.

One way to check is boot into the other OS, go to system, drivers, network, tcpip and see if there is an installed pppoe driver.
You can also check RH9 to see if the dhcp client was installed by: rpm -q dhclient otherwise dhcp will not get an address.

If the nvnet is installed and loaded then you need to check the network config and make sure it is correct. BTW, the line in the modules should look like this alias eth0 nvnet and the kernel will load it on boot.

You can also look in the system log (var/log/messages) and see what's happening. You should see:
Aug 26 10:35:10 sysname kernel: nvnet: module license 'NVIDIA' taints kernel.
stuff removed
Aug 26 10:48:24 sysname dhclient: DHCPREQUEST on eth0 to 206.180.xxx.xx port 67

If no "taint" warning then module is not loaded and if no DHCP lines then the dhcp is not starting correctly.

Sorry I can't add much else but without more info it's a bit difficult to diagnose the problem.

nvidiausr 08-28-03 06:49 PM

With lsmod it shows nvnet, size 30720, used 0, other columns blank. Gotta check the rest.

nvidiausr 08-28-03 07:25 PM

Well I found on the win98 system DNS is disabled, so I guess that means it uses DHCP. I looked and looked and couldn't find a PPPoe driver. I have run RH8 on the same win98 system before and the NIC worked fine.

When I typed rpm -q dhclient, it replied: dhclient3.0 something

Then looking through the system log messages using the desktop tools and system log message utility, I found that there was no mentioning of "taint" or "DHCP" and I even double checked w/ the filter utility and the system log didn't contain either.

Also found on the win box that disable wins resolution is selected, and use DHCP for wins resoulution is unckecked.

geowiz 08-28-03 07:46 PM

well ...
Ok, so we know that the driver is loaded. But no address. I would use the network config tools that RedHat provides and reconfigure eth0.

I no longer run a "standard" RH9 and don't use their tools (net setup or firewall). I have dual net cards etc. So, other than suggesting that you retry setting up the network via their tools I have reached the end of what I can help you with .......

If network is starting dhclient you can look to see if it does by ps -ef | grep dhclient you should see something like /sbin/dhclient -1 -q -lf /var/lib/dhcp/dhclient-eth1.leases -pf /var/run/dhclient-eth1.pid .

Only other thought is to run dhclient from the command line (as root) and see if it reports errors without logging them.

Good luck ...

nvidiausr 08-28-03 08:03 PM

Yeah man, thanks a ton for the help on this ugly mother. I've been through hell and back several times on this new Biostar based system with the nForce chips. win98 wouldn't even install on this system for a dual boot. Don't know why Nvidia, Biostar, and the rest of em can't get their acts together and produce some products that actually work, without all the fuss. Sheez, if I woulda forseen all this garbage, I would of just ordered another older MSI AMD761 based board that works.

Big thanks though for enduring all this drama. I'll give those suggestions a try before I get out the sledgehammer.:D

All times are GMT -5. The time now is 12:08 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.