nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Xlib: extension "XFree86-DRI" missing on display ":0.0". (http://www.nvnews.net/vbulletin/showthread.php?t=17237)

Prommy 08-30-03 02:17 AM

Xlib: extension "XFree86-DRI" missing on display ":0.0".
 
Hi.
I get the above error message from some xscreensaver savers. I checked with ldd which libraries are being used. The interesting one is /usr/X11R6/lib/tls/i686/libGL.so.1, which was wrongly linked (to libGL.so.1.2 in the same directory). When I move the link to instead pointing to /usr/lib/tls/libGL.so.1 everything works fine.

The problem is it seems that every time XFree86 is restarted the not-working link is restored to it's faulty state. Anyone knows why this is?

/Daniel

dpw2atox 08-30-03 01:15 PM

im using redhat 9.0.93 sevren and it has the same problem. Since XFree86 4.3.0-17 and up in rawhide this has continued to cause a problem for me. I just installed 4.3.0-3 which comes with rh9 and it works fine again. Hopefully they will fix this issue soon.

Prommy 08-30-03 02:27 PM

Hmmm... Posted a bug in redhat bugzilla. They claims it's not a bug. I still not know what to do about it. Do you?

https://bugzilla.redhat.com/bugzilla....cgi?id=103437

/Daniel

Prommy 08-31-03 03:08 AM

Ok. I've got it working now. Seems like the only alternative was to do a "rpm --nodeps -e XFree86-Mesa-libGL".

I don't like the --nodeps argument though. It usually messes things up. This should be fixed in some nicer way, either by Redhat or Nvidia...

/Daniel

davess4 08-31-03 08:19 PM

I am having the same problem.
 
Hey...
I've been having the exact same problem except I do not understand now you fixed it. I tried running that command but I get package not found. I've tried downgrading drivers but none seem to work with my kernel. Any help would be much appreciated, this is a pain in the butt.

-Dave

Prommy 09-01-03 01:01 PM

Are you sure you wrote the command exactly correct? If you did and got that result it means you haven't got XFree86 libGL installed, and then I can't really say what's causing your trouble.

Running a "rpm -qa XFree86*" should give you a list of all installed XFree86 packages on your system.

/Daniel

dpw2atox 09-01-03 04:37 PM

well thats screwed up then....thanks for the info though....i'll be sure to make that change when the next beta of redhat comes out and I install it and then the nvidia drivers.

sphincter 09-04-03 09:54 PM

I came up with a sort of work around. I copied the nvidia lib to that directory and renamed it, after renaming the original. Now it works and I don't have to do that every time I reboot, as seldom as that may be.


All times are GMT -5. The time now is 04:43 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.