nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Low performance with SuSE 8.2 (http://www.nvnews.net/vbulletin/showthread.php?t=17321)

g.schwann 09-01-03 08:28 AM

Low performance with SuSE 8.2
 
Hi!

I do have poor performance with my setup. "gears" shows me only ~1000 FPS (should be >5000).

My setup:
Pentium4 2.2 GHz
Quadro4 200/400 NVS
1 GB RAM

SuSE Linux 8.2
NVidia Driver 4496

glxinfo:
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
...
OpenGL version string: 1.4.0 NVIDIA 44.96

ldd /usr/bin/gears:
libglut.so.3 => /usr/lib/libglut.so.3 (0x40024000)
libGLU.so.1 => /usr/lib/libGLU.so.1 (0x4005c000)
libGL.so.1 => /usr/lib/libGL.so.1 (0x400f6000)
libc.so.6 => /lib/libc.so.6 (0x4015f000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x40295000)
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x4029d000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x402a6000)
libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x402be000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x402d4000)
libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x402e3000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x402eb000)
libm.so.6 => /lib/libm.so.6 (0x403b9000)
libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0x403db000)
libdl.so.2 => /lib/libdl.so.2 (0x408b4000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x408b7000)

cat /proc/driver/nvidia/agp/status:
Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled


The nvidia driver is correctly loaded. But The OpenGL-performance is pretty bad. With Windows XP OpenGL works pretty fast.

Does anyone have a clue why my OpenGL-performance is that bad (it seems Software rendering is still used at some places :( )?

ciao

pe1chl 09-01-03 01:25 PM

gears, with default window size, gives me about 2500 fps on SuSE 8.2, with an FX 5200 card, and Pentium 4 at 2533 MHz.

Gyokuran 09-01-03 06:30 PM

strange, it gives me about 2700-2800 fps with the default window size.

CPU: amd athlon-tbird 1400
GPU: Geforce3 Ti 200

glxinfo says:
OpenGL renderer string: GeForce3/AGP/3DNOW!
OpenGL version string: 1.4.0 NVIDIA 43.63

cat /proc/driver/nvidia/agp/status:
Status: Enabled
Driver: NVIDIA
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

(it is the nVidia agp-module since the kernel agp-module doesn't support high rates for my VIA KT400)

I'm using the 43.63 version as the newer version has some performance reduction (go figure).

g.schwann 09-02-03 02:18 AM

Quote:

Originally posted by pe1chl
gears, with default window size, gives me about 2500 fps on SuSE 8.2, with an FX 5200 card, and Pentium 4 at 2533 MHz.
Have a look at these examples:
http://sdb.suse.de/de/sdb/html/wessels_3d_results.html

I'm getting the same results with my "graphics-workstation" at work (P4 2.2, Quadro 4) as with my Notebook (Athlon XP 2000, Gefore Go32). Which is about the same as an Athlon 850 with Matrox G400!
Softwarerendering with my "workstation" gives me 250-300 FPS (Hardware is only 3-4 times faster!)

ciao

Moled 09-02-03 04:07 AM

5900 ultra/ 3ghz p4

default window size, fsaa disabled etc


44215 frames in 5.0 seconds = 8843.000 FPS
44198 frames in 5.0 seconds = 8839.600 FPS
44231 frames in 5.0 seconds = 8846.200 FPS
44207 frames in 5.0 seconds = 8841.400 FPS


and with 0 window size


93941 frames in 5.0 seconds = 18788.200 FPS
94050 frames in 5.0 seconds = 18810.000 FPS
93781 frames in 5.0 seconds = 18756.200 FPS

Gyokuran 09-02-03 06:06 AM

Quote:

Originally posted by g.schwann
Have a look at these examples:
http://sdb.suse.de/de/sdb/html/wessels_3d_results.html

Good to know that; in that case my performance more or less fits in with the examples (2700-2800 with athlon 1400, GeForce3 Ti 200, 24 bit depth)


All times are GMT -5. The time now is 08:07 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.