nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   FX 5200 Dual View + REDHAT 9 (http://www.nvnews.net/vbulletin/showthread.php?t=17337)

Error6666 09-01-03 01:03 PM

FX 5200 Dual View + REDHAT 9
 
I have installed a FX 5200 Dual View card in RedHat 9.
However when I start X I get the following error msg,

(EE) NVIDIA(0): No modes remaining for display device CRT-0

(EE) Screen(s) found, but none have usable configuration

Could anyone please help me out with this. I have followed the instructions in the XF86config.example file but I still get this error msg.

mesters 09-08-03 04:07 AM

Yes, I have seen that one several times.

Delete all stuff that has to do with modes-lines and have the software work out the mode that can work with your dual-setup. In my case I had the frequencies to high and just not enough memory for running both monitors (only 128mb....).

Just copy the lines below into your /etc/X11/XF86Config file.

Here are the relevant lines from my twinview setup:

Section "Monitor"
Identifier "Monitor[1]"
ModelName "FP1702"
VendorName "DELL"
HorizSync 31-80
VertRefresh 56-65
EndSection

Section "Monitor"
Identifier "Monitor[0]"
ModelName "P1130"
VendorName "DELL"
HorizSync 30-130
VertRefresh 80-170
EndSection

#Section "Modes"
# Identifier "Modes[0]"
#EndSection

#Section "Modes"
# Identifier "Modes[1]"
#EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1280x1024"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "Quadro4 900XGL"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Option "Dac8Bit"
Option "NvAGP" "3"
Option "Stereo" "3"
Option "Rotate" "off"
Option "ConnectedMonitor" ""
Option "NoTwinViewXineramaInfo"
Option "TwinView" "on"
Option "MetaModes" "1280x1024 , 1280x1024"
Option "TwinViewOrientation" "Rightof"
Option "SecondMonitorHorizSync" "31-80"
Option "SecondMonitorVertRefresh" "48-65"
Screen 0
VendorName "NVidia"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen 0 "Screen[0]" 0 0
EndSection

crazyme9 09-09-03 06:55 PM

i did those changes and i get the same problem and error. here is a copy of my XF86Config:

Section "Module"
Load "dbe"
Load "record"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
Load "v4l"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
ModulePath "/usr/X11R6/lib/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "AutoRepeat" "250 30"
Option "XkbRules" "xfree86"
Option "XkbModel" "microsoft"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Buttons" "5"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "Resolution" "300"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor[0]"
ModelName "Unprobed Monitor"
VendorName "Monitor Vendor"
HorizSync 31.5-37.9
VertRefresh 50-70
EndSection

Section "Monitor"
Identifier "Monitor[1]"
ModelName "Unprobed Monitor"
VendorName "Monitor Vendor"
HorizSync 31-80
VertRefresh 56-65
EndSection

Section "Device"
BoardName "Gforce FX 5200"
Identifier "Device[0]"
VendorName "nvidia"
Driver "nvidia"
BusID "PCI:2:09:0"
Option "Dac8Bit" "3"
Option "TwinView" "on"
Option "Stereo" "3"
Option "Rotate" "off"
Option "NoTwinViewXineramaInfo" "1"
Option "NvAGP" "3"
Option "ConnectedMonitor" ""
Option "TwinViewOrientation" "RightOf"
Option "SecondMonitorHorizSync" "31-80"
Option "SecondMonitorVertRefresh" "48-65"
Option "MetaModes" "1024x768,1024x768"
Screen 0
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
Subsection "Display"
Depth 24
EndSubsection
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
Screen 0 "Screen[0]" 0 0
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
Option "Xinerama" "off"
Option "Clone" "off"
EndSection

mesters 09-10-03 04:05 AM

Hmmmm, your HorizSync 31.5-37.9 of monitor[1] does not make to much sence to me. There is indeed no mode left to be used.

Use the program gtf and try it yourself:

gtf 1024 768 37.5 (resolution x y and refresh)

The answer you get is

# 1024x768 @ 37.50 Hz (GTF) hsync: 29.44 kHz; pclk: 37.68 MHz

At 37.5Hz, hsync is 29.44kHz...... not within the ranges you defined! Nothing will fit, sorry.

Are you really sure about the values?

crazyme9 09-10-03 10:50 AM

yeh 95% sure i have been playing with this config file for about 2 days and im still stuck. If you are familiar with IRC go to server irc2.beyondirc.net channel #devshed or #UFSS, also what should the monitor hsync ranges be?? I have a Dell flat screen not lcd its newer model i dont know which one exacly tho, and i have a compaq presario mv400.


All times are GMT -5. The time now is 07:13 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.