nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   290.xx and 295.17 menus drawing incorrectly (http://www.nvnews.net/vbulletin/showthread.php?t=173375)

bitter 02-03-12 03:10 AM

290.xx and 295.17 menus drawing incorrectly
 
This has been going on for a few versions now. Some menus just will not draw or draw incorrectly. I can mouseover and off, it may work, it may not. It is not very random and is easily replicable.

It seems to be mostly gtk apps (screenshots are eclipse, firefox does it too). kde/qt apps seem to be immune.

screenshots - http://img31.imageshack.us/img31/4748/badnvidia.png
xorg.conf - http://pastebin.com/z383xCcw
GeForce GTS 250 / xorg-server-1.11.4 / kde 4.8.0 / linux 3.2.2 64bit / gentoo

poltsy 02-03-12 06:25 AM

Re: 290.xx and 295.17 menus drawing incorrectly
 
Noticed the exact same thing on GTS 450 a while ago when debian started pushing xserver 1.11 in unstable. Going back to xserver 1.10 from backports made the issue disappear so I completely forgot about it.

weltall 02-03-12 06:56 AM

Re: 290.xx and 295.17 menus drawing incorrectly
 
Quote:

Originally Posted by poltsy (Post 2525535)
Noticed the exact same thing on GTS 450 a while ago when debian started pushing xserver 1.11 in unstable. Going back to xserver 1.10 from backports made the issue disappear so I completely forgot about it.

same on 8600MGT the only thing that i changed was the x.org server when it started happening some year ago. if you use more than one monitor you might get the menu to open on a screen and the same coordinates of the opened menu get erased in the other monitor (you see the desktop wallpaper). I also get gnome widgets not rendering or windows showing behind rendering above. (even though they answer to commands too so logically they seems above even if from the look of it they seem behind).

mooninite 02-03-12 11:28 PM

Re: 290.xx and 295.17 menus drawing incorrectly
 
I'm not seeing any of this on xorg 1.11, 3.2.2 kernel, gnome-shell 3.2 on the 290.xx driver. GeForce 9 series cards (and a laptop). TwinView or no TwinView.

ledoc 02-04-12 12:34 AM

Re: 290.xx and 295.17 menus drawing incorrectly
 
Yeah, same problem here for some time now. I agree it probably came with the 1.11 xserver update some time ago.
amd64/FX880/various kernels.

Did anybody try 1.12rc?

ispmarin 02-28-12 07:47 PM

Re: 290.xx and 295.17 menus drawing incorrectly
 
Same problem here, Debian Sid and Testing, KDE 4.6 and 4.7. Any news? Xserver 1.11

Licaon 02-29-12 05:28 AM

Re: 290.xx and 295.17 menus drawing incorrectly
 
nvm

Konker 03-11-12 08:45 AM

Re: 290.xx and 295.17 menus drawing incorrectly
 
Any news on this bug? I have the same.

bitter 03-20-12 09:08 PM

Re: 290.xx and 295.17 menus drawing incorrectly
 
I was hoping xorg 1.12 would fix it but no such luck. Using same xorg.conf, 295.20, Gentoo x64.

Plagman 03-20-12 11:15 PM

Re: 290.xx and 295.17 menus drawing incorrectly
 
Are you using a composite manager?

bitter 03-21-12 02:20 PM

Re: 290.xx and 295.17 menus drawing incorrectly
 
yes, kwin.

Plagman 03-21-12 06:57 PM

Re: 290.xx and 295.17 menus drawing incorrectly
 
Does reverting to a regular window manager (eg., disabling desktop effects) affect this issue at all?


All times are GMT -5. The time now is 07:52 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.