nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   [Regression] 295.17 / 295.20 segfault when searching in gnome3 (http://www.nvnews.net/vbulletin/showthread.php?t=174049)

Dragoran 02-14-12 03:33 AM

[Regression] 295.17 / 295.20 segfault when searching in gnome3
 
1 Attachment(s)
When searching in gnome3 (pressing windows key and start typing) the driver gnome-shell segfaults inside the driver:

[ 23.595372] gnome-shell[1800]: segfault at 10 ip 00007fbde9126c0f sp 00007fbda67fb658 error 6 in libnvidia-tls.so.295.20[7fbde9126000+300

It happens in 1 out of 2 tries. I tried to get a decent backtrace but it seems to work fine when running inside gdb.

It works fine with all previous driver releases I tested with (including 295.09).

leigh123linux 02-14-12 06:34 AM

Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3
 
It does the same here


Code:

[leigh@main_pc ~]$ rpm -qa *\nvidia\* gnome-shell |sort
akmod-nvidia-295.20-1.fc16.x86_64
gnome-shell-3.2.2.1-1.fc16.x86_64
kmod-nvidia-3.2.5-2.fc16.x86_64-295.17-1.fc16.1.x86_64
kmod-nvidia-3.2.5-3.fc16.x86_64-295.20-1.fc16.x86_64
nvidia-settings-1.0-16.fc16.x86_64
nvidia-xconfig-1.0-16.fc16.x86_64
xorg-x11-drv-nvidia-295.20-1.fc16.x86_64
xorg-x11-drv-nvidia-libs-295.20-1.fc16.i686
xorg-x11-drv-nvidia-libs-295.20-1.fc16.x86_64
[leigh@main_pc ~]$ uname -r
3.2.5-3.fc16.x86_64
[leigh@main_pc ~]$


dudez 02-15-12 08:24 AM

Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3
 
I've two machines both running ArchLinux/64, however this problem *always* happen on only one so i downgraded to 290.10.. don't get what's up with the other machine, the new 295.20 doesn't crash there.
However, i thought the update would fix some long-standing, gnome-shell related problems, such as the one triggered by resizing Blender windows that will entirely crash gnome-shell, also after login everything seems to load fine, but inspecting dmesg i usually find at least one message such as:

Code:

gnome-shell[1106]: segfault at 58 ip 00007f778a110b08 sp 00007f775a04ff88 error 4 in libpangoft2-1.0.so.0.2904.0[7f778a0fd000+2b000]
..or in libnvidia-glcore or in libnvidia-tls or even libfreetype2..:(

Kaurin 02-15-12 01:06 PM

Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3
 
This happens to me too. After downgrading to 290.10 the problem no longer occurs. Arch Linux x86_64

Kaurinov 3.2.5-1-ARCH #1 SMP PREEMPT Tue Feb 7 08:34:36 CET 2012 x86_64 Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz GenuineIntel GNU/Linux

lui75 02-15-12 01:57 PM

Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3
 
I've deleted all .* dirs and files related to Unity and GNOME and GNOME Shell does not crash anymore while writing on dash search bar.

Dragoran 02-15-12 03:54 PM

Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3
 
Quote:

Originally Posted by lui75 (Post 2528972)
I've deleted all .* dirs and files related to Unity and GNOME and GNOME Shell does not crash anymore while writing on dash search bar.

Ah thanks.

It seems to be caused by old cache files in ~/.nv/GLCache .. removing or renaming that directory fixes it.

Bevan 02-15-12 04:11 PM

Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3
 
Quote:

Originally Posted by Dragoran (Post 2529003)
It seems to be caused by old cache files in ~/.nv/GLCache .. removing or renaming that directory fixes it.

For me removing the ~/.nv folder solved the problem only for a short moment. A bit later it reappeared :(

Dragoran 02-15-12 04:14 PM

Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3
 
Quote:

Originally Posted by Bevan (Post 2529004)
For me removing the ~/.nv folder solved the problem only for a short moment. A bit later it reappeared :(

Does setting GLShaderDiskCache to 0 in xorg.conf help?

Bevan 02-15-12 04:28 PM

Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3
 
Quote:

Originally Posted by Dragoran (Post 2529007)
Does setting GLShaderDiskCache to 0 in xorg.conf help?

Unfortunately not. I successfully deactivated the disk cache, so there is no .nv directory anymore. But when I'm doing the search, that failed before this change, two times the second time it leads to a segfault in libnvidia-tls.so.

davezerave 02-15-12 06:14 PM

Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3
 
experienced the same with 295.20 on Archlinux and Kernel 3.2.5.
Awkward issues with some (only some?!) search parameters in gnome-shell.

downgrading to 290.10 solved the issue for me so far.

Please fix, because switching resolutions/screens seems to have been speeded up whilst looking less "glitchy"! Surely would like to use that! :)

enigmatichus 02-15-12 06:47 PM

Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3
 
Same issue here, removing ~/.nv/GLCache did not fix the problem for me so far.
Downgrading to 290.10 (on Arch Linux i686 with gnome-shell) solved the issue. I hope a fix will be published for 295.20 soon as it solved another annoying bug I have (system lags when I unlock screen and when I bring laptop up from suspend).

senjik 02-15-12 06:57 PM

Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3
 
I have the same problem . i pray for a quickly solucion


All times are GMT -5. The time now is 02:39 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.