nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia, SuSE8.2, kernel-2.4.20-4GB-athlon (http://www.nvnews.net/vbulletin/showthread.php?t=17409)

83mercedes 09-03-03 01:00 AM

nvidia, SuSE8.2, kernel-2.4.20-4GB-athlon
 
Hi all, I have searched this forum, cannot find an answer to this, have the above named kernel, but the kernel-source installed obviously doesn't match, have tried IGNORE_CC_MISMATCH along with the --kernel-include-path options,( nvidia geforce4 Ti-4400 video card.)
Not able to install driver, it compiles it, but then "Unable to load the kernel module 'nvidia.o'." error.
Am ripping my hair out,
PLEASE help! :confused:

83mercedes 09-03-03 01:44 AM

Found a half-a**ed way around this, uninstalled the 'athlon' kernel & re-installed the default kernel.
But I am sure there is a way I can use both the athlon-optimised kernel AND nvidia drivers, correct?

zander 09-03-03 05:04 AM

Yes; what's the exact error message, i.e. why does the module fail to load, specifically?

83mercedes 09-03-03 08:07 AM

Thanks for the reply-

ERROR: Unable to load the kernel module 'nvidia.o'. This is most likely
because the kernel module was built using the wrong kernel header files.
Please make sure you have installed the kernel header files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel header
files are installed, you may specify the kernel include path with the
'--kernel-include-path' commandline option.
-> Kernel module load error: ./usr/src/nv/nvidia.o: kernel-module version
mismatch
./usr/src/nv/nvidia.o was compiled for kernel version 2.4.20-4GB
while this kernel is version 2.4.20-4GB-athlon.

unhappy_mage 09-03-03 09:23 AM

Quote:

If you know the correct kernel header files are installed, you may specify the kernel include path with the '--kernel-include-path' commandline option.
-> Kernel module load error: ./usr/src/nv/nvidia.o: kernel-module version
mismatch
./usr/src/nv/nvidia.o was compiled for kernel version 2.4.20-4GB
while this kernel is version 2.4.20-4GB-athlon.
if you have the origional redhat disks, then you should be able to find the 'kernel-source-athlon' rpm, or something like that, somewhere. Install this, and then your problems should go away. hopefully. maybe.

cosborn 09-03-03 03:40 PM

Hello,

here was my solution to the problem. Become root for all steps.

First remove any kernal-source rpms you have on the system. Then go to /usr/src and delete the kernel source directory, usually linux-2.4.xx.SuSE. Then go back and install the kernel-source rpm. Now use Yast Online update to update the kernel-source package to the current set.

After that, open a terminal and go to the /usr/src/linux directory. The linux is acutally a link that should be updated by the rpm. If not make it point to the kernel source directory. Ok, in the directory /usr/src/linux run the following:

make cloneconfig

make dep clean

Both should run without errors and may take awhile depending on the machine.

now cd to

/usr/src/linux/include/linux/

view the file version.h

now run 'uname -r' If the versions match then go to console 1 (ctrl+alt+f1) and change to run level 3 (init 3 as root) to kill the xserver. If they don't match then you still need the correct source. You can manually get the source for your kernel from the kernel.org site.

Extract the nvidia install package with the --extract-only switch.

change into the nvidia directory and then to ./usr/src/nv

edit the Makefile in this directory to include the following line:

IGNORE_CC_MISMATCH=1

This will ignore the gcc version problem. I got the error even though my kernel was compiled by the same version gcc.

now change back to the base nvidia directory (cd ../../..) and run the nvidia_installer executable.

The installer should now compile and insert without problems.

Reboot to run level 3, don't let an xserver start after the reboot.

Do not use sax to set up your display!

Manually edit the XF86config file using the options in the nvidia readme to set up your graphics card. Hopefully you had a running xserver before so you just need to modify the device section. If not, then good luck building an XF86config file. It is not too hard. You can find templates.

Then test your xserver (startx). It should work provided there are no typos.

Good Luck!

Chris

cosborn 09-03-03 05:46 PM

Hi again.

Here was the machine that I set up the nvidia graphics on for the above post:

-Dual p3 1gig with 1GB memory on Supermicro P6DGU
-SuSE 8.2
-2.4.20-64GB-SMP kernel from SuSE
-ACPI turned ON
-GeFORCE FX 5200 on the PCI bus driving two 25 inch SGI HDTV Monitor (16:9 aspect ratio)
-GeFORCE 2 GTS on the AGP bus driving a standard 17 inch monitor

When my xserver is running the two HDTV monitors are one huge desktop and the 17 inch is a seperate server. I use the machine for high end cad work so the second server is essentially used for email and web browsing. Anyhow, hope any of this helps.

Here are some sections of my XF86Config file to help with the config part. Make sure that X11 is not trying to do any Xinerama if you are using multiple monitors. And again...

DO NOT USE SAX to set up your nvidia display device. It will not correctly set it up.

If you still want to use SAX, make sure you have downloaded the switch2nvidia script from SuSE and make sure you run the script.

However I find that SAX will still always try and load the nv driver, which is not what you want.


From My XF86Config:

Section "Device"
BoardName "GeForceFX 5200"
BusID "0:13:0"
Driver "nvidia"
Identifier "Device[0]"
VendorName "NVidia"
Option "NvAGP" "1"
Option "TwinView" "1"
Option "ConnectedMonitor" "CRT, CRT"
Option "TwinViewOrietation" "RightOf"
Option "SecondMonitorHorizSync" "30.0-96.0"
Option "SecondMonitorVertRefresh" "48.0-160.0"
Option "MetaModes" "1600x1200,1600x1200; 1600x1200,NULL"
EndSection

Section "Device"
BoardName "GeForce2 GTS"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[1]"
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
Screen "Screen[1]" RightOf "Screen[0]"
EndSection

83mercedes 09-03-03 07:22 PM

I really appreciate the responses, I guess my main deal is this:
I know the kernels don't match, because I can't locate an 'athlon' kernel-source, while I have already the 'athlon' kernel.
Question:
Is there an 'athlon' kernel-source package that I just can't find? Other than on a Red-Hat Cd, (which, by the way, I don't have).
Thanks again.

cosborn 09-04-03 07:03 AM

The kernel sources you donwloaded contain all sources you need, just not in the way you need them. That is what the 'make cloneconfig' does. When you run this command on your sources it looks at your current kernel and makes a clone for the sources which contains the same .config file used to initially compile the current running kernel (provided it is a SuSE kernel if you are using the kernel-source package). Remember that my kernel is smp, which there is no smp kernel source package. I had to make one using the cloneconfig switch. You then run 'make dep clean' to make all the dependencies and to clean up the compiler junk.

If that still doesn't work then you can copy the vmlinuz.version.h and vmlinuz.autoconf.h files (in /boot) to the '/usr/src/linux/include/linux' directory which will make the sources look like they match. copy the files to simply version.h and autoconf.h so you have:

/usr/src/linux/include/linux/version.h
/usr/src/linux/include/linux/autoconf.h

You might want to rename the ones in there before you copy over them.

Good luck.

Chris

edited some typos. 4/sep/2003

83mercedes 09-04-03 08:13 AM

Thanks a lot, I will give it another try this evening.

83mercedes 09-04-03 06:38 PM

cosborn,
Thanks again for the help, and taking the time to explain...
that finally got me going! :D

cosborn 09-04-03 07:19 PM

Glad to have been of help!


All times are GMT -5. The time now is 05:54 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.