nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   295.20 x86_64 gnome3 (gdm) crashes on startup (http://www.nvnews.net/vbulletin/showthread.php?t=174242)

mephist0 02-16-12 10:43 AM

295.20 x86_64 gnome3 (gdm) crashes on startup
 
1 Attachment(s)
Hi,

I'm using gentoo linux x86_64 on Intel i7, Intel DP67BG motherboard, nvidia Geforce 590 GTX with MultiGPU enabled. LCD is HP zr30w.

Would like to use the 30bit colors on 295.20 drivers ;)

I cant login to gdm:

Code:

/etc/init.d/xdm start
it crashes even before the login screen is displayed with that error:

Code:

------------[ cut here ]------------
WARNING: at arch/x86/mm/ioremap.c:102 __ioremap_caller+0x382/0x3b0()
Hardware name:       
Modules linked in: nvidia(P) vmnet(O) vmblock(O) vsock(O) vmci(O) vmmon(O) w83627ehf hwmon_vid coretemp snd_seq_midi snd_seq_oss snd_seq_midi_event snd_seq snd_pcm_oss snd_mixer_oss uvcvideo videodev v4l2_compat_ioctl32 snd_virtuoso snd_oxygen_lib snd_pcm snd_timer snd_page_alloc snd_mpu401_uart snd_rawmidi firewire_ohci e1000e snd_seq_device firewire_core i2c_i801 3w_9xxx [last unloaded: nvidia]
Pid: 23003, comm: Xorg Tainted: P          O 3.2.1-gentoo-r2 #5
Call Trace:
 [<ffffffff81046cfb>] ? warn_slowpath_common+0x7b/0xc0
 [<ffffffff81024842>] ? __ioremap_caller+0x382/0x3b0
 [<ffffffff810cdf1f>] ? kfree+0xf/0xa0
 [<ffffffffa14bef41>] ? _nv014557rm+0xeb/0x10b [nvidia]
 [<ffffffffa0e0f42e>] ? _nv009538rm+0x89/0x142 [nvidia]
 [<ffffffffa0e0f59f>] ? _nv014127rm+0xb8/0x102 [nvidia]
 [<ffffffffa0e0fa52>] ? _nv014167rm+0x58/0x9e [nvidia]
 [<ffffffffa0e0aa68>] ? _nv014137rm+0xbe/0x2f0 [nvidia]
 [<ffffffffa0e0ad45>] ? _nv014172rm+0xab/0x174 [nvidia]
 [<ffffffffa0e0ae5e>] ? _nv014136rm+0x50/0x5d [nvidia]
 [<ffffffffa0e11eb6>] ? _nv014112rm+0x9ef/0xb29 [nvidia]
 [<ffffffffa14d2c3f>] ? _nv012389rm+0x174/0x662 [nvidia]
 [<ffffffffa14d2bbd>] ? _nv012389rm+0xf2/0x662 [nvidia]
 [<ffffffffa0e58931>] ? _nv003997rm+0x1e5/0x1deb [nvidia]
 [<ffffffffa1235f1b>] ? _nv004022rm+0xa96e/0xd078 [nvidia]
 [<ffffffffa123461d>] ? _nv004022rm+0x9070/0xd078 [nvidia]
 [<ffffffffa0dd568e>] ? _nv009823rm+0x25/0x40 [nvidia]
 [<ffffffffa14d2951>] ? _nv014614rm+0x7c8/0x942 [nvidia]
 [<ffffffffa14d3aa1>] ? _nv001086rm+0x522/0x7a1 [nvidia]
 [<ffffffffa14ca49c>] ? rm_init_adapter+0xae/0x1bb [nvidia]
 [<ffffffffa14ec064>] ? nv_kern_open+0x3f4/0x7b0 [nvidia]
 [<ffffffff810d6240>] ? mount_fs+0xd0/0xd0
 [<ffffffff810d6a60>] ? cdev_put+0x30/0x30
 [<ffffffff810d6b77>] ? chrdev_open+0x117/0x200
 [<ffffffff810d0f22>] ? __dentry_open.clone.16+0x242/0x370
 [<ffffffff810dc9ce>] ? path_get+0x2e/0x60
 [<ffffffff810e0df7>] ? do_last.clone.39+0xb7/0x7f0
 [<ffffffff810e1658>] ? path_openat+0xd8/0x420
 [<ffffffff810e1add>] ? do_filp_open+0x4d/0xc0
 [<ffffffff810edd54>] ? alloc_fd+0xe4/0x140
 [<ffffffff810d1f3f>] ? do_sys_open+0xff/0x1e0
 [<ffffffff815206bb>] ? system_call_fastpath+0x16/0x1b
---[ end trace d4bd45f8b6810a4d ]---


I tried to disable the GL cache option in xorg.conf and deleted ~/.nv/. But still no go.

I am now on 285.05.09 and it works pretty well.

nvidia-bug-report log file is attached.


All times are GMT -5. The time now is 03:32 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.