nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Cannot install nvidia 256.53 drivers on 3.1.2 kernel (http://www.nvnews.net/vbulletin/showthread.php?t=174530)

igor012 02-21-12 09:34 AM

Cannot install nvidia 256.53 drivers on 3.1.2 kernel
 
Hello,
I have been trying to install NVIDIA-Linux-x86_64-256.53 found here on a 12.1 opensuse with a 3.2.1 kernel.

In the nvidia-installer log file :
Code:

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 256.53.
-> Running distribution scripts
  executing: '/usr/lib/nvidia/pre-install'...
-> done.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Using the kernel source path '/usr/src/linux/source' as specified by the
  '--kernel-source-path' commandline option.
-> Kernel source path: '/usr/src/linux/source'
-> Kernel output path: '/usr/src/linux/source'
ERROR: If you are using a Linux 2.4 kernel, please make sure
      you either have configured kernel sources matching your
      kernel or the correct set of kernel headers installed
      on your system.

      If you are using a Linux 2.6 kernel, please make sure
      you have configured kernel sources matching your kernel
      installed on your system. If you specified a separate
      output directory using either the "KBUILD_OUTPUT" or
      the "O" KBUILD parameter, make sure to specify this
      directory with the SYSOUT environment variable or with
      the equivalent nvidia-installer command line option.

      Depending on where and how the kernel sources (or the
      kernel headers) were installed, you may need to specify
      their location with the SYSSRC environment variable or
      the equivalent nvidia-installer command line option.

I used this command "sh NVIDIA-Linux-x86_64-256.53.run --kernel-source-path="/usr/src/linux/source"

I have also tried to use a patch -> there.

Can somebody help me ?

Thank you

Dragoran 02-21-12 09:45 AM

Re: Cannot install nvidia 256.53 drivers on 3.1.2 kernel
 
Why are you trying to install an ancient driver on a recent kernel?
Any reason why you can't just use a newer driver?

igor012 02-21-12 09:52 AM

Re: Cannot install nvidia 256.53 drivers on 3.1.2 kernel
 
It is a certified autodesk driver. I can't use any other ones.

igor012 02-22-12 05:19 AM

Re: Cannot install nvidia 256.53 drivers on 3.1.2 kernel
 
No one can help me ?

krokodil 02-22-12 05:56 AM

Re: Cannot install nvidia 256.53 drivers on 3.1.2 kernel
 
It's a mismatch of header files and installed kernel.
It works fine here (even with an older driver: 173.14) on an old AGP system (Quadro FX 3000).
You'll have to check that kernel running and kernel sources against you want to build the driver are the same. No one can do this check for you.

igor012 02-22-12 10:40 AM

Re: Cannot install nvidia 256.53 drivers on 3.1.2 kernel
 
Ok, i'll check
i'll let you know

thanks

igor012 02-23-12 05:17 AM

Re: Cannot install nvidia 256.53 drivers on 3.1.2 kernel
 
It seems to be using the correct ones. but it may be possible that the installer cannot find them.
They are located under /lib/modules/linux-3.1.2-1.4-desktop. I have also created a symbolic link between /usr/src/linux and /lib/modules/3.1.2-1.4-desktop.

Any ideas ?

krokodil 02-23-12 06:57 AM

Re: Cannot install nvidia 256.53 drivers on 3.1.2 kernel
 
Quote:

Originally Posted by igor012 (Post 2530873)
It seems to be using the correct ones. but it may be possible that the installer cannot find them.
They are located under /lib/modules/linux-3.1.2-1.4-desktop. I have also created a symbolic link between /usr/src/linux and /lib/modules/3.1.2-1.4-desktop.

Any ideas ?

Header files under /lib? There must be something very strange on your system.
Headers here are under /usr/src/linux-3.1.4* and related subdirectories.

pc-aurora:/home/hmayer # cd /lib
pc-aurora:/lib # find . -name "*.h" -print
pc-aurora:/lib #
pc-aurora:/usr/src # find . -name "*.h" -print | more
./linux-3.1.9-1.4-obj/i386/desktop/include/config/dm/zero.h
./linux-3.1.9-1.4-obj/i386/desktop/include/config/dm/multipath/ql.h
./linux-3.1.9-1.4-obj/i386/desktop/include/config/dm/multipath/st.h
./linux-3.1.9-1.4-obj/i386/desktop/include/config/dm/delay.h
./linux-3.1.9-1.4-obj/i386/desktop/include/config/dm/raid.h
etc.
I would advise you make sure you really have system sources installed and installed into the correct places.
Sorry I can't be more specific but that would be my first guess: incomplete or not correctly installed sources.

igor012 02-23-12 07:36 AM

Re: Cannot install nvidia 256.53 drivers on 3.1.2 kernel
 
you are right my headers are missing.
Correct me if i am wrong but i need the headers related to my new kernel. if so, i have to copy them from somewhere, right ?

krokodil 02-23-12 09:56 PM

Re: Cannot install nvidia 256.53 drivers on 3.1.2 kernel
 
Quote:

Originally Posted by igor012 (Post 2530884)
you are right my headers are missing.
Correct me if i am wrong but i need the headers related to my new kernel. if so, i have to copy them from somewhere, right ?

Yes. My first guess would be your distribution media (DVD) or you could try and install from the net.
In yast > software > repositories you could select community repositories and select sources.

igor012 02-24-12 02:55 AM

Re: Cannot install nvidia 256.53 drivers on 3.1.2 kernel
 
In /usr/include i have found many ".h" files.
So those are the headers i guess, but of which kernel ?

Gusar 02-24-12 03:47 AM

Re: Cannot install nvidia 256.53 drivers on 3.1.2 kernel
 
Guessing won't bring you far. There must be a package with kernel headers that match your running kernel. I don't use Suse, so I don't know how the package is called. But the distro for sure has documentation about it.


All times are GMT -5. The time now is 03:10 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.