nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Does it work for anyone ? (http://www.nvnews.net/vbulletin/showthread.php?t=17464)

cedricorban 09-03-03 09:48 PM

Does it work for anyone ?
Can't get the driver to work properly with Geforce4
I get random X Freeze. X Spins on I don't know what. Can't Alt-F1 , Ctrl-Alt-backspace.
The only way out is killall -9 X by login from another machine
I have Mandrake 9.1
I redid a 2.4.22 kernel
I tried NvAGP "0"

It freezes randomly apparently when there is other I/O activity. It hangs wheter or not
doing openGL
I have a ASUS P4S533 / P4 2.4Ghz motherboard with SIS chipset and 1 GB with Bigmem config

Here is part of my log file

Driver only sees 32 Mb of mem eventough card BIOS reports 64MB at boot
I Changed AGP aperture to 128 MB to no avali.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NvAGP" "0"
(**) NVIDIA(0): Use of AGP disabled per request
(--) NVIDIA(0): Linear framebuffer at 0xF0000000
(--) NVIDIA(0): MMIO registers at 0xDF000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce4 MX 440
(--) NVIDIA(0): VideoBIOS:
(--) NVIDIA(0): VideoRAM: 32768 kBytes
(II) NVIDIA(0): Connected display device(s): CRT-0
(--) NVIDIA(0): Detected TV Encoder: NVIDIA
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 8 bpp: 350 MHz
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 16 bpp: 350 MHz
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 32 bpp: 350 MHz
(II) Loading sub module "ddc"

blanny 09-05-03 09:21 PM

I have the same problem with a geforce 4 ti 4200.

dalek 09-05-03 10:01 PM

Same here
I have a Chaintech FX5200 w/128MB and have a very similiar problem. I been researching this and have found that agpgart is not supported. I'm still looking for a fix.

If you look through your syslog through Mandrake Control Center you may find the same error. This sort of ticks me. I bought a NVIDIA for the support they have compared to ATI. I hope they will fix this soon. Another video card is starting to look good.

I guess there are more people in the boat with me. Keep bailing, please.

:D :D :D :D

cedricorban 09-05-03 10:31 PM

I don't think it is a problem with agpgart. I've tried disabling it and it makes no difference. I 've also enabled log in the nvidia module and it seems that the module keeps running ( it keep logging stuff) even when my X is frozen. I think it is a bug in the X server because it happens with differen card . I've seen the problem on a Dell server at work with a Quadro FX500.
I also got the Nvidia card because it is fast and I thought well supported. Now I'm back to my original ATI card.

Seth 09-06-03 12:33 AM

I had the same problem using a G4Ti4600. I found that if I toned down the AGP setting from 4x to 1x my system had stability. Now I don't mean tune down your AGP options within the XF86config-4 file, because I too did this and got nowhere. I lowered my AGP in my Bios and this seemed to help. I found that once I did this the system seemed to run longer before it hung.

I'm not sure if this was the correct cure, but I finally corrected my freezes by setting my bios back to its default settings. Since I've done this, Mandrake 9.1 runs stable and my OpenGl applications run like a champ. After doing this, I let my system run for 4 days, and it ran rock solid.

I have a Gigabyte GA -7VRXP mb and within the section that controls the graphics, I have options such as aperature size, strentgh of the signal and settings such as Ultra, Fast...you get the picture.
I had my aperature set as 128 and my setting at Ultra along with other things. Linux and Windows didn't seem to handle these setting very well and always resulted in a crash, infinite loop, or some other type of headache. Again, for you, I suggest setting your Bios to its default and then give Mandrake a try.

For your problem with the driver only seeing half of your video memory I don't have a clue. Sorry!

As for the agpgart, this should not be a problem for you. I might be mistaken, but I thought the problem only existed for users using AMD (athlon) processors.

More then anything it sounds as if your proplem lies within your motherboards bios. Best of Luck.

dalek 09-06-03 02:29 AM

Here's error meessage
This is the error from syslog:
Sep 4 18:00:22 smoker kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Sep 4 18:00:22 smoker kernel: agpgart: Maximum main memory to use for agp memory: 439M
Sep 4 18:00:22 smoker kernel: agpgart: unsupported bridge
Sep 4 18:00:22 smoker kernel: agpgart: no supported devices found.
Sep 4 18:00:22 smoker modprobe: modprobe: insmod agpgart failed
Sep 4 18:00:22 smoker kernel: 0: NVRM: AGPGART: unable to retrieve symbol table

Yea, I named it smoker. It's a lot faster than my old 400MHz machine. he he he he he

I did a google search for this error and got over 200 links to this problem. It's growing.

It seems that agpgart is not supported in the Kernal and NVIDIA needs to come up with a module for it. I think I'll be looking for another video card before to long. I'm hoping 9.2 will help. :D :D

Mine will run for a week or two though before crashing.

Here's to hoping.

:D :D :D :D

AndyNicholson 09-06-03 09:35 AM

For agpgart add the line:
options agpgart agp_try_unsupported=1
in your /etc/modules.conf

I started getting the X freeze when I updated my LM9.0 kernel to 2.4.19-35 from 2.4.19-32 (and increased RAM to 768MB).
Reducing by BIOS AGP multiplier reduced its frequency, but did not fix it. I still don't have the solution.

I've found I can get out of a freeze by using
Alt-PrintScreen-k (see /usr/src/linux/Documentation/sysrq.txt)

dalek 09-06-03 12:09 PM

Yeh, I know
AndyNicholson: I have put that in there. It seems a bit more stable but it still doesn't have the agpgart support and does not work as it should. It has crashed since I added the line to. I think it, agpgart support, needs to be added to the kernel or a module that works made by NVIDIA.

I wish I could find a e-mail address for NVIDIA. I looked on their site but didn't find one. I keep all my data on a seperate drive so to find a fix, I don't care if I crash the OS and have to reinstall. I just want the end result to be my system is stable and so will a lot of other people. Make sense??

NVIDIA, are you reading this????

:confused: :D :D :D

AndyNicholson 09-06-03 02:27 PM

With the
options agpgart agp_try_unsupported=1

line I get syslog of:

Sep 1 23:19:56 domus kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Sep 1 23:19:56 domus kernel: agpgart: Maximum main memory to use for agp memory: 690M
Sep 1 23:19:56 domus kernel: agpgart: Detected AMD 761 chipset
Sep 1 23:19:56 domus kernel: agpgart: AGP aperture is 64M @ 0xd8000000

Adding the agp_try_unsupported line was all I can remember doing to there from the same unsupported bridge bridge error (it was 2 years ago).

I think the freezing is unrelated. I had no problems for nearly two years. My freezing problem started recently (at same time as a kernel and memory change). I've tried going back to old nvidia drivers and they all now show the same problem. From the news groups there are others out there with this problem, and no good answers.

Sorry I can't help - I need the answer as much as you!

dalek 09-06-03 03:00 PM

Maybe, but not for me
When I put "nv" in the XF86Config-4 file, I have no problems with the crashing. Not once. Sometimes it won't last a few days when "nvidia" is in the XF86Config-4 file.
Basically when loading the drivers it crashes, when it doesn't use the drivers it's stable.

I WANT A FIX NVIDIA!!! Maybe I should have bought a ATI card. :confused: :confused:

:rolleyes: :rolleyes: :rolleyes:

AndyNicholson 09-07-03 05:25 PM

:bash: Well, do I feel silly.

I finally realized that I could, and probably should have been using NVagp (which does support my AMD 761) rather then AGPGART which doesn't (hence my options agpgart agp_try_unsupported=1).
Swapping was easy - Option "NvAGP" "1" - in XF86Config-4.

As my problems started with a new kernel (and hence new agpgart) I'm hoping this fixes things for me. I'll be back if it doesn't.

AndyNicholson 09-09-03 06:18 AM

Well that only lated a day before freezing.
NVagp and agpgart seem to work equally well and freeze equally badly for me.

On to try something else.

See " X freeze on Mandrake(and other) solved!!" thread.

All times are GMT -5. The time now is 07:03 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.