nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   2.4.21 / 2.4.22 Nvidia 4496 corrupted display after X logout. (http://www.nvnews.net/vbulletin/showthread.php?t=17471)

Pagan 09-04-03 02:53 AM

2.4.21 / 2.4.22 Nvidia 4496 corrupted display after X logout.
 
I"m running SuSE Linux with a custom 2.4.21 / 2.4.22 kernel build. I've tried the installer and compiling drivers myself. I get the same result all ways...

After I end my x session and return to text mode, my screen is corrupted and I can't see anything.
Only solution is have is to blindly type:
shutdown -r now
and let it reboot.

I'm running a GeForce4 440 AGP
IRQ:16
Video BIOS: 04.17.00.45.00
Kernels 2.4.21 & 2.4.22
GigaByte 845PE667Ultra2 mobo
512 MB DDR ram
SuSE Linux 8.1 pro.

THe same drivers run fine on wife's geforce2 and my son's 5200.

Any suggestions?

frycarson 09-05-03 12:43 AM

I have the same problem with the corrupted display

Pentium Celeron
Geforce 4 MX440 128 ram AGP

anyone have suggestions other then an older driver?

Frycarson

UPDATE:

the 1.0-4363 driver in Nvidia's archive won't cause corruption. It might just be an issue for now.

Pagan 09-06-03 04:50 AM

More Info...
 
I just upgraded to SuSE Linux 8.2 Pro and the problem remains...

Wonder why it's fine in the previous version?

Ran the installer upon installation finalization, and got the same results...
3-D is fast in X, but upon logout it's corrupted...
I guess If I ran at graphical login it's fine, but what do ya do the first time ya need a text console?

My son's running the same MoBo as I am, with a 5200 card and it's fine.

Wife's PC is running a GigaByte socket 370 series with a Geforce2 FX with newest drivers, hers is fine too...

another_mike 09-10-03 07:57 PM

Hi folks.

The same with me!

1.0-4496:
No errors during installation.
3D acceleration works fine, but no terminal is visible. :confused:

1.0-4363:
Everything works fine.

A little system information:
Suse 8.2 (FTP installation)
standard kernel 2.4.20, updated via Yast Online Update

AOpen BX-Board
Celeron 1000 FCPGA2 running on modified Socket370-Adapter
ASUS V3800 Deluxe (Riva TNT2 AGP Board, 32MB)

I can live with the 'old' driver, but it would be nice to benefit of the latest features/fixes.


I hope, anybody will reply.

Thanks in advance,
mike

another_mike 09-10-03 08:18 PM

Hi, again.

Maybe, I found the solution for this strange behaviour:

Quote:

After trying to get the twinview going i have the exact same "garbled screen after switching from x to terminal" problem!!

Ive found that this only happens with my tv hooked to the card. pulling the cable from the tv without any changes to the config stops this odd behavior....
hmmm these colours really look like a 1982 vga game

but.... would be great to fix this problem, because i like the 2d speed of the new driver set so much!


best,
lars
I haven't tried to reinstall the latest driver, but: My TV is hooked to my graphics card.... :angel2:

mike

dj1471 09-11-03 07:20 AM

I am also having this problem with the following setup: -

Redhat 9
Kernel 2.4.22-ac1
GeForce 440 Go

It's nothing to do with TV out...

I hope nVidia fix this in the next release - it's driving me mad!

Pagan 09-11-03 09:38 PM

Quote:

Originally posted by another_mike
Hi, again.

Maybe, I found the solution for this strange behaviour:



I haven't tried to reinstall the latest driver, but: My TV is hooked to my graphics card.... :angel2:

mike

I'm not running tv out, and there's no cable or anything hooked up to that port... Only change is the nvidia drivers...

And BTW the nvidia installer did NOT install the nvigia gl headers into /usr/include/GL on three tested systems! I've had to manually copy them into place, and recompile wine... just a heads up!

pe1chl 09-12-03 04:14 AM

What could help is to change the handling of the textmode screen from that FB stuff that SuSE is using into a normal text console.

I think there is an option for this somewhere.

I am running SuSE 8.2 myself, but I recompiled the kernel (for another reason) and while doing that I removed the FB support.

It then boots up with a standard dull 80x24 text screen instead of the nice graphic screen with SuSE logo, but I don't care.
I did this after reading about difficulties switching between X and textmode screens.
At first it worked fine, but after I had configured my card to use 2 X screens (CRT and TV) the trouble returned. Now, when I switch to textmode, that is output on the TV. The CRT has text but it is not updated when I type.

Well, why would one want to exit X?
Use graphical login, and shutdown from the login screen.

Pagan 09-13-03 02:49 AM

FrameBuffer and Exiting X
 
I had some suspicions about that... I've tried it with vga=792 vga=exteneded, and no vga kernel parameter... same result and this is a custom 2.4.22 kernel build...

And to answer your question about exiting x:
I do a lot of work in a text console... both remote and local... liek forexample when compiling something large I'll use vc2 [ctrl+alt+f2] to compile and then switch back to x with alt+f7

Sometimes I won't be in x for days...

yS_ 09-13-03 04:42 AM

There is another post about this. Perhaps it can help you.

http://www.nvnews.net/vbulletin/show...&threadid=6611


All times are GMT -5. The time now is 05:37 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.