nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   "agpgart: unsupported bridge" error (http://www.nvnews.net/vbulletin/showthread.php?t=17487)

dalek 09-04-03 11:19 AM

"agpgart: unsupported bridge" error
 
1 Attachment(s)
I don't think I'm the only one with this but I can't find a fix. It also makes 'x' very unstable as in crashes. Hardware is in sig below. Here is some of the errors:

dmesg
0: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4496 Wed Jul 16 19:03:09 PDT 2003
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: unsupported bridge
agpgart: no supported devices found.
0: NVRM: AGPGART: unable to retrieve symbol table
spurious 8259A interrupt: IRQ7.

Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: unsupported bridge
agpgart: no supported devices found.

I'll attach a copy of XFree86.0.log. The sys logs are the same or seem so.

I can run fine with the driver "nv" in the XF86Config-4 file. I don't seem to have any hardware problems, bad power, memory, mobo etc with it that way. But when I put 'nvidia' in the XF86Config-4 file I run into stability problems that are really strange.

If needed I can reinstall the OS with different settings if needed.

Any ideas?? I hope.

:confused: :D :D :D

zander 09-05-03 04:17 AM

It seems that Linux AGPGART doesn't support whichever chipset you are using and that the NVIDIA driver is falling back to its builtin AGP GART driver. The NVIDIA README has an AGP and general stability section, you may want to try some of the suggestions found there (i.e. changing AGP configuration settings, disabling rivafb/vesafb, UP I/O APIC, ACPI, ...).

dalek 09-05-03 10:15 AM

Done did
 
Already done vesa//rivafb. Also tried the I/O settings. X crashed :mad: . I'll try the APIC and ACPI next.

What gets me is I bought NVIDIA because it was supposed to work. But it don't. Well, it does it just makes it unstable. If I wanted a OS that crashes and all that crap I would use Windoze. :rolleyes:

I'm going to put a post in the official thing and see if they need a little white mouse to experiment on.

Thanks for the post. Kind of confirms what I have read. Is there a video card that works perfectly with Linux??????? About a $70.00 or $80.00 AGP one????

Thanks fo rthe info zander.

:D :D :D

westep23 09-09-03 10:54 PM

Just so you know AGPGART is part of the linux kernel not nvidia one. I had this problem up untill the 2.4.22 kernel. try to pass "agp_try_unsupported=1" to the agpgart module when you load it. What kind a chipset you got.

dalek 09-10-03 12:25 AM

Get ready for this
 
It's NVIDIA. I assume you are talking about the mobo chipset?

I did disable APIC, still same error though. I also tryied the agp_try_unsupported=1 and another one that I can't recall at the moment. It had "3" in it and nv*. Same error. It doesn't, or at least hasn't, crashed though. I just hate errors.

Any more ideas short of shooting it or beating it with a hammer. I got a little three pound sledge in the shop. Be right back . . . . . .


:kill: :kill: :D :D

westep23 09-14-03 07:31 PM

What kernel version you have?

dalek 09-14-03 08:56 PM

Goodie
 
[root@smoker dale]# uname -r
2.4.21-0.13mdk
[root@smoker dale]#

I did take out the ACPI part though.

I don't crash or at least haven't. I got rid of there error by turning that off. Still like to get it right though.

Also, I have Mandrake 9.2 coming and Gentoo and Slackware. Hopefully 9.2 will solve some of the problem.

Any help though will be appreciated.

westep23 09-15-03 03:10 AM

Take a look at 2.4.22 from kernel.org I noticed it has some support for nforce boards never noticed it before 22. Also you get the supermount patch here for the stock 2.4.22. I would just D/L the full patch. Some of his other kernel hacks help with speed.

dalek 09-15-03 03:17 AM

Curious
 
I haven't looked but I have Mandrake 9.2 coming. That may help.

Any who, I'll try it and post. I'm on 24K dial-up and downloading is a pain. I have to order everything on CD's. Be my luck the download will be bad. :rolleyes:

Keep you posted though.

:D :D :D

westep23 09-15-03 04:53 PM

And I thought 56k was bad, 9.2 will probley ship w/2.4.22.

Forge 09-16-03 05:18 AM

dalek - ACPI/APIC are not your problems (Well, not your AGP problem, anyways).

Switch from AGPGART to NvAGP. Use the Nvidia internal AGP, as that has supported NF/NF2 for a while now.

If all else fails, rmmod agpgart, delete /lib/modules/kernel.version/kernel/drivers/agpgart.o.gz or whichever, and then reinstall the Nvidia driver. It should detect your AGPGART-lessnes and use NvAGP.

For someone on dialup, it's a lot easier fix than downloading a new kernel.

dalek 09-16-03 05:32 AM

Thanks
 
It seems to be stable. I think I already added a line to one of the files to force it to use the one you said. It does seem to work for now.

I'm currently installing Gentoo. I've been heating up the CPU doing a bit of compiling. That Volcano 11+ fan sure does get noisy when it starts warming up. :eek:

Still hoping that 9.2 will correct the problem. I wish/hope that NVIDIA will work with whoever to get it fixed. Make it easy for newbies. It kind of seems to be a Mandrake thing. Not really sure though.

Wish me luck on Gentoo. Found a snag already. Out of primary partitions. Waiting for help on another forum.

Thanks for the response. 9.2 is on the way.

:D :D :D :D


All times are GMT -5. The time now is 04:44 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.