nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Mandrake 8.2 Nvidia src.rpm problems (http://www.nvnews.net/vbulletin/showthread.php?t=1755)

Mr_Malcontent 09-11-02 04:35 PM

Mandrake 8.2 Nvidia src.rpm problems
 
Using NVchooser.sh points me to the src.rpm for the kernel driver and the GLX rpm for the GLX driver.

With that said, I should point out that I have previously tried the mandrake 8.2 UP rpm with no success. Now, when I try to use the $ rpm --rebuild NVIDIA_kernel-1.0-2960.src.rpm command I end up with the following:

Installing NVIDIA_kernel-1.0-2960.src.rpm
Executing(%prep): /bin/sh -e /var.tmp/rpm-tmp.1644
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd /usr/src/RPM/BUILD
+rm -rf NVIDIA_kernel-1.0-2960
+ /bin/gzip -dc /usr/src/RPM/SOURCES/NVIDIA_kernel-1.0-2960.tar.gz
+ tar -xf-
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd NVIDIA_kernel-1.0-2960
+ exit 0
Executing(%build) : /bin/sh -e /var/tmp/rpm-tmp.1644
+umask 022
+ cd /usr/src/RPM/BUILD
+set +e
++ rpm -q --queryformat '%{VERSION} ' rpm
+ RPMVERSION=4.0.3
++ awk -F . '{print $1;}'
++ echo 4.0.3
+ RPMMAJOR =4
++ echo 4.0.3
++ awk -F . '{print $3;}'
+ RPMPATCH=3
+ '[' 4 -le 3 -a 0 -le 0 -a 3 -lt 4 '['
+ make NVdriver
echo \#define NV_COMPILER \" `cc -v 2>&1 | tail -1`\" > nv_compiler.h
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparenthese -Wpointer-arith -Wcast-qual -Wno-Multichar -0 -MD 0D__KERNEL__ -DMODULE
-D_LOOSE_KERNEL_NAMES -D_X86=1 -Di386 -DLINUX -DNV4_HW -DNTRM -DRM20 -D_GNU_SOURCE -DRM_HEAPMGR -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=2960 -I. -I/usr/src/linux/include -Wno-cast-qual nv.c
In file included from /usr/include/linux/module.h:296,
from nv.c:25:
/usr/include/linux/version.h:2:2: #error "================================================= ======="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
/urs/include/linux/version.h:8:2: #error "These files are glibc internal and many not match the "
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
/usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error " "
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
/usr/include/linux/version.h:15:2: " "
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error " "
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/buils exists and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
/usr/include/linux/version.h:21:2: #error " "
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/version.h:24:2: #error " "
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
/usr/include/linux/version.h:27:2: #error " "
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/version.h:29:2: #error " "
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error " "
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error " "
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefule accordingly."
/usr/include/linux/version.h:35:2: #error "================================================= ============="
In file included from nv-linux.h:24,
from nv.c:27:
/usr/include/linux/version.h:2:2: #error "================================================= ============="
****The Above Section repeats itself****
****Above section followed by text below****
In file included from nv.c:27:
nv-linux.h:32:40: missing binary operator before '<'
nv-linux.h:34:42: missing binary operator before '<'
nv-linux.h:36:42: missing binary operator before '<'
nv-linux.h:38:42: missing binary operator before '<'
nv-linux.h:40:42: missing binary operator before '<'
nv-linux.h:44:4: #error This driver does not support 2.6x or newer kernels!
nv-linux.h:53:28: linux/autoconf.h: No such file or directory
nv.c:180:59: missing binary operator before '>='
nv.c:784:59: missing binary operator before '>='
nv.c:1098:59: missing binary operator before '>='
nv.c:1127:59: missing binary operator before '>='
nv.c:1470:59: missing binary operator before '<'
nv.c:3020:59: missing binary operator before '>='
make: *** [nv.0] Error 1
+ exit 0
Executing (%install) : /bin/sh -e /var/tmp/rpm-tmp.1644
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd NVIDIA_kernel-1.0-2960
+ rm -f /tmp/files.lst
+ '[' -z ' ' ']'
++ uname -r
+ export TARGET_KERNEL=2.3.18-6mdkenterprise
+ TARGET_KERNEL=2.4.18-6mdkenterprise
+ '[' -d /lib/modules/2.4.18-6mdkenterprise/kernel ']'
+ INSTALLPATH=/lib/modules/2.4.18-6mdkenterprise/kernel/dri
+ mkdir -p /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.18-6
drivers/video
+install -m 0444 NVdriver /var/tmp/NVIDIA_kernel-1.0//lib/
terprise/kenel/drivers/video
install: cannot stat `NVdriver' : No such file or directory
error : Bad exit status from /var/tmp/rpm-tmp.1644 (%install



RPM Build errors:
Bad exit status from /var/tmp/rpm-tmp.1644 (%install)

**************************************************

Can someone please translate this to n00b-speak for me. I'm rather frustrated with the amount of time that I have spent on this particular issue. I have tried the mdk82UP.rpm version of the kernel driver as well, and have run into other problems. I figured uninstalling the RPM, resetting xconfig and starting from scratch would be the best way to handle this, but now I'm up against a brick wall. Any help would be greatly appreciated. Thanks.

LaoTzuTao 09-11-02 05:28 PM

If I remember right, you need to install the linux kernel source before you try to install the nvidia kernel source. I just got my drivers to finally work, although I'm using SuSE 8.0, I'm not sure if it would be the same for you. Try installing the linux kernel source first, then try the nvidia kernel source again. Hope that helps!

Mr_Malcontent 09-11-02 05:42 PM

Linux kernel source? Where would I find that? more importantly, how would I check to see if it is already installed or not. remember I an NEW, like right off the boat kinda new.

LaoTzuTao 09-11-02 06:30 PM

Well I'm not much more experienced than you unfortunately. Also I use SuSE so I'm not sure how similar or different Mandrake is. SuSE comes with a RPM database program that shows me all the RPM's installed on my system, and I can install, or uninstall programs from there. I can also use the online update feature to show me all the programs abailable to install from the website, and which I already have installed. If Mandrake has something similar to that, just search through it to see if you have the kernel sources installed or not. If you just did a default installation, they're probably not. The RPM I needed to install was simply called kernel-source. Search for something along those lines. I wish I could be a little more helpful, but I'm still quite new too.

LaoTzuTao 09-11-02 06:35 PM

I was just checking the Mandrake website and came across this feature...

Improved URPMI (apt-like package manager) and Software Manager.

That sounds like something alongs the lines of what SuSE comes with, try using that.

Mr_Malcontent 09-11-02 06:47 PM

Hmm... No kernel-source installed. I guess I will try to grab it somewhere. Is the kernel-source RPM distro specific to your knowledge?

Andy Mecham 09-11-02 07:12 PM

kernel-source packages are specific by kernel. If you have the 2.4.19-foo kernel, you'll need the kernel-source-2.4.19-foo package. Check a Mandrake mirror...

Can you check the md5sum of your Nvidia SRPMS against the posted ones on the driver page? You can check with 'md5sum /path/to/SRPMS'. The "missing binary operator" messages occasionally pop up on a bad download.

--andy

Mr_Malcontent 09-11-02 07:19 PM

I love you man... that actually worked. Thanks a ton.

(I didn't have the kernel-source RPM installed)

LaoTzuTao 09-11-02 09:53 PM

Congrats! Feels good doesn't it? :D


All times are GMT -5. The time now is 12:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.