nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Fedora16 latest nvidia driver not working (http://www.nvnews.net/vbulletin/showthread.php?t=175518)

eltdesign 03-04-12 03:54 PM

Fedora16 latest nvidia driver not working
 
After upgraded to F16 x86_64 cant start X...I`m using latest 295.20 driver.. before using 290.xx without problem on F15.. I blacklisted noueveau and nomodeset kernel parameter.. also re-created init file without nouveau.. cant attach nvidia bug report because of file limit..

xorg.conf generated by nvidia-config default

here is nvidia bug report

http://www.2shared.com/file/xIdKY2FS...reportlog.html

leigh123linux 03-05-12 02:59 AM

Re: Fedora16 latest nvidia driver not working
 
.................................

eltdesign 03-06-12 11:05 AM

Re: Fedora16 latest nvidia driver not working
 
Quote:

Originally Posted by leigh123linux (Post 2533872)
.................................

What? Tryed your guide also not working for me.. because i used this drivers for a long time.. Any clue about this?

jeremielorente 03-08-12 03:35 AM

Re: Fedora16 latest nvidia driver not working
 
same problem here :/

Code:

lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
00:01.0 PCI bridge [0604]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port [8086:27a1] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 1 [8086:27d0] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 2 [8086:27d2] (rev 02)
00:1c.2 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 3 [8086:27d4] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 [8086:27c8] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 [8086:27c9] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 [8086:27ca] (rev 02)
00:1d.3 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 [8086:27cb] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller [8086:27cc] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller [8086:27c4] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation N10/ICH 7 Family SMBus Controller [8086:27da] (rev 02)
01:00.0 VGA compatible controller [0300]: nVidia Corporation G73 [GeForce Go 7600] [10de:0398] (rev a1)
02:00.0 Ethernet controller [0200]: Intel Corporation 82573L Gigabit Ethernet Controller [8086:109a]
03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
0a:04.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]
0a:04.1 FireWire (IEEE 1394) [0c00]: Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller [104c:803a]
0a:04.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]
0a:04.3 SD Host controller [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]

Code:

X.Org X Server 1.11.4
Release Date: 2012-01-27
[    24.145] X Protocol Version 11, Revision 0
[    24.145] Build Operating System: x86-07 2.6.32-220.4.1.el6.x86_64
[    24.145] Current Operating System: Linux pc-manu 3.2.9-1.fc16.i686 #1 SMP Thu Mar 1 01:58:05 UTC 2012 i686
[    24.146] Kernel command line: BOOT_IMAGE=/vmlinuz-3.2.9-1.fc16.i686 root=/dev/mapper/vg_pcmanu-lv_root ro rd.lvm.lv=vg_pcmanu/lv_swap rd.md=0 rd.dm=0 quiet LANG=fr_FR.UTF-8 SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 rd.lvm.lv=vg_pcmanu/lv_root KEYTABLE=fr-latin9 nouveau.modeset=0 rd.driver.blacklist=nouveau
[    24.146] Build Date: 08 February 2012  10:54:47PM
[    24.146] Build ID: xorg-x11-server 1.11.4-1.fc16
[    24.146] Current version of pixman: 0.22.2
[    24.146]        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    24.146] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    24.146] (==) Log file: "/var/log/Xorg.1.log", Time: Wed Mar  7 22:21:42 2012
[    24.146] (==) Using config file: "/etc/X11/xorg.conf"
[    24.147] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    24.147] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    24.147] (==) ServerLayout "Layout0"
[    24.147] (**) |-->Screen "Screen0" (0)
[    24.147] (**) |  |-->Monitor "Monitor0"
[    24.148] (**) |  |-->Device "Device0"
[    24.148] (**) |-->Input Device "Keyboard0"
[    24.148] (**) |-->Input Device "Mouse0"
[    24.148] (==) Automatically adding devices
[    24.148] (==) Automatically enabling devices
[    24.148] (**) FontPath set to:
        /usr/share/fonts/default/Type1,
        catalogue:/etc/X11/fontpath.d,
        built-ins
[    24.148] (==) ModulePath set to "/usr/lib/xorg/modules"
[    24.148] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    24.148] (WW) Disabling Keyboard0
[    24.148] (WW) Disabling Mouse0
[    24.148] (II) Loader magic: 0x8222580
[    24.148] (II) Module ABI versions:
[    24.148]        X.Org ANSI C Emulation: 0.4
[    24.148]        X.Org Video Driver: 11.0
[    24.148]        X.Org XInput driver : 13.0
[    24.148]        X.Org Server Extension : 6.0
[    24.150] (--) PCI:*(0:1:0:0) 10de:0398:1179:ff31 rev 161, Mem @ 0xd1000000/16777216, 0xc0000000/268435456, 0xd0000000/16777216, I/O @ 0x00002000/128, BIOS @ 0x????????/131072
[    24.151] (II) LoadModule: "extmod"
[    24.151] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    24.152] (II) Module extmod: vendor="X.Org Foundation"
[    24.152]        compiled for 1.11.4, module version = 1.0.0
[    24.152]        Module class: X.Org Server Extension
[    24.152]        ABI class: X.Org Server Extension, version 6.0
[    24.152] (II) Loading extension SELinux
[    24.152] (II) Loading extension MIT-SCREEN-SAVER
[    24.152] (II) Loading extension XFree86-VidModeExtension
[    24.152] (II) Loading extension XFree86-DGA
[    24.152] (II) Loading extension DPMS
[    24.152] (II) Loading extension XVideo
[    24.152] (II) Loading extension XVideo-MotionCompensation
[    24.152] (II) Loading extension X-Resource
[    24.152] (II) LoadModule: "dbe"
[    24.152] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    24.152] (II) Module dbe: vendor="X.Org Foundation"
[    24.152]        compiled for 1.11.4, module version = 1.0.0
[    24.152]        Module class: X.Org Server Extension
[    24.152]        ABI class: X.Org Server Extension, version 6.0
[    24.152] (II) Loading extension DOUBLE-BUFFER
[    24.152] (II) LoadModule: "glx"
[    24.153] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    24.153] (II) Module glx: vendor="X.Org Foundation"
[    24.153]        compiled for 1.11.4, module version = 1.0.0
[    24.153]        ABI class: X.Org Server Extension, version 6.0
[    24.153] (==) AIGLX enabled
[    24.153] (II) Loading extension GLX
[    24.153] (II) LoadModule: "record"
[    24.153] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    24.153] (II) Module record: vendor="X.Org Foundation"
[    24.154]        compiled for 1.11.4, module version = 1.13.0
[    24.154]        Module class: X.Org Server Extension
[    24.154]        ABI class: X.Org Server Extension, version 6.0
[    24.154] (II) Loading extension RECORD
[    24.154] (II) LoadModule: "dri"
[    24.154] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    24.154] (II) Module dri: vendor="X.Org Foundation"
[    24.154]        compiled for 1.11.4, module version = 1.0.0
[    24.154]        ABI class: X.Org Server Extension, version 6.0
[    24.154] (II) Loading extension XFree86-DRI
[    24.154] (II) LoadModule: "dri2"
[    24.154] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    24.154] (II) Module dri2: vendor="X.Org Foundation"
[    24.154]        compiled for 1.11.4, module version = 1.2.0
[    24.154]        ABI class: X.Org Server Extension, version 6.0
[    24.154] (II) Loading extension DRI2
[    24.154] (II) LoadModule: "nvidia"
[    24.155] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    24.156] (II) Module nvidia: vendor="NVIDIA Corporation"
[    24.156]        compiled for 4.0.2, module version = 1.0.0
[    24.156]        Module class: X.Org Video Driver
[    24.156] (II) NVIDIA dlloader X Driver  290.10  Wed Nov 16 19:29:07 PST 2011
[    24.156] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    24.156] (II) NVIDIA X compatibility module for ABI 11.0 built from xorg-server-1.11.0
[    24.156] (II) X log verbosity: 7
[    24.156] (--) using VT number 2

[    24.162] (II) Loading sub module "fb"
[    24.162] (II) LoadModule: "fb"
[    24.162] (II) Loading /usr/lib/xorg/modules/libfb.so
[    24.162] (II) Module fb: vendor="X.Org Foundation"
[    24.162]        compiled for 1.11.4, module version = 1.0.0
[    24.162]        ABI class: X.Org ANSI C Emulation, version 0.4
[    24.162] (II) Loading sub module "wfb"
[    24.162] (II) LoadModule: "wfb"
[    24.163] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    24.163] (II) Module wfb: vendor="X.Org Foundation"
[    24.163]        compiled for 1.11.4, module version = 1.0.0
[    24.163]        ABI class: X.Org ANSI C Emulation, version 0.4
[    24.163] (II) Loading sub module "ramdac"
[    24.163] (II) LoadModule: "ramdac"
[    24.163] (II) Module "ramdac" already built-in
[    24.163] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    24.163] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    24.163] (II) Loading /usr/lib/xorg/modules/libfb.so
[    24.163] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    24.163] (==) NVIDIA(0): RGB weight 888
[    24.163] (==) NVIDIA(0): Default visual is TrueColor
[    24.163] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    24.164] (==) NVIDIA(0): Using HW cursor
[    24.164] (==) NVIDIA(0): Video key set to default value of 0x101fe
[    24.164] (==) NVIDIA(0): Not mapping the primary surface by default.
[    24.164] (**) NVIDIA(0): Enabling 2D acceleration
[    24.164] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[    24.164] (EE) NVIDIA(0):    log file that the GLX module has been loaded in your X
[    24.164] (EE) NVIDIA(0):    server, and that the module is the NVIDIA GLX module.  If
[    24.164] (EE) NVIDIA(0):    you continue to encounter problems, Please try
[    24.164] (EE) NVIDIA(0):    reinstalling the NVIDIA driver.
[    25.943] (EE) NVIDIA(0): Failed to get supported display device(s)
[    25.970] (WW) NVIDIA(GPU-0): Failed to query OR info 0x24
[    25.973] (II) NVIDIA(0): NVIDIA GPU GeForce Go 7600 (G73) at PCI:1:0:0 (GPU-0)
[    25.973] (--) NVIDIA(0): Memory: 131072 kBytes
[    25.973] (II) NVIDIA(0): Board ID: 0x730a
[    25.973] (II) NVIDIA(0): GPU RAM Type: DDR2
[    25.973] (--) NVIDIA(0): VideoBIOS: 05.73.22.10.a2
[    25.973] (--) NVIDIA(0): Found 2 heads on board
[    25.973] (II) NVIDIA(0): Supported display device(s): CRT-0, DFP-1, TV-0
[    25.973] (II) NVIDIA(0): Bus detected as PCI Express
[    25.973] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    25.973] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[    25.973] (II) NVIDIA(0): DFP scaling is supported on this GPU
[    25.973] (II) NVIDIA(0): VPES : 5
[    25.973] (II) NVIDIA(0): SPS  : 8
[    25.973] (II) NVIDIA(0): User configuration of GPU PowerMizer is not supported
[    25.973] (II) NVIDIA(0):
[    25.973] (II) NVIDIA(0): Mode timing constraints for  : GeForce Go 7600
[    25.973] (II) NVIDIA(0): Maximum mode timing values  :
[    25.973] (II) NVIDIA(0):    Horizontal Visible Width : 8192
[    25.973] (II) NVIDIA(0):    Horizontal Blank Start  : 8192
[    25.973] (II) NVIDIA(0):    Horizontal Blank Width  : 4096
[    25.973] (II) NVIDIA(0):    Horizontal Sync Start    : 8184
[    25.973] (II) NVIDIA(0):    Horizontal Sync Width    : 504
[    25.973] (II) NVIDIA(0):    Horizontal Total Width  : 8224
[    25.973] (II) NVIDIA(0):    Vertical Visible Height  : 8192
[    25.973] (II) NVIDIA(0):    Vertical Blank Start    : 8192
[    25.974] (II) NVIDIA(0):    Vertical Blank Width    : 256
[    25.974] (II) NVIDIA(0):    Veritcal Sync Start      : 8191
[    25.974] (II) NVIDIA(0):    Vertical Sync Width      : 15
[    25.974] (II) NVIDIA(0):    Vertical Total Height    : 8193
[    25.974] (II) NVIDIA(0):
[    25.974] (II) NVIDIA(0): Minimum mode timing values  :
[    25.974] (II) NVIDIA(0):    Horizontal Total Width  : 40
[    25.974] (II) NVIDIA(0):    Vertical Total Height    : 2
[    25.974] (II) NVIDIA(0):
[    25.974] (II) NVIDIA(0): Mode timing alignment        :
[    25.974] (II) NVIDIA(0):    Horizontal Visible Width : multiples of 8
[    25.974] (II) NVIDIA(0):    Horizontal Blank Start  : multiples of 8
[    25.974] (II) NVIDIA(0):    Horizontal Blank Width  : multiples of 8
[    25.974] (II) NVIDIA(0):    Horizontal Sync Start    : multiples of 8
[    25.974] (II) NVIDIA(0):    Horizontal Sync Width    : multiples of 8
[    25.974] (II) NVIDIA(0):    Horizontal Total Width  : multiples of 8
[    25.974] (II) NVIDIA(0):
[    25.974] (--) NVIDIA(0): Connected display device(s) on GeForce Go 7600 at PCI:1:0:0
[    25.974] (--) NVIDIA(0):    none
[    25.974] (EE) NVIDIA(0): No display devices found for this X screen.
[    26.036] (II) UnloadModule: "nvidia"
[    26.036] (II) Unloading nvidia
[    26.036] (II) UnloadModule: "wfb"
[    26.036] (II) Unloading wfb
[    26.036] (II) UnloadModule: "fb"
[    26.036] (II) Unloading fb
[    26.036] (EE) Screen(s) found, but none have a usable configuration.
[    26.036]
Fatal server error:
[    26.036] no screens found
[    26.036]
Please consult the Fedora Project support
        at http://wiki.x.org
 for help.
[    26.036] Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[    26.036]
[    26.040] Server terminated with error (1). Closing log file.

The most important lines are:


01:00.0 VGA compatible controller [0300]: nVidia Corporation G73 [GeForce Go 7600] [10de:0398] (rev a1)
and

[ 26.036] (EE) Screen(s) found, but none have a usable configuration.


on last fedora kernel (3.1.9) and nvidia 290.10 rpmfusion package

everything ok on other nvidia graphique card (460gtx)

kwizart 03-08-12 03:51 AM

Re: Fedora16 latest nvidia driver not working
 
I guess that the driver is miss installed.
Please follow this guide while re-installing your system.
http://rpmfusion.org/Howto/nVidia


BTW, the earlier error is
[ 24.164] (EE) NVIDIA(0): Failed to initialize the GLX module; please check

eltdesign 03-08-12 03:13 PM

Re: Fedora16 latest nvidia driver not working
 
1 Attachment(s)
my card is Nvidia 8500GT

Using GNOME 3

I attached some logs of xorg.0.log boot.log and nvidia-installer.log

still cant use drivers...

jeremielorente 03-09-12 07:12 AM

Re: Fedora16 latest nvidia driver not working
 
thx for your answer kwizard.

i've reinstall fedora 3 times, and the same problem happens....

i didn't had this kind of problems on nvidia card since this one and i have 3 others configurations with nvidia card on fedora: 460gtx, 9600M GS, nforce working lije a charm....

I've installed the driver 295.20 driver from nvidia website and it works great know!

so i'm sure that's a problem with 290.10 version of the driver....

you should take a see to this thread too:
http://www.nvnews.net/vbulletin/showthread.php?t=168305

i really think it would be necessary to upgrade rpmfusion driver............

:) thx

kwizart 03-09-12 07:15 AM

Re: Fedora16 latest nvidia driver not working
 
The problem is the last driver make gnome-shell search feature crash, IIRC.
This is a showstopper to update the driver distro wide.

Usually you could pick the driver from rawhide, but not in this case: the F-17 UsrMove change will make the driver packaging incompatible with older fedora releases.

jeremielorente 03-09-12 08:38 AM

Re: Fedora16 latest nvidia driver not working
 
i've didn't noticed this kind of problem, but only a refresh problem on firefox when i scroll on website.

so we have to wait for nvidia to publish a new driver..... or maybe it's possible to add a "testing" or "depreciated" package including 295.20 drivers to make work card like go73?

eltdesign 03-09-12 10:18 AM

Re: Fedora16 latest nvidia driver not working
 
i uninstalled binary driver and re-installed orginal mesa-GL libs and re-installed kmod-nvidia from rpm fusion.. not working still!! screen blinks 3-4 times then boom shutoff i can open another terminal..

leigh123linux 03-10-12 05:10 AM

Re: Fedora16 latest nvidia driver not working
 
Quote:

Originally Posted by eltdesign (Post 2535043)
i uninstalled binary driver and re-installed orginal mesa-GL libs and re-installed kmod-nvidia from rpm fusion.. not working still!! screen blinks 3-4 times then boom shutoff i can open another terminal..

Try reinstalling Xorg

Code:

su
yum reinstall xorg-x11-server-Xorg

Also post

Code:

su
updatedb
locate libnvidia


eltdesign 03-11-12 08:22 AM

Re: Fedora16 latest nvidia driver not working
 
Quote:

Originally Posted by leigh123linux (Post 2535265)
Try reinstalling Xorg

Code:

su
yum reinstall xorg-x11-server-Xorg

Also post

Code:

su
updatedb
locate libnvidia



re-installed xorg-server no result...


Code:

here is output
/usr/lib/libnvidia-tls.so.1
/usr/lib/libnvidia-tls.so.190.42
/usr/lib/nvidia/libnvidia-cfg.so.1
/usr/lib/nvidia/libnvidia-cfg.so.290.10
/usr/lib/nvidia/libnvidia-compiler.so.1
/usr/lib/nvidia/libnvidia-compiler.so.290.10
/usr/lib/nvidia/libnvidia-glcore.so
/usr/lib/nvidia/libnvidia-glcore.so.1
/usr/lib/nvidia/libnvidia-glcore.so.290.10
/usr/lib/nvidia/libnvidia-ml.so.1
/usr/lib/nvidia/libnvidia-ml.so.290.10
/usr/lib/nvidia/libnvidia-tls.so.1
/usr/lib/nvidia/libnvidia-tls.so.290.10
/usr/lib/nvidia/tls/libnvidia-tls.so
/usr/lib/nvidia/tls/libnvidia-tls.so.1
/usr/lib/nvidia/tls/libnvidia-tls.so.290.10
/usr/lib64/libnvidia-cfg.so.1
/usr/lib64/libnvidia-cfg.so.190.42
/usr/lib64/libnvidia-tls.so.1
/usr/lib64/libnvidia-tls.so.190.42
/usr/lib64/nvidia/libnvidia-cfg.so.1
/usr/lib64/nvidia/libnvidia-cfg.so.290.10
/usr/lib64/nvidia/libnvidia-compiler.so.1
/usr/lib64/nvidia/libnvidia-compiler.so.290.10
/usr/lib64/nvidia/libnvidia-glcore.so
/usr/lib64/nvidia/libnvidia-glcore.so.1
/usr/lib64/nvidia/libnvidia-glcore.so.290.10
/usr/lib64/nvidia/libnvidia-ml.so.1
/usr/lib64/nvidia/libnvidia-ml.so.290.10
/usr/lib64/nvidia/libnvidia-tls.so.1
/usr/lib64/nvidia/libnvidia-tls.so.290.10
/usr/lib64/nvidia/tls/libnvidia-tls.so
/usr/lib64/nvidia/tls/libnvidia-tls.so.1
/usr/lib64/nvidia/tls/libnvidia-tls.so.290.10
/usr/lib64/tls/libnvidia-tls.so.1
/usr/lib64/tls/libnvidia-tls.so.190.42
/usr/lib64/tls/libnvidia-tls.so.190.53
/usr/lib64/tls/libnvidia-tls.so.195.30
/usr/lib64/tls/libnvidia-tls.so.195.36.03
/usr/lib64/tls/libnvidia-tls.so.195.36.08
/usr/lib64/xorg/modules/extensions/nvidia/libnvidia-wfb.so
/usr/lib64/xorg/modules/extensions/nvidia/libnvidia-wfb.so.1
/usr/lib64/xorg/modules/extensions/nvidia/libnvidia-wfb.so.290.10



All times are GMT -5. The time now is 08:22 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.