nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   1600x1200 mode doesn't work (http://www.nvnews.net/vbulletin/showthread.php?t=17594)

osm 09-06-03 03:08 PM

1600x1200 mode doesn't work
 
Problem:

Driver loads fine, 3d & 2d accel seem to work fine, but only in mode 1280x1024 and below. When running at 1600x1200x24 the nVidia logo shows up, but as soon as the normal X screen (in my case, KDE) takes over, the screen is garbled, like the timings are messed up.
----------------------------
My Hardware:

Via p4pa motherboard
Intel P4 1.4GHz
1Gig Ram
nVidia GeForce 2 based video card (pny verto)
4x AGP
Monitor is known to handle 1600x1200 res. with XFree86 using the same config file I'm using now. Also supports 1600x1200 res with the GeForce 2 under Windows 2000.
----------------------------
Software:

Linux kernel 2.4.22
nVidia driver 4496-pkg2
XFree86 4.3.0.1 (patched 4.3.0)
gcc 3.2.3
glibc 2.3.2
binutils 2.14
This is a custom system, not RedHat, SuSe, etc.
----------------------------
lspci -v output for nVidia board:

01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0311 (rev a1) (prog-if 00 [VGA])
Flags: bus master, 66Mhz, medium devsel, latency 248, IRQ 11
Memory at e4000000 (32-bit, non-prefetchable) [size=16M]
Memory at d8000000 (32-bit, prefetchable) [size=128M]
Expansion ROM at <unassigned> [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [44] AGP version 3.0
----------------------------
XF86Config file:

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/TrueType/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
EndSection

Section "Module"
Load "record"
Load "extmod"
Load "dbe"
#Load "dri"
Load "glx"
Load "xtrap"
Load "type1"
Load "speedo"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mouse0"
Option "Buttons" "6"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Iiyama"
ModelName "Vision Master Pro 502"
HorizSync 27-96
VertRefresh 50-160
ModeLine "1600x1200/75Hz" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +HSync +VSync
EndSection

Section "Device"
Identifier "NVIDIA Graphics Adapter"
Driver "nvidia"
VendorName "NVIDIA"
BoardName "NVIDIA GEFORCE"
Option "NvAGP" "1"
EndSection

Section "Screen"
Identifier "Screen0"
Monitor "Monitor0"
Device "NVIDIA Graphics Adapter"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1600x1200"
Virtual 0 0
EndSubSection
EndSection


Section "DRI"
Mode 0666
EndSection


Section "ServerFlags"
EndSection
----------------------------
/var/log/XFree86.0.log:

(attached)

T----------------------------

cat /proc/driver/nvidia/version:

NVRM version: NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4496 Wed Jul 16 19:03:09 PDT 2003
GCC version: gcc version 3.2.3

----------------------------

cat /proc/driver/nvidia/cards/0:

Model: GeForce FX 5600 Ultra
IRQ: 11
Video BIOS: 04.31.20.52.00
Card Type: AGP

----------------------------

cat /proc/driver/nvidia/agp/card:

Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x1f000104

----------------------------

cat /proc/driver/nvidia/agp/host-bridge:

Host Bridge: VIA Technologies, Inc. VT8753 [P4X266 AGP]
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000207:0x00000104

----------------------------

cat /proc/driver/nvidia/agp/status:

Status: Enabled
Driver: NVIDIA
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

----------------------------

In 1280x1024, everything works perfectly, including Maya 5.0 (which is why I replaced a fairly new Radeon with this GeForce) which is fully accelerated with hardware rendering enabled.

I cannot stand using a 1280x1024 display and want my 1600x1200 back! Please Help!

:)

Thanks!

osm 09-06-03 04:11 PM

I should probably also include this list of things I've tried already
 
Enable/disable IRQ in BIOS
Enable/disable kernel agpgart
Enable/disable driver agp
commented out ModeLine

None of that worked, obviously. I've scoured the internet and found a few mentions of this problem, but it doesn't look like anyone has ever resolved it.

falo 09-07-03 03:47 PM

I had exaclty the same problem and managed to resolve it using this option:

Option "IgnoreEDID" "true"

Give that a go.

osm 09-07-03 04:54 PM

Quote:

Originally posted by falo
I had exaclty the same problem and managed to resolve it using this option:

Option "IgnoreEDID" "true"

Give that a go.

Thanks for the reply, falo. I tried that option and it didn't do the trick. I tried several of the options I found in the README last night and nothing had any effect. I messed around with the modelines as well.

I'm starting to think this is something that only nVidia is going to be able to fix and, unfortunately, they seem to be AWOL on this board.

osm 09-07-03 07:38 PM

New Developments
 
OK. I installed RedHat 9 on a different partition and then installed the nividia drivers there. Not only was I able to get 1600x1200, but I was able to get 1920x1440!

So, there is something wrong with my X installation. I'm going to recompile it with less aggressive optimization settings and see what that does. I'll also look through the RedHat patches applied to the stock x 4.3.0 package and see if that turns up anything. I'll post the results when I am finished.

osm 09-08-03 02:04 AM

Working
 
I ended up just dumping my own compilation of XFree86 and installing the binaries available from XFree86.org.

I recompiled the x sources several times with different patches (some taken from the RedHat source RPM) and always got the same result.

Oh Well. I may mess with it some more, but it's working now, so I'm not going to spend as much time with it.


All times are GMT -5. The time now is 03:10 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.