nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X freeze on Mandrake(and other) solved!! (http://www.nvnews.net/vbulletin/showthread.php?t=17685)

mangus 09-08-03 07:36 PM

X freeze on Mandrake(and other) solved!!
 
Hi evrybody, Im very happy because nvidia driver works great on my system, under redhat9 and mandrake 9.1 (also winz..) with geforce4 mx 420
what u have to do is disabiling APIC (not APCI)
1 . go to bios and turn it off
2 . my bios don't have this option so i've to recompile the kernel turning off in the
PROCESSOR TYPE AND FEATURE the apic and io apic config and , if you want the smp config.

thats all
****in APIC what pain in the ass!!!:afro2:
post me if you solve the problem like me
greetings from italy
mangus

AndyNicholson 09-09-03 06:19 AM

Congratulations mangus, and thanks for posting it.

In my news searches I missed APIC as a possible solution. I must have read APCI every time I hit it.

Interestingly I already have APIC disabled in my BIOS. I must have disabled it two years ago when getting the system going for the first time - I don't recall why. The kernel seems to ignore the BIOS. Looking back at archived syslogs it was doing this long before I started getting the X freeze problem. Some non-consecutive lines from my syslog:
Sep 8 18:34:53 domus kernel: Local APIC disabled by BIOS -- reenabling.
Sep 8 18:34:53 domus kernel: Found and enabled local APIC!
Sep 8 18:34:53 domus kernel: Using local APIC timer interrupts.
Sep 8 18:34:53 domus kernel: calibrating APIC timer ...
Sep 8 18:34:53 domus kernel: PCI: Disabling Via external APIC routing


I'll try your APIC solution next if (once) my current attempt has failed.
I'm currently disabling apm and acpi via lilo boot options: apm=off acpi=off. I probably have to wait a week or so before I know this hasn't fixed things for me.
There are lots of solutions in the news groups that have worked for some people but not others. APIC looks very promising.

mangus 09-09-03 08:01 AM

hi Andy
I ve notice that my motherboard is for smp solution even if I run only one processor.
so mandrake at intallation enable APIC in the kernel( and install also a smp kernel..) by default, thing that redhat 9 don't do. so the driver works in redhat but not in mandrake in the same system.
so I thought it wasn't a hardware problem but something about the kernel or X.
watching dmesg logs the only difference was the enabling APIC by mandrake kernel. just I recompile it.

now works great. I dont mind now of what disabiling APIC means for my system.

best luck
mangus

sand 09-09-03 05:20 PM

hmmm
 
thx for your research guys but one thing i like to say.....

wise people always think things 2 easy and babbel......

but what about those guys that only wanna use their geforce and play a little??


i have no idea how to rekompile my kernel.
i disabled apic(or so..disabling isn posible...changed it to pic ..) but the problem is still there...

any help would be nice......thx....



and please....no google for it .......im on it.....but maybe ur faster.....

:angel:

mangus 09-09-03 07:37 PM

Hi sand

theres nothing wrong about just want to play a little with linux
but to have linux working well you must solve the problems that it takes often ;)
now you have the problem,you have to decide if you wanna solve or not
I hope that my indication about APIC may working on you, as I think, if you have a smp chipset (for multiprocessor) and a kernel that always enable APIC at boot.
the only way is "change" kernel. recompile
I'm not gonna tell you here how to make it. Theres tons of doc for your distro in the net and in your harddisk( I think) that explain how to do this.
There's nothing secret here
it's your choice ,
like mine that I've passed weird times trying to solve.
hope you'll be lucky like me
--
<> take care of your linux box! <>
Fede

sand 09-09-03 08:02 PM

haha
 
great.....

you missed to say may the force be with you......


u know, i got smb dhcp nfs dns servers going and am no noob using linux..

i just never used my biggest machine under linux and NEver Ever compiled the kernel..

im just looking for a point to start...

i googled couple of hours...but what i found are doks about redoing the whole kernel, and what was meant was just editing, right...

just tell me that i can open a file with vi and edit the section....

if not, please gimme a hint what to use to get to the section i have to change...

is it so hard to give hints...???

i couldnt really stop APIC i changed it to PIC under bios....

problem still there.,....

MacKTHeRIPper 09-10-03 12:14 AM

Kernal howto
 
Open up this howto if you did not install the howto then do so and this will guide you right through the entire process.
Just copy and paste this in your favorite browser.

file:/usr/share/doc/HOWTO/HTML/en/Kernel/Kernel-HOWTO.html

mangus 09-10-03 05:47 AM

sand
If your problem is like mine (and may be not but I think so) the ONLY way to solve it is to recompile the kernel.
Recompiling kernel is not just editing something with an editor but follow a list of procedure well known by linux lovers.
you NEED to learn this stuff if you wanna go on.
also you can decide to back to winz if dont want study how.
once you have practice of configuring a new kernel you can understand this:
when you make command " Xconfig" in the GUI search the PROCESSOR TYPE feature and then
unselect (say no ) to Simmetric multiprocessor feature
unselect to the 2 APIC and IO APIC feature.
then save and go on recompiling
I cant tell you here how is the complete procedure to recompile, is too long &complicated but it's all written somewhere and U dont have problem to find it.

if U dont understand this you cant solve your problem
just learn

U are right , may the force (and the skill) be with U... ;)

sand 09-10-03 07:40 AM

as always.....
 
i hoped to have it easier but as always i have to bang my head against the table until i understood......

theres no going back to M$ ..... i have 5 machines here and only one is running M$ and that only because i wanna look at win2003 server.....

some questions because im a little slow:

1.

i have to redo the WHOLE kernel.... copy it and replace it...??
o.k.......think itīll be a while until i will be able to play my beloved ET again...

2.

and i have to do this, because apic makes my X freeze after i installed the nvidia driver????
cause its an asus a7v333 board ...no multiprocessor....

mangus 09-10-03 08:18 AM

the problem may be that u have one processor but a chipset that support 2 processor o plus. when you install mandrake seems that it recognize this kind of chipset and install a kernel with APIC feature by default, thing that red hat don't do.
in my sistem the driver worked with redhat but dont with mandrake. so i realize that wasn't a hardware or card problem but in the kernel
the kernel enables APIC even if is disabilited by bios.
the only way is change the kernel of mandrake. look with a terminal with the command uname-a what kind of kernel you're running. IF u find something like that 2.4.21-0.13mdk-smp , you are running a kernel with APIC enabled which seems to crash X. may be is a normal kernel 2.4.21-0.13mdk( without smp, simmetric multiprocessor) but also with the feature APIC enabled. I think that mandrake does this.
three way
- recompile that kernel(bla bla bla)
-install a new kernel by mandrake cd's hoping that it don't have APIC enabled (may be not a solution)
- change distribuition installing redhat9 kernel 2.4.20-8 that seems to work because it has APIC disabled by default

try to solve this kind of problem in linux (that are frequent) means to know a little how the system works, it's not so simple but the documentation is evrywhere, just need a little time to learn and understand.

and realize that this solution may not work for u for reasons that i cant know

AndyNicholson 09-10-03 09:35 AM

A far easier thing to do that is supposed to stop the "X freeze" is disabling AGP support. This reduces graphics performance - only you can decide if that's ok for you.
I'm currently trying this to see if it works for me. If it does I may accept the loss of performance until the underlying bug is resolved.

To turn off AGP support the the nvidia driver add
Option "NvAGP" "0"
to the
Section "Device"
section of your /etc/X11/XF86Config-4. The same section that contains
Driver "nvidia"

This is documented in /usr/share/doc/NVIDIA_GLX-1.0/README APPENDIX F

Good luck.

sand 09-10-03 06:31 PM

i read that section, and i tried 1 and 2 .....

letīs see if it works.... usualy x freezes after couple of minutes....

if not ill go for the kernel....anyway......sys is setup in 30 mins max....so why worry...

and since i know that i can replace the whole kernel im willed to try....


tell ya later .....:D


All times are GMT -5. The time now is 10:17 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Đ1998 - 2014, nV News.