nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Common Error But I Am Stumped (http://www.nvnews.net/vbulletin/showthread.php?t=17741)

crazyme9 09-09-03 09:20 PM

Common Error But I Am Stumped
 
i have RH9 and have been messing with Twin veiw but it still dont work after 5 aganising days i get the error No modes remaining for display device
my xf86config is as follows:
Section "Module"
Load "dbe"
Load "record"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
Load "v4l"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
ModulePath "/usr/X11R6/lib/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "AutoRepeat" "250 30"
Option "XkbRules" "xfree86"
Option "XkbModel" "microsoft"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Buttons" "5"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "Resolution" "300"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor[0]"
ModelName "Unprobed Monitor"
VendorName "Monitor Vendor"
HorizSync 31.5-37.9
VertRefresh 50-70
EndSection

Section "Monitor"
Identifier "Monitor[1]"
ModelName "Unprobed Monitor"
VendorName "Monitor Vendor"
HorizSync 31-80
VertRefresh 56-65
EndSection

Section "Device"
BoardName "Gforce FX 5200"
Identifier "Device[0]"
VendorName "nvidia"
Driver "nvidia"
BusID "PCI:2:09:0"
Option "Dac8Bit" "3"
Option "TwinView" "on"
Option "Stereo" "3"
Option "Rotate" "off"
Option "NoTwinViewXineramaInfo" "1"
Option "NvAGP" "3"
Option "ConnectedMonitor" ""
Option "TwinViewOrientation" "RightOf"
Option "SecondMonitorHorizSync" "31-80"
Option "SecondMonitorVertRefresh" "48-65"
Option "MetaModes" "1024x768,1024x768"
Screen 0
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
Subsection "Display"
Depth 24
EndSubsection
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
Screen 0 "Screen[0]" 0 0
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
Option "Xinerama" "off"
Option "Clone" "off"
EndSection

LordMorgul 09-14-03 12:09 AM

I've never used a syntax like:
Monitor[0]

instead I've always seen:
Monitor0

Are you certain the XFree86 config accepts this naming convention?

zander 09-14-03 04:05 AM

Either is a valid identifier; the problem with the configuration looks like the lack of modes in the Display subsection of the Screen section:

Code:

Section "Screen"
  Identifier "Screen[0]"
  Device "Device[0]"
  Monitor "Monitor[0]"
  DefaultDepth 24
  Subsection "Display"
    Depth 24
  EndSubsection
EndSection

You will need to define the target modes you're interested in, for example:

Code:

  ...
  Subsection "Display"
    Depth 24
    Modes "1024x768" "800x600" "640x480"
  EndSubsection
  ...



All times are GMT -5. The time now is 08:59 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.