nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X server 1.12.0.902 instantly crashes on connection of HDMI monitor on 9600M GT (http://www.nvnews.net/vbulletin/showthread.php?t=178068)

misc 04-11-12 01:14 PM

X server 1.12.1 instantly crashes on connection of HDMI monitor on 9600M GT
 
1 Attachment(s)
My Iiyama ProLite E2773HDS works perfectly on Windows 7, but whenever I just plug it in via HDMI on Linux (x64) the X server immediately crashes, regardless of my xorg.conf present or none at all. If I try to log in from ngetty (to xmonad) the desktop sometimes flashes for less then a second, then it's back to ngetty again.

The same crash will happen one time after X is started without this second monitor, thereafter at least the primary one works again.

Aside from the memory positions, the backtrace in Xorg.0.log is always the same.

xorg-server 1.12.1, nvidia 295.40, glibc 2.15 (w/ Arch Linux patchset -10), kernel 3.3.2, 9600M GT
Occurred also with previous versions.

Attached nvidia-bug-report created with no xorg.conf present (used X server 1.12.0.902, kernel 3.3.1).

misc 04-13-12 05:38 AM

Re: X server 1.12.1 instantly crashes on connection of HDMI monitor on 9600M GT
 
Any comments, devs? This situation is really lousy, I'm doing most of my work with Linux.

edit: Explicitly disabling composite changes nothing.

misc 04-13-12 03:01 PM

Re: X server 1.12.1 instantly crashes on connection of HDMI monitor on 9600M GT
 
Explicitly disabling Xinerama doesn't change anything either.

However, the display works fine with nouveau. Thus I'm tempted to say that this indeed is a bug in your driver, or at least the interaction between it and xorg (d'uh).

(Won't use nouveau though since I need vdpau/etc. acceleration and power management. But sweet goodness, KMS makes the console look so much nicer on a FHD display.)

edit: With no relevant source changes, same for X server 1.12.1 and kernel 3.3.2.

misc 04-14-12 07:05 AM

Re: X server 1.12.1 instantly crashes on connection of HDMI monitor on 9600M GT
 
With both (and only both) RenderAccel set to False and the first Metamodes "1920x1080,NULL;" the X Server will at least properly start (and still crash if the HDMI cable is plugged in/out).

However, it shows a corrupted oversized image (example) if there's another metamode given, and nvidia-settings will not detect the second display in "X Server Display Configuration", though it does list it as DFP-1 under GPU 0. Also, that monitor will remain in standby.

edit: RenderAccel may remain true, apparently.

Correction: The monitor is listed properly in Display Configuration, I just had to actually select it in "Model:". The crash then occurs once it's enabled, regardless of the chosen resolution (eg Auto).

misc 04-15-12 12:40 PM

Re: X server 1.12.1 instantly crashes on connection of HDMI monitor on 9600M GT
 
If just tried it with a DVI:HDMI (monitor:laptop) cable, and while the crash is exactly the same if the cable if plugged in/out with X running (same with the different monitor it belongs to), this way the display at least works.

I do not want this workaround to become permanent, though.

sandipt 04-16-12 10:48 AM

Re: X server 1.12.0.902 instantly crashes on connection of HDMI monitor on 9600M GT
 
Please attach dmidecode o/p.

misc 04-16-12 11:58 AM

Re: X server 1.12.1 instantly crashes on connection of HDMI monitor on 9600M GT
 
1 Attachment(s)
dmidecode 2.12-cvs

misc 04-18-12 02:38 PM

Re: X server 1.12.1 instantly crashes on connection of HDMI monitor on 9600M GT
 
So, what does it look like? Any status?

sandipt 04-19-12 09:55 AM

Re: X server 1.12.0.902 instantly crashes on connection of HDMI monitor on 9600M GT
 
NVIDIA internal Bug Id 966827 to track this issue.

misc 04-20-12 09:49 AM

Re: X server 1.12.1 instantly crashes on connection of HDMI monitor on 9600M GT
 
Yay, thanks.

Is it possible for unprivileged users like me to check that bug id's progress?

misc 05-02-12 05:20 PM

Re: X server 1.12.0.902 instantly crashes on connection of HDMI monitor on 9600M GT
 
Gone with 302.07 (using a fresh X Server compile from git). Hotplugging works fine, too.


All times are GMT -5. The time now is 03:32 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.