nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   295.x drivers cause start X to crash when Dell M4600 laptop is docked, 290.10 ok (http://www.nvnews.net/vbulletin/showthread.php?t=178143)

pbc2520 04-12-12 09:09 AM

X fails to start when external display present from boot with 295.x, 290.10 ok
 
3 Attachment(s)
The laptop is a Dell Precision M4600 with Quadro 2000M and IPS RGB LCD panel. When docked, two displays exist: DFP-4 (external) and DFP-5 (internal) with DFP-5 is disabled, only external DFP-4 in use.

The driver 290.10 works fine when docked (and undocked). See attached nvidia-bug-report-290.10-docked.log.gz for normal operation.

Switching to any 295.x drivers, keeping all other things the same, X starts all right when UNdocked, i.e. only DFP-5 available (although the screen flickers badly when in power saving mode). See attached nvidia-bug-report-295.40-undocked.log.gz for normal operation. However, when docked, any 295.x driver causes X to fail to start and the system hangs locally. It is possible to remotely log in via ssh but many operations just hang, including nvidia-bug-report.sh. I was able to pull out certain log files - see attached my-log-files-295.40-docked.tar.gz for error reports. In particular, Xorg.0.log contains the errors:

(EE) NVIDIA(GPU-0): Failed to tear down EVO channel
...
(EE) NVIDIA(GPU-0): EVO Push buffer channel allocation failed
(EE) *** Aborting ***
(EE) NVIDIA(GPU-0): Failed to allocate EVO DMA push buffer
(EE) *** Aborting ***

pbc2520 04-19-12 10:59 AM

Re: 295.x drivers cause start X to crash when laptop uses external display, 290.10 ok
 
I've investigated this issue more with the 295.40 driver. The issue is not so much being docked (as previously reported) but having an external display connected.

Steps to reproduce:
1. With laptop turned off, connect external display (possibly by inserting into docking station)
2. Turn on and start X.
Result:
Screens remain blank (internal display flickers a bit if in use). Machine requires hard reset. Same error messages as before (extracted via SSH) whether the internal display is in use or not.

However, if the external display is connected after X has been started, 'Detect displays' finds the screen and all is ok. Unfortunately, this workaround doesn't work for a docking station - the lid cannot open in the docking station, and I don't trust Linux drivers to hot-plug at all.

As mentioned, 290.10 works ok, and I did not change anything apart from the driver version.

pbc2520 05-02-12 01:52 PM

Re: X fails to start when external display present from boot with 295.x, 290.10 ok
 
Issue still exists with 302.07.

pbc2520 05-28-12 01:57 PM

Re: 295.x drivers cause start X to crash when Dell M4600 laptop is docked, 290.10 ok
 
I have found that adding
Code:

    Option        "UseDPLib" "off"
to xorg.conf avoids the issue. (The issue is still present in 295.53 though.)

kekar 09-27-12 09:34 AM

Re: 295.x drivers cause start X to crash when Dell M4600 laptop is docked, 290.10 ok
 
Same issue for the FreeBSD 9 (AMD64) driver too.

sandipt 09-28-12 08:10 AM

Re: 295.x drivers cause start X to crash when Dell M4600 laptop is docked, 290.10 ok
 
Quote:

Originally Posted by kekar (Post 2576873)
Same issue for the FreeBSD 9 (AMD64) driver too.

On which system? Is the same error message and reproduction steps? Please attach nvidia bug report.

kekar 10-01-12 04:31 AM

Re: 295.x drivers cause start X to crash when Dell M4600 laptop is docked, 290.10 ok
 
Quote:

Originally Posted by sandipt (Post 2576918)
On which system? Is the same error message and reproduction steps? Please attach nvidia bug report.

http://www.nvnews.net/vbulletin/showthread.php?t=179484

Now I'm running FreeBSD 9.1RC1 AMD64 NVS 4200M (Dell Latitude E6420).

If the option isn't excplicitly disabled in xorg.conf, the X11 server crashes with the same error. The screen goes blank and the system get unresponsive, and the PC speaker beeps sporadically a few times if I try anything.

Let me know *where* to fill out a more complete report, if desired.

pbc2520 10-01-12 02:32 PM

Re: 295.x drivers cause start X to crash when Dell M4600 laptop is docked, 290.10 ok
 
I seem to recall that it was easiest (possibly necessary) to log in via SSH from another machine before performing the startx command that causes the system to hang. Even so, the nvidia-bug-report.sh would hang (or run so slowly as to be indistinguishable) but it was possible to copy the key log files to an area that could be retrieved on a subsequent boot.


All times are GMT -5. The time now is 03:57 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.