nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia driver 1.0-3123 VIA 4x issues. (http://www.nvnews.net/vbulletin/showthread.php?t=1787)

dcstimm 09-12-02 04:16 PM

Nvidia driver 1.0-3123 VIA 4x issues.
 
I have been using the Nvidia drivers on linux for a long long time, I have always had no problems getting AGP4x to work on my VIA motherboard. I would just edit the os_registy.c file, and switch:

-static int NVreg_EnableVia4x = 0;
+static int NVreg_EnableVia4x = 1;

Now with the 3123 I do that but it still stays at 2x,

here is my output:

cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: NVIDIA
AGP Rate: 2x
Fast Writes: Enabled
SBA: Enabled

cat /proc/driver/nvidia/agp/host-bridge
Host Bridge: Via Apollo Pro
Fast Writes: Supported
SBA: Supported
AGP Rates: 2x 1x
Registers: 0x1f000213:0x00000112

With the older drivers it would always say:

AGP Rate 4x 2x 1x, now I only get 2x 1x.

Trust me I have done everything to get this working, its not a screw up on my end.

The 3123 Nvidia drivers are broken.

--Daryl

Klaus-P 09-12-02 04:55 PM

"The 3123 Nvidia drivers are broken."

Or more specifically the written info about agp rate 4x is rubbish and you actually get 4x agp. I would run graphics test programs comparing the actual behavior.

bwkaz 09-12-02 05:49 PM

You didn't do what I did once and forget about having turned off 4x AGP in the BIOS, did you?

I had been using a Voodoo3 for a while, which didn't support 4x mode, so (for whatever reason) I had the BIOS set to 2x.

dcstimm 09-12-02 06:19 PM

I did run glxgears, before and after to test, before it was at 1283FPS and now its running around 1133FPS.

Either the new drivers are slower and 4x is enabled but the output is wrong, or the new drivers are broken.

Yes I did check everything, including my bios.

dcstimm 09-13-02 04:28 AM

I sure hope they fix this.

Klaus-P 09-13-02 11:02 AM

Try also to replace "__ReqAGPRate" with the two leading underscores
by "ReqAGPRate" in os-registry.c (new driver package 3123)
and recompile. Do also read the warnings!

samppa 09-29-02 04:48 PM

same problem
 
I have the same problem, can't get 4x on my Via Abit VP6 board. I don't edit the source code, but use the module parameter NVreg_EnableVia4x instead, which does the same thing (type modinfo NVdriver to get all module parameters).

This worked with older nVidia binary drivers, but not anymore with 3123. E.g. option NVreg_EnableAGPFW works ok still.

samppa 09-29-02 05:22 PM

I tried again with AGPGART instead of NVAGP and managed to get 4xAGP working. Nice increase in fps on UT2003. Now I get 20fps on the forest map instead of ~10fps i had before.

SubTexel 09-29-02 09:34 PM

I havent had problems, just set the bios to 4x, I get 16886.99FPS on the glxgears program (keeps going up..I have a Geforce 4 4200ti..) dont know if that is good or not, but I could really care less. I Dont use Linux for games :)


All times are GMT -5. The time now is 01:03 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.