nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   FreeBSD 9.0 AMD64 NVS 4200M (http://www.nvnews.net/vbulletin/showthread.php?t=179484)

kekar 04-27-12 09:03 AM

FreeBSD 9.0 AMD64 NVS 4200M
 
Hi,

I have a newer Dell Latitude laptop with the NVIDIA NVS 4200M gfx. card.

My problem is that all newer drivers, in the v29x-series won't work properly. I have tried the latest as well (v.295.40). The X server doesn't crash, but after startup the screen goes black and the monitor doesn't get any signal.

However, if I go back to the NVIDIA driver v285.05.09 it works quite well. The *only* thing I changed are the kernel drivers, nothing else.

Are there anyone others that have the same symptoms with the v29x drivers and the NVS series?

PS. There's some Windows 7 graphics specific device (don't remember the name) hardware on this lapotop, but this is of course disabled in the BIOS.

Let me know if there's something else I can test, or you want me to provide additional information..

Big Thanks!

kekar 04-27-12 09:29 AM

Re: FreeBSD 9.0 AMD64 NVS 4200M
 
I must correct myself. I apperently didn't test 290.10, it worked as well as 285.05.09.

kekar 05-17-12 09:04 AM

Re: FreeBSD 9.0 AMD64 NVS 4200M
 
Same with 295.53 and 302.07 (beta). The speaker in the laptop makes sporadic beeps for a little while.

Back to 290.10, I guess..

kekar 05-21-12 09:17 AM

Re: FreeBSD 9.0 AMD64 NVS 4200M
 
I must also make a note that with v.285 and v.290 the driver gets unstable if ACPI is enabled.

Port config:
[ ] ACPI_PM Enable support for ACPI Power Management

It may work for several hours or a day, but if it stay too long in suspension mode, it often will not activate. Sometimes the X-server takes 100% CPU, and sporadic reboots may occur when it tries to wake-up.

kekar 09-26-12 11:13 AM

Re: FreeBSD 9.0 AMD64 NVS 4200M
 
Quote:

(II) Sep 25 15:52:07 NVIDIA(0): Virtual screen size determined to be 1600 x 900
(EE) Sep 25 15:52:11 NVIDIA(GPU-0): Failed to tear down EVO channel
(--) Sep 25 15:52:11 NVIDIA(0): DPI set to (131, 134); computed from "UseEdidDpi" X config
(--) Sep 25 15:52:11 NVIDIA(0): option
(--) Depth 24 pixmap format is 32 bpp
(II) Sep 25 15:52:11 NVIDIA: Reserving 3072.00 MB of virtual memory for indirect memory
(II) Sep 25 15:52:11 NVIDIA: access.
(EE) Sep 25 15:52:15 NVIDIA(GPU-0): EVO Push buffer channel allocation failed
(EE) *** Aborting ***
(EE) Sep 25 15:52:15 NVIDIA(GPU-0): Failed to allocate EVO core DMA push buffer
(EE) *** Aborting ***
Adding the following option solved it;

Option "UseDPLib" "false"

It have been broken since after v290.10, it's still an issue with v304.43.


All times are GMT -5. The time now is 05:30 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.