nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   /dev/fb0 doesn't exist (http://www.nvnews.net/vbulletin/showthread.php?t=17965)

bored_SuSE_user 09-13-03 08:54 AM

/dev/fb0 doesn't exist
 
I am having problems trying to get an application to run, it says that it cannot find /dev/fb0.
At the moment I have vga=normal in my grub, because if I change this, I get the corruption.
Is there anyway to convince the linux system I do have a frame buffer?

Incidentally I am getting similar problems on my old linux box, which I am hoping to turn into a mame machine. I get errors identical to my nvivida laptop. I cannot find a vga= parameter which will turn on the fb. I have even tried setting the device to vesa->framebuffer device in Sax2 but it doesn't test it properly - comes back with the same error above.

Maybe you have to do this, then restart? I'm not sure, but I don't want to muck my configuration up.

Vadim 09-13-03 10:25 AM

you should add options like "vga=0x317 video=vesa:mtrr,ypan" to your kernel command line. videomode can be different (you can find list in /usr/src/linux*/Documentation/fb/vesafb.txt), but there no way to change mode after boot.

bored_SuSE_user 09-13-03 11:40 AM

Thanks for the quick reply.
My friend thought it was possible to install a fb driver like rivafb or sisfb but one for my card does not exist (only the installed nvidia one).

I will try that and hopefully it will work!

bored_SuSE_user 09-13-03 12:00 PM

No...the highest my mame linux box will go to is 217 according to 'scan'. It doesn't enable the fb therefore. I presume that the card doesn't support the framebuffer.

I haven't tried my laptop with the video=vesa: command, but before I got corruption due to nvidia buggy drivers.

Vadim 09-13-03 03:18 PM

vesafb modes have nothing with scan output

bored_SuSE_user 09-13-03 05:44 PM

I found the problem: my bios on my old linux box doesn't support framebuffer, if I select a number like 317, the screen goes blank (i.e. video card output dies).

On my dell with nivida I am getting the error that vesafb doesn't allow creation of new modes (trying to run advance menu).

Seems everytime I fix something or work out why it is causing an error, I get another problem.


All times are GMT -5. The time now is 05:20 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.