nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Newbie prob with GeF4 & suse 8.2 (http://www.nvnews.net/vbulletin/showthread.php?t=17968)

billythekidgoat 09-13-03 09:33 AM

Newbie prob with GeF4 & suse 8.2
 
1 Attachment(s)
Hi, you're help would be much appreciated.
My computer is

AMD Athlon XP 1800
Asrock K7S8X
Geforce 4 MX440 8x
Geforce driver for IA32 "NVIDIA-Linux-x86-1.0-4496-pkg2.run
Suse 8.2 personal edition

can't work out my video bios revision-no /nvidia/ in proc/driver/
I've attached xfree86.0.log and XF86Config

The problem is, i've installed the drivers but open GL programs just close. When I try to enable the openGL/3d acceleration, the screen goes blank.

What am i doing wrong?!
Thanks,
Billythekidgoat

billythekidgoat 09-13-03 09:36 AM

1 Attachment(s)
don't know how to attach to attachments, so here's the second!

Pwipwi 09-14-03 03:12 PM

Just read the FAQ (README from nvidia)
answer to your question is here :)

billythekidgoat 09-17-03 02:11 PM

Thanks for your reply.
I'm probably being really stupid but I still can't get the thing to work!
I've read the FAQ section in the readme but I can't find the answer.What am I missing? looking at the log the problem seems to be to do with

(EE) [GLX]: Failed to add GLX extension (NVIDIA XFree86 driver not found)

But I don't know how to rectify this. I reinstalled the drivers but this has not helped.
Again any help is great!
Billy the kid goat

Pwipwi 09-17-03 04:08 PM

1 Attachment(s)
This is indeed a newbie question :)
in your /etc/X11/XF86Config file, in the section "Device", change the driver from "nv" to "nvidia" (supposing you installed the driver already, right :) )

But you know, don't rush when reading FAQs and READMEs, cause stuff said in here is REALLY important (ie: the thing that you missed is in fact really obvious and told in the FAQ even in the "for the impatient" instruction :) )

here is the fixed file:

billythekidgoat 09-18-03 02:54 PM

Thanks for your reply again!

i've actually already tried doing this-manually editing the XF86Config file and replacing "nv" with "nvidia" and then rebooting but when X loads I just get a black screen. This had happened both times i've tried it.

When I tick the "enable 3d" box on the Sax2 console and then test the setting the same thing happens- I just get a black screen and have to restart with the old settings.

What am I doing wrong?
I've reinstalled the drivers and that all seems to go fine. This is on a new system with just Suse 8.2 installed along with the programs that came with the program.

Billy the kid goat
:)

Pwipwi 09-18-03 03:30 PM

aha. this one is a bit trickier :)
Just that you know, you won't get any 3d acceleration if you don't use the nvidia driver. The nv driver doesn't handle it at all. Have you tried the FAQ thingies with the nvidia driver on ? If not, I encourage you to do so.
Anyway, this could come from the ACPI on (again!) ! At least, it wouldn't surprise me if you had a nforce chipset on your motherboard :). It could come from the AGP thing, either way, so you should give a try to the NvAGP 0 ( or option "NvAGP" "0") in the Device section of your XF86Config file. Could you try everything of the faq again with the nvidia driver on, then tell me the results or particular things you noticed ?

Have fun :)

billythekidgoat 09-18-03 04:32 PM

Thanks for the swift reply!

With the nvidia driver on i can't load x so have to work from the command line which is a new experience for me!
I'll try as you suggested and post the results.
Cheers!
Billy the kid goat:)

billythekidgoat 09-18-03 05:00 PM

:D :D :D
IT WORKS!!!

I added in "NvAGP" "0" into the devices section and it worked 1st time!

Thanks for all your help genius!

Billy the kid goat :afro:

Pwipwi 09-19-03 03:54 PM

you're welcome


All times are GMT -5. The time now is 09:43 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.