nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Mandrake 9.1 + Geforce2 GTS (http://www.nvnews.net/vbulletin/showthread.php?t=17972)

dave77 09-13-03 10:23 AM

Mandrake 9.1 + Geforce2 GTS
 
Hi linuxfriends,

after installing with "sh NVIDIA-Linux-x86-1.0-4496-pkg2.run"

and changing entries in XF86Config-4
the x-server crashes with following.

===cut===
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(==) NVIDIA(0): Using HW cursor
(==) NVIDIA(0): Video key set to default value of 0x101fe
(--) NVIDIA(0): Linear framebuffer at 0xD0000000
(--) NVIDIA(0): MMIO registers at 0xDC000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
===cut===

lsmod shows that the module is loaded:

...
nvidia 1767264 0 (autoclean)
...

dont know what to do? can someone please help me?

dave77 09-13-03 11:05 AM

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Sep 13 17:49:18 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
ERROR: No package found for installation. Please run this utility with the
'--help' option for usage information.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.



:(

dave77 09-13-03 11:51 AM

i tried "make install" and get this:

[root@dagobah NVIDIA-Linux-x86-1.0-4496-pkg2]# make install
cd usr/src/nv; make install
make[1]: Entering directory `/home/david/Programme/nvidia/NVIDIA-Linux-x86-1.
0-4496-pkg2/usr/src/nv'
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wpa
rentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DM
ODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KE
RNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=44
96 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -I. -I/usr/src
/linux/include -Wno-cast-qual nv.c
In file included from /usr/include/linux/prefetch.h:13,
from /usr/include/linux/list.h:6,
from /usr/include/linux/module.h:11,
from nv-linux.h:28,
from nv.c:14:
/usr/include/asm/processor.h:55: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here
(not in a function)
...
===cut===

do i need to recompile the package?

...i am new to linux and like to learn more about it!

pls someone help!

Sharker 09-13-03 01:11 PM

what is your XF86Config file?

dave77 09-13-03 01:24 PM

i changed the XFconfig, here:

# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us_intl"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1280x1024 @ 76 Hz"
HorizSync 31.5-82
VertRefresh 50-90

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce2 DDR (generic)"
Driver "nv"
BusID "PCI:1:0:0"
Option "DPMS"
Option "NvAGP" "1"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

i am so brrrrr.... workin for hours now at this

dave77 09-13-03 01:26 PM

Driver "nv" ==> nvidia

just for a working x right now!

Sharker 09-13-03 02:34 PM

Have you tried to leave only one "Display" sub-section under the "Screen" ?

dave77 09-13-03 03:05 PM

thx for your suggestion, i uncomment (#) them and get the same errormessage! :(

maybe i need to compile the files new ?!? i have read a post doing it with mkprecompile... , but i dont have that exec. can someone tell where i can get it or which package contains it?

thx

kauko 09-14-03 07:52 AM

I have a similar problem with MDK 9.1 & GeForce 2 MX200, x crashes with 'no screen found with usable configuration' on normal bootup.
If I boot into 'Failsafe -> Graphic & Network' then x starts up like it should ! I would prefer to bootup the normal way , but until someone can help I'm stuck with Failsafe. Would this work for you ?

dave77 09-14-03 10:42 AM

Yes, it works!!
YES!!! :eek:
during severel experiments i wanted to compile the exist kernel and think of having seen there was problem with the agpgart module! i am not sure! now i have downloaded new kernelsources and trieing my luck with them! thx for the tip!! Now mine kde is incredibly faster than before! try to solve the problem. hard time for a noob!


All times are GMT -5. The time now is 10:42 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.