nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   302.07: Xv V-Sync is borked (http://www.nvnews.net/vbulletin/showthread.php?t=180025)

RealNC 05-04-12 10:33 AM

302.07: Xv V-Sync is borked
 
Since VDPAU is unusable with KDE, I always use Xv with mplayer. It works great. However, I tested the 302.07 beta driver and found a regression: The video shows a tearing line that slowly moves from top to bottom over time and "jitters" slightly up/down while doing the general downwards motion. It takes about 20 seconds for the tearing line to go from top to bottom. Then it appears again at the top and repeats.

The "Sync to VBlank" checkbox for "Video Texture Adaptor" is checked in nvidia-settings.

This is on 64-bit, using X.Org server 1.12.1 and kernel 3.3.4 with a GTX 560 Ti.

Edit:
I only have one monitor, connected through DVI-D, 1920x1080.

Plagman 05-04-12 11:50 AM

Re: 302.07: Xv V-Sync is borked
 
Can you expand on "VDPAU unusable with KDE"? Is there already a thread detailing the issues there? Sorry if I missed it.

Can you please attach an nvidia-bug-report.log?

RealNC 05-04-12 11:56 AM

Re: 302.07: Xv V-Sync is borked
 
Quote:

Originally Posted by Plagman (Post 2552500)
Can you expand on "VDPAU unusable with KDE"? Is there already a thread detailing the issues there? Sorry if I missed it.

Yes, the thread is:

http://www.nvnews.net/vbulletin/showthread.php?t=173519

Quote:

Can you please attach an nvidia-bug-report.log?
Oops, I should have remembered to do that myself. I will re-install 302.07 shortly and attach it.

RealNC 05-04-12 12:11 PM

Re: 302.07: Xv V-Sync is borked
 
1 Attachment(s)
Here goes. X was started with "-logverbose 6".

RealNC 05-04-12 12:38 PM

Re: 302.07: Xv V-Sync is borked
 
I should mention something I just discovered: If I go into nvidia-settings and uncheck the "Sync to VBlank" and check it again, this seems to fix it. What's weird is that I can uncheck it again, but Xv vsync is still happening. If I restart X, I have to go into nvidia-settings again and play with the checkbox again to get Xv vsync back.

RealNC 05-04-12 01:23 PM

Re: 302.07: Xv V-Sync is borked
 
(I hope I'm not spamming here.)

Turns out that just starting nvidia-settings fixes it, even if I don't change any settings in there.

mocharhw 05-04-12 01:25 PM

Re: 302.07: Xv V-Sync is borked
 
Quote:

Originally Posted by RealNC (Post 2552542)
(I hope I'm not spamming here.)

Turns out that just starting nvidia-settings fixes it, even if I don't change any settings in there.

Are you running "nvidia-settings -l" when your desktop environment or window manager starts up?

RealNC 05-04-12 01:32 PM

Re: 302.07: Xv V-Sync is borked
 
Quote:

Originally Posted by mocharhw (Post 2552546)
Are you running "nvidia-settings -l" when your desktop environment or window manager starts up?

I never needed to. Where did you get that information that this needs to be done?

Gusar 05-04-12 05:31 PM

Re: 302.07: Xv V-Sync is borked
 
1 Attachment(s)
I've noticed tearing too. When there's sideways motion, I see a tear line moving up. But no amount of playing with nvidia-settings fixes it. I think it's a simple matter of xv sync not being active, despite nvidia-settings saying it is. nvidia-bug-report is attached.

Licaon 05-04-12 06:00 PM

Re: 302.07: Xv V-Sync is borked
 
Quote:

Originally Posted by RealNC (Post 2552550)
I never needed to. Where did you get that information that this needs to be done?

how else would the settings you modified in nvidia-settings be applied then ? :p

RealNC 05-04-12 07:08 PM

Re: 302.07: Xv V-Sync is borked
 
Quote:

Originally Posted by Licaon (Post 2552627)
how else would the settings you modified in nvidia-settings be applied then ? :p

I don't know. I was using an ATI card before and I never needed to run catalyst control center to apply the settings. The driver itself would load them automatically. This seems to work the same way with NVidia drivers prior to 302.07.

Sounds kind of weird that I would need to run a program manually to apply settings.

Gusar 05-04-12 08:16 PM

Re: 302.07: Xv V-Sync is borked
 
It may sound weird, but it is so. If you've set anything in nvidia-settings that's not the default (xv sync *is* default), it'll only get applied when you launch nvidia-settings. That's why the "--load-config-only" option exists, so you can put it in start-up scripts (in my case ~/.config/openbox/autostart)


All times are GMT -5. The time now is 06:22 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.