nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   failing to initialize NV driver (http://www.nvnews.net/vbulletin/showthread.php?t=1803)

PsyShook 09-13-02 01:58 AM

failing to initialize NV driver
 
i can't get Xfree86 to start because it claims to not be able to initialize the NV driver. i used the tarball versions of the driver and when i did the make installs on those the GLX was ok with no problems. i think the problem resides in the fact that the NV driver was adding stuff for PCMCIA which is not compiled in my kernel because i have no use for it so i took it out and when doing a make clean and then make install for NV driver it errors with unresolved symbols for some PCMCIA stuff. i figured it probably wasn't a problem because i could modprobe NVdriver and then i checked to see if the module loaded ok with dmesg and lsmod. it says the module is there but "(unused)" is next to it. that's about it. i'd really like to get some 3d software running instead of this lame VESA driver.

Andy Mecham 09-13-02 03:43 AM

Please post your /var/log/XFree86.0.log, /etc/X11/XF86Config-4, etc.

--andy

PsyShook 09-13-02 10:15 AM

1 Attachment(s)
here's my XF86Config file

PsyShook 09-13-02 10:18 AM

1 Attachment(s)
here's the log file

closertech 09-13-02 06:43 PM

Hi PsyShook

Alot of times the modules.conf file must be edited to load the NVdriver. The Install should modify the modules.conf file for you however many times it does not. A second thought is that most your xconfig files are in this format XF86Config-4 for xfree86 4.0 and newer and the XF86Config file is for the old version xfree86 3.0 versions and NVdrivers dont work with the older version.

? are you editing right XF68Config-4 file
? is your modules.conf file loading NVdriver
? what distro are you running and what are you running it on

closer

PsyShook 09-17-02 09:08 PM

think it's working
 
allright. i didn't toy around getting the drivers working over the last few days cause it is not of extreme importance. but i installed xine today and ran ldconfig or ldconf can't remember which. but this seems to have fixed my problem i think. is there a way i can tell that my nvidia drivers are now working?

PsyShook 09-17-02 09:28 PM

back to the beginning
 
all right. i made a mistake and posted that too soon. i'm back to the beginning. i made a mistake in thinking that my recently configured XF86Config was the one being used. anyways. i am still having the same problem as before. i'm using slackware 8.1 and a kernel i compiled myself.

z28Power 09-18-02 12:01 PM

I'm having almost the same EXACT problem as you are! I compiled and configured the 2.4.5 kernel for my Slackware install and when I tried to run make modules_install I got a couple of errors with the /lib/modules/pcmcia folder files, or something like that. all the errors were with about 4 or 5 files getting unresolved symbols with a file format of filename.o.gz and when i try to make install the nvidia stuff, I get those same unresolved symbols failing, and one additional file -- NVdriver!! I have tried to rebuild the kernel a couple of times but to no avail. What do you guys think?

PsyShook 09-19-02 01:54 AM

theory
 
i've got an idea of why you and i are having this problem. i lack the time to try this out at the moment. but i am going to try in the next 24 hours. i suspect that you and i are lacking PCMCIA support in our kernels because we are on desktop systems and have no need for it, but the NVdriver is a universal driver for graphics cards including ones that are on notebooks and they need the PCMCIA support. so maybe we should try putting that support in our kernels. tell me if that works for you. i'll post my results when they come out. that might take a day or two though.

proza 09-19-02 03:18 AM

Are you upgrading an older NVdriver or installing a fresh new one on a fresh new system ?

Andy Mecham 09-19-02 12:41 PM

The NVdriver module does not depend on PCMCIA support.

w/r/t unresolved symbols - are you sure your kernel sources are configured correctly? How did you compile your kernel?

--andy


All times are GMT -5. The time now is 09:14 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.