nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Need to Reinstall 32 bit support (http://www.nvnews.net/vbulletin/showthread.php?t=181006)

eliwap 05-16-12 05:20 AM

Need to Reinstall 32 bit support
 
1 Attachment(s)
Hi

please find included nvidia-bug-report.log.gz

Currently running:

Nvidia GPU - GTS 450
Fedora 16 x86_64
nvidia driver: 295.49-1 (from rpmfusion - including 32bit library support)

There is a game I'm running under wine and of course, it requires 32bit support. What happens, is that almost everytime that I need to quit the game and then restart it, the game fails to start unless I uninstall and then reinstall the 32bit libraries.

When I run the game from the command line, I get the following error message.

winehq err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr


Please help me to resolve this. This is driving me a little nuts

kwizart 05-16-12 09:22 AM

Re: Need to Reinstall 32 bit support
 
Problem like this might be related to one or another 32bit libraries using rpath or dlopening the wrong libGL library from /usr/lib instead of trusting the system linker that will use /usr/lib/nvidia.

Is there any improvements with only running ldconfig as root instead of yum reinstall xorg-x11-drv-nvidia-libs.I686 ?

In the worst case:
rpm -e mesa-libGL.i686 --nodeps but then it will be missing from RPM dependencies perspective

eliwap 05-17-12 03:46 AM

Re: Need to Reinstall 32 bit support
 
Thanks for your response kwizart and for pointing me to the appropriate locations in the file system.

There is no improvement when running ldconfig as root. I tried that quite some time ago.

I'm sure that you are already aware, when running rpm -e mesa-libGL.i686, I get:

libGL.so.1 is needed by (installed) mesa-libGLU-7.11.2-3.fc16.i686
libGL.so.1 is needed by (installed) wine-core-1.5.4-1.fc16.i686

As a consquence I am reluctant to run this --nodeps as wine may not work at all let alone the difficulties of maintaining the reliability of updates on the computer.

Based on the info you provided, I was thinking of manually recreating the links in /usr/lib/ to point the appropriate file in /usr/lib/nvidia. What do you think?

And if this works, how do we get this fixed?

Thanks again for your help

Eli

eliwap 05-17-12 03:55 PM

Re: Need to Reinstall 32 bit support
 
OK... I tried it, and it didn't work. :(

Any suggestions?


All times are GMT -5. The time now is 04:24 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.