nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   API mismatch (http://www.nvnews.net/vbulletin/showthread.php?t=181171)

Goddard 05-18-12 03:25 AM

API mismatch
 
17/05/12 04:50:49 PM NVRM API mismatch: the client has the version 290.10, but
17/05/12 04:50:49 PM NVRM this kernel module has the version 295.40. Please
17/05/12 04:50:49 PM NVRM make sure that this kernel module and all NVIDIA driver
17/05/12 04:50:49 PM NVRM components have the same version.

I am having difficulties removing 290.10 remnants. It is causing problems viewing things on my desktop. I have tried purging everything I know to remove and uninstalling all Nvidia drivers and still I have a mismatch.

Can some one assit please?

hussam 05-18-12 05:50 AM

Re: API mismatch
 
what distribution? it looks like you have version 290.10 of the nvidia libraries but the 295.40 kernel module loaded. most distributions should provide nvidia driver packages.

Goddard 05-18-12 06:43 PM

Re: API mismatch
 
I fixed this error by installing and uninstalling with the nvidia.run drivers.

The packages for my distribution Ubuntu 12.04 didn't fix this error.

Apprently if you install drivers from nvidia then install the drivers from your distribution at least in ubuntu it will give an API mismatch.

I came from 11.10 so maybe it happened then and 12.04 couldn't repair ... either way that solved my issue.

If you have an API mismatch for me it made my Unity toolbar icons disappear. So if your having that issue check your kernel logs for an API mismatch.


All times are GMT -5. The time now is 10:16 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.