nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GTS240 - Ubuntu 12.04 - nv302.11 - Still crashing (http://www.nvnews.net/vbulletin/showthread.php?t=182323)

thefreecat 05-30-12 11:47 AM

GTS240 - Ubuntu 12.04 - nv302.11 - Still crashing
 
2 Attachment(s)
Hi,
Since I upgraded my ubuntu to 12.04 I face crashes several times a day. 11.10 worked like a charm with absolutely no crash for months.
I have tried version 295.33, 295.40, 295.49, 295.53 and yesterday I installed 302.11 (from xedgers).

Crashes are of various forms :
- session gets closed and I get back to lightdm login (currently I have seen only this crash in 302.11)
- session is hanged : mouse can or can not move (both behaviours may occur). ssh connection and lightdm restart, killing xorg and restarting it don't work. The card does not respond to anything (even Ctrl-Alt-F1)

Watching videos (YouTube) often generates a crash (hw accel is disabled in flash since I experience bad colours bug : red is blue, blue is red, etc.). The crash happens in full screen as well as in firefox's window.

Most of the crashes happen when nothing special happens : writing a mail in thunderbird, working in virtualbox/windows xp/delphi, command-line in a gnome-terminal. I use gnome-shell, not unity.
I guess you will see more of the environment in the logs. The nvidia-report-bug.sh script was run after relogging after the crash.

If I can be of some help, testing workarounds for example, I'd be happy, please let me know.

Thanks for your help,

JC

tkarkkainen 05-30-12 03:56 PM

Re: GTS240 - Ubuntu 12.04 - nv302.11 - Still crashing
 
I'm experiencing very similar problems, and am also using Ubuntu 12.04. My video card is the GTS250, though, and I am using the Unity desktop. Watching Flash videos on sites like Youtube also seem to make the crashes more likely to happen, although this may or may not be an illusion (the greater frequency of crashes, that is, the crashes most certainly are not an illusion).

Relevant part of dmesg output:

Code:

[ 4675.706761] NVRM: Xid (0000:02:00): 6, PE0001
[ 4675.798667] do_general_protection: 27 callbacks suppressed
[ 4675.798671] Xorg[1231] general protection ip:7f23fca590f9 sp:7fffcf6aae30 error:0 in nvidia_drv.so[7f23fc9f7000+6e1000]
[ 5076.372128] NVRM: Xid (0000:02:00): 6, PE0001
[ 5446.207991] NVRM: Xid (0000:02:00): 6, PE0001
[ 5446.301229] Xorg[2736] general protection ip:7f42353ec0f9 sp:7fff03c719b0 error:0 in nvidia_drv.so[7f423538a000+6e1000]
[ 6637.700619] NVRM: Xid (0000:02:00): 6, PE0001
[ 6637.739748] Xorg[3631]: segfault at 68 ip 00007f04889ff0f9 sp 00007fffe6aa1830 error 4 in nvidia_drv.so[7f048899d000+6e1000]
[ 7710.325275] NVRM: Xid (0000:02:00): 6, PE0001
[ 7710.327576] NVRM: Xid (0000:02:00): 56, CMDre 00000007 00000000 ffffffff 00000003 00000000
[ 7710.327608] NVRM: Xid (0000:02:00): 6, PE0002
[ 9869.538257] NVRM: Xid (0000:02:00): 6, PE0001

Output from 'nvidia-smi -q':

Code:

==============NVSMI LOG==============

Timestamp                      : Wed May 30 21:47:04 2012

Driver Version                  : 295.49

Attached GPUs                  : 1

GPU 0000:02:00.0
    Product Name                : GeForce GTS 250
    Display Mode                : N/A
    Persistence Mode            : Disabled
    Driver Model
        Current                : N/A
        Pending                : N/A
    Serial Number              : N/A
    GPU UUID                    : N/A
    VBIOS Version              : 62.92.7D.00.11
    Inforom Version
        OEM Object              : N/A
        ECC Object              : N/A
        Power Management Object : N/A
    PCI
        Bus                    : 0x02
        Device                  : 0x00
        Domain                  : 0x0000
        Device Id              : 0x061510DE
        Bus Id                  : 0000:02:00.0
        Sub System Id          : 0x83051043
        GPU Link Info
            PCIe Generation
                Max            : N/A
                Current        : N/A
            Link Width
                Max            : N/A
                Current        : N/A
    Fan Speed                  : 35 %
    Performance State          : N/A
    Memory Usage
        Total                  : 1023 MB
        Used                    : 197 MB
        Free                    : 825 MB
    Compute Mode                : Default
    Utilization
        Gpu                    : N/A
        Memory                  : N/A
    Ecc Mode
        Current                : N/A
        Pending                : N/A
    ECC Errors
        Volatile
            Single Bit           
                Device Memory  : N/A
                Register File  : N/A
                L1 Cache        : N/A
                L2 Cache        : N/A
                Total          : N/A
            Double Bit           
                Device Memory  : N/A
                Register File  : N/A
                L1 Cache        : N/A
                L2 Cache        : N/A
                Total          : N/A
        Aggregate
            Single Bit           
                Device Memory  : N/A
                Register File  : N/A
                L1 Cache        : N/A
                L2 Cache        : N/A
                Total          : N/A
            Double Bit           
                Device Memory  : N/A
                Register File  : N/A
                L1 Cache        : N/A
                L2 Cache        : N/A
                Total          : N/A
    Temperature
        Gpu                    : 38 C
    Power Readings
        Power Management        : N/A
        Power Draw              : N/A
        Power Limit            : N/A
    Clocks
        Graphics                : N/A
        SM                      : N/A
        Memory                  : N/A
    Max Clocks
        Graphics                : N/A
        SM                      : N/A
        Memory                  : N/A
    Compute Processes          : Not Supported

Kernel version is 3.2.0-24 generic x86_64, the one supplied by Ubuntu.

All help is appreciated. Thank you. I am also willing to try things out on my computer, within reason.

thefreecat 06-02-12 07:48 AM

Re: GTS240 - Ubuntu 12.04 - nv302.11 - Still crashing
 
No answer, not even an ACK... That's support.
Switched to the "Nouveau" driver that works very nicely.

bactrimel 09-26-12 09:37 AM

Re: GTS240 - Ubuntu 12.04 - nv302.11 - Still crashing
 
Quote:

Originally Posted by thefreecat (Post 2560843)
No answer, not even an ACK... That's support.
Switched to the "Nouveau" driver that works very nicely.

Without the slightest intention to sound patronizing, I would say that Nouveau has been evolving into a fine driver for any non-hard-core-gaming/non-CUDA usage pattern. Its performance on composite desktops and OpenGL is excellent, even (I dare say, even more so?) using Intel core graphics.

Perhaps something for nVidia to ponder re their future presence on desktop linux...

sandipt 09-28-12 09:46 AM

Re: GTS240 - Ubuntu 12.04 - nv302.11 - Still crashing
 
Did you tested with latest 304 driver? http://www.nvidia.com/object/unix.html


All times are GMT -5. The time now is 06:20 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.