nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Geforce2 driver help (http://www.nvnews.net/vbulletin/showthread.php?t=1825)

doom 09-13-02 08:01 PM

Geforce2 driver help
 
ok...
I recently got redhat 7.3 distro and tried to download the linux drivers for my geforce 2 mx400 off the nvidia site. My friend who happens to have been using linux since 94' sent me this file to overwrite in the kernel. When i rebooted my system i saw two Operating systems pop up in the dual boot screen. i tried both of them, logged into my account and i only hade the linux shell. I had lost the gui somehow, so then i went back to win2k. Now a week later im back on redhat and want your help on which drivers i should get. here are some of my system specs just incase:
1.8p4
256rdram
40gighd
geforce2mx400
sorry kinda in a hurry, if u need anymore info on my system just reply, i would really appreciate someone's help.

Andy Mecham 09-13-02 08:11 PM

Please download and run NVchooser.sh from the driver page. It will tell you which files you should use.

--andy

doom 09-13-02 08:17 PM

how is this spose to help?
I do have the two files that i needed to download, i just havent extracted them yet.

Here are the files i already have, just tell me if it is safe to extract them.

NVIDIA_GLX-1.0-3123.i386.rpm
NVIDIA_kernel-1.0-3123.rh73up_2.4.18_10.i386.rpm

Andy Mecham 09-13-02 08:23 PM

Your comment
Quote:

Now a week later im back on redhat and want your help on which drivers i should get.
lead me to believe you didn't know what files to download. What problem are you running into? Have you looked at the installation instructions in the README?

--andy

Andy Mecham 09-13-02 08:25 PM

Quote:

Here are the files i already have, just tell me if it is safe to extract them.
If that's what NVchooser.sh recommended, then those are the files you should install. The GLX package is fine; not knowing which kernel arch you have installed, I can't tell you if the kernel package is correct.

--andy

doom 09-13-02 08:26 PM

what would u recommend i should do??

...btw how do i check which kernel arch i have on already, before i install these files.

Andy Mecham 09-13-02 08:36 PM

Quote:

...btw how do i check which kernel arch i have on already, before i install these files.
You can check arch a number of ways - 'uname -a' is the easiest. If you (or your distro) installed the kernel via RPM, you can try 'rpm -q --qf %{ARCH} kernel'. In any case, you should download and run NVchooser.sh to verify you have the right files.

Please make sure you've read and understand the README's installation instructions before installing.

--andy

doom 09-13-02 08:39 PM

its
Redhat 7.3
2.4.18-3
i686
does this mean i have downloaded the wrong files?

Andy Mecham 09-13-02 08:43 PM

Probably. Download and run NVchooser.sh (from http://www.nvidia.com/view.asp?IO=li...splay_1.0-3123) to determine the correct files.

--andy

doom 09-13-02 08:45 PM

well the NVchooser helped somewhat

doom 09-13-02 08:48 PM

which glx driver should i get??
GLX RPM NVIDIA_GLX-1.0-3123.i386.rpm??

and if so will it work with
NVIDIA_kernel-1.0-3123.rh73up_2.4.18_10.i686.rpm
file??

Andy Mecham 09-13-02 08:54 PM

Yes.

From the README:

"The NVIDIA_GLX rpm, however, is not dependent upon the kernel version".

--andy


All times are GMT -5. The time now is 11:57 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.